]> git.pld-linux.org Git - packages/arts.git/blobdiff - arts.spec
- oops - fixed release
[packages/arts.git] / arts.spec
index fcdb4a392e5fbf8b589ec20224f13500226c4de3..40dba452066cb7c16f1b8e4b9dbe64032bf7ebe3 100644 (file)
--- a/arts.spec
+++ b/arts.spec
@@ -1,38 +1,42 @@
-# _without_alsa - disable alsa
-
-%define                _state          stable
-%define                _kdever         3.1
-
+#
+# _with_nas            - enable NAS audio support
+# _without_alsa                - disable ALSA support
+#
+%ifarch sparc sparcv9 sparc64
+%define                _without_alsa   1
+%endif
 Summary:       aRts sound server
 Summary(pl):   Serwer d¼wiêku
 Summary(pt_BR):        Servidor de sons usado pelo KDE
 Name:          arts
-Version:       1.1
-Release:       5
+Version:       1.1.4
+Release:       1
 Epoch:         12
 License:       LGPL
 Vendor:                The KDE Team
 Group:         Libraries
-Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{version}.tar.bz2
-%ifnarch sparc sparcv9 sparc64
+Source0:       ftp://ftp.kde.org/pub/kde/stable/3.1.4/src/%{name}-%{version}.tar.bz2
+# Source0-md5: aa4bef1e80cd3795e3fd832471e348e9
+URL:           http://www.kde.org/
 %{!?_without_alsa:BuildRequires:       alsa-lib-devel}
-%endif
 BuildRequires: audiofile-devel
+BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: glib2-devel >= 2.0.0
 BuildRequires: libjpeg-devel
+BuildRequires: mad-devel
 BuildRequires: libpng-devel
-# not needed, only ./configure check for this
-#BuildRequires:        libvorbis-devel
-#BuildRequires:        mad-devel
+BuildRequires: libstdc++-devel
+BuildRequires: libtool >= 2:1.5-2
+BuildRequires: libvorbis-devel
+%{?_with_nas:BuildRequires:    nas-devel}
 BuildRequires: pkgconfig
 BuildRequires: qt-devel >= 3.1
-URL:           http://www.kde.org/
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _prefix         /usr/X11R6
 %define                _htmldir        /usr/share/doc/kde/HTML
 
-%define                no_install_post_chrpath         1
-
 %description
 aRts sound server.
 
@@ -53,6 +57,7 @@ outros.
 Summary:       X11 dependent part of aRts
 Summary(pl):   Czê¶æ aRts wymagaj±ca X11
 Group:         X11/Libraries
+Requires:      %{name} = %{epoch}:%{version}
 
 %description X11
 X11 dependent part of aRts.
@@ -64,7 +69,7 @@ Cz
 Summary:       QT dependend part of aRts
 Summary(pl):   Czê¶æ aRts wymagaj±ca QT
 Group:         X11/Libraries
-Requires:      %{name} >= %{version}
+Requires:      %{name} = %{epoch}:%{version}
 Requires:      qt >= 3.1
 
 %description qt
@@ -79,7 +84,8 @@ Summary(pl):  Serwer d
 Summary(pt_BR):        Arquivos para desenvolvimento com o o aRts
 Group:         Development/Libraries
 Requires:      qt-devel >= 3.1
-Requires:      %{name} >= %{version}
+Requires:      %{name} = %{epoch}:%{version}
+%{?_with_nas:Requires: nas-devel}
 
 %description devel
 Header files required to compile programs using arts.
@@ -94,7 +100,8 @@ Arquivos para desenvolvimento com o o aRts.
 %package glib
 Summary:       GLib dependend part of aRts
 Summary(pl):   Czê¶æ aRts wymagaj±ca GLib
-Group:         X11/Libraries
+Group:         Libraries
+Requires:      %{name} = %{epoch}:%{version}
 Requires:      glib >= 1.2.6
 
 %description glib
@@ -107,37 +114,51 @@ Cz
 %setup -q
 
 %build
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+%{__perl} admin/am_edit
+
 kde_htmldir="%{_htmldir}"; export kde_htmldir
 kde_icondir="%{_pixmapsdir}"; export kde_icondir
-
 %configure \
        --%{?debug:en}%{!?debug:dis}able-debug \
+       --disable-rpath \
        --enable-final \
        --with-xinerama \
        --with%{?_without_alsa:out}-alsa
 
-
+%if %{!?_with_nas:1}0
+# Cannot patch configure.in because it does not rebuild correctly on ac25
+sed -e 's@#define HAVE_LIBAUDIONAS 1@/* #undef HAVE_LIBAUDIONAS */@' \
+       < config.h \
+       > config.h.tmp
+mv -f config.h{.tmp,}
+%endif
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%clean
+rm -rf $RPM_BUILD_ROOT
 
-%post X11   -p /sbin/ldconfig
-%postun X11 -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
-%post qt   -p /sbin/ldconfig
-%postun qt -p /sbin/ldconfig
+%post  X11 -p /sbin/ldconfig
+%postun        X11 -p /sbin/ldconfig
 
-%post glib   -p /sbin/ldconfig
-%postun glib -p /sbin/ldconfig
+%post  qt -p /sbin/ldconfig
+%postun        qt -p /sbin/ldconfig
 
-%clean
-rm -rf $RPM_BUILD_ROOT
+%post  glib -p /sbin/ldconfig
+%postun        glib -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
@@ -149,29 +170,56 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/artsshell
 %attr(755,root,root) %{_bindir}/artswrapper
 %attr(755,root,root) %{_bindir}/testdhandle
-%{_libdir}/lib[!gqx]*.la
-%attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*
+# shared libraries
+%attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
+%attr(755,root,root) %{_libdir}/libartsflow*.so.*.*.*
+%attr(755,root,root) %{_libdir}/libkmedia2*.so.*.*.*
+%attr(755,root,root) %{_libdir}/libmcop*.so.*.*.*
+%attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
+# lt_dlopened modules (*.la needed)
+%attr(755,root,root) %{_libdir}/libarts*playobject.so.*.*.*
+%{_libdir}/libarts*playobject.la
+%attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
+%{_libdir}/libartscbackend.la
+%attr(755,root,root) %{_libdir}/libartsdsp*.so.*.*.*
+%{_libdir}/libartsdsp*.la
 %{_libdir}/mcop
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/artsc-config
 %attr(755,root,root) %{_bindir}/mcopidl
-%{_libdir}/*.so
+%attr(755,root,root) %{_libdir}/libartsc.so
+%attr(755,root,root) %{_libdir}/libartsflow*.so
+%attr(755,root,root) %{_libdir}/libkmedia2*.so
+%attr(755,root,root) %{_libdir}/libmcop*.so
+%attr(755,root,root) %{_libdir}/libsoundserver_idl.so
+%attr(755,root,root) %{_libdir}/libgmcop.so
+%attr(755,root,root) %{_libdir}/libqtmcop.so
+# some apps (incorrectly?) link with libarts*playobject (gg with -lartswavplayobject only?)
+%attr(755,root,root) %{_libdir}/libarts*playobject.so
+%{_libdir}/libartsc.la
+%{_libdir}/libartsflow*.la
+%{_libdir}/libkmedia2*.la
+%{_libdir}/libmcop*.la
+%{_libdir}/libsoundserver_idl.la
+%{_libdir}/libgmcop.la
+%{_libdir}/libqtmcop.la
 %{_includedir}/arts
 %{_includedir}/artsc
 
 %files X11
 %defattr(644,root,root,755)
+# lt_dlopened module (.la needed)
+%attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
 %{_libdir}/libx11globalcomm.la
-%attr(755,root,root) %{_libdir}/libx11globalcomm.so.*
 
 %files glib
 %defattr(644,root,root,755)
-%{_libdir}/libgmcop.la
-%attr(755,root,root) %{_libdir}/libgmcop.so.*
+# shared library
+%attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
 
 %files qt
 %defattr(644,root,root,755)
-%{_libdir}/libqtmcop.la
-%attr(755,root,root) %{_libdir}/libqtmcop.so.*
+# shared library
+%attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
This page took 0.048356 seconds and 4 git commands to generate.