]> git.pld-linux.org Git - packages/apport.git/blame - apport.spec
- initial release
[packages/apport.git] / apport.spec
CommitLineData
7ce35e5c
PZ
1Summary: Read, write, and modify problem reports
2Name: apport
3Version: 0.102
4Release: 1
5License: GPL
6Group: Applications/System
7Source0: %{name}_%{version}.tar.gz
8# Source0-md5: db81f86c0e71b0d80ba3eac5819bc4fa
9Source1: %{name}.init
10URL: https://wiki.ubuntu.com/Apport
11BuildRequires: gettext
12BuildRequires: intltool
13BuildRequires: python-devel >= 1:2.5
14#BuildRequires: tetex-format-pdflatex
15#BuildRequires: tetex-latex
16# Need the ability to use pipes in /proc/sys/kernel/core_pattern
17# seems only 2.6.24 allows command line params
18Requires: uname(release) >= 2.6.24
19Requires(post,preun): /sbin/chkconfig
20Requires(post,preun): /sbin/service
21Requires(post,postun): hicolor-icon-theme
22Requires(post,postun): shared-mime-info
23Requires: python-rpm
24Requires: yum
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29apport automatically collects data from crashed processes and compiles
30a problem report in /var/crash/.
31
32This package also provides apport's python libraries and a command
33line frontend for browsing and handling the crash reports.
34
35See https://wiki.ubuntu.com/AutomatedProblemReports for more
36information.
37
38%package gtk
39Summary: GTK frontend for the apport crash report system
40Group: Applications/System
41Requires: procps
42Requires: python-pygtk-gtk
43Requires: python-pygtk-glade
44Requires: python-pyxdg
45
46%description gtk
47apport automatically collects data from crashed processes and compiles
48a problem report in /var/crash/.
49
50This package provides a GTK frontend for browsing and handling the
51crash reports.
52
53%package qt
54Summary: Qt4 frontend for the apport crash report system
55Group: Applications/System
56Requires: procps
57Requires: python-PyQT
58Requires: python-pyxdg
59
60%description qt
61apport automatically collects data from crashed processes and compiles
62a problem report in /var/crash/.
63
64This package provides a Qt4 frontend for browsing and handling the
65crash reports.
66
67%package retrace
68Summary: Tools for reprocessing Apport crash reports
69Group: Applications/System
70
71%description retrace
72apport-retrace recombines an Apport crash report (either a file or a
73Launchpad bug) and debug symbol packages (.ddebs) into fully symbolic
74stack traces.
75
76This package also ships apport-chroot. This tool can create and manage
77chroots for usage with apport-retrace. If the fakeroot and fakechroot
78libraries are available (either by installing the packages or by
79merely putting their libraries somewhere and setting two environment
80variables), the entire process of retracing crashes in chroots can
81happen with normal user privileges.
82
83%prep
84%setup -q -n ubuntu
85
86%build
87python setup.py build
88%{__make} -C po
89%{__make} -C gtk
90%{__make} -C qt4
91#%{__make} -C doc
92# set up the packaging backend
93cp backends/packaging_rpm.py backends/packaging_fedora.py apport
94ln -s packaging_fedora.py apport/packaging_impl.py
95
96%install
97rm -rf $RPM_BUILD_ROOT
98python setup.py install \
99 --optimize=2 \
100 --root=$RPM_BUILD_ROOT \
101 --install-scripts %{_datadir}/apport
102
103%py_postclean
104
105# Do the man pages
106install -d $RPM_BUILD_ROOT%{_mandir}/man1
107install man/apport-*.1 $RPM_BUILD_ROOT%{_mandir}/man1
108# cron job
109install -d $RPM_BUILD_ROOT/etc/cron.daily
110install debian/apport.cron.daily $RPM_BUILD_ROOT/etc/cron.daily/apport
111# create the dir for crash reports
112install -d $RPM_BUILD_ROOT/var/crash
113# install initscript
114install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
115install %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/apport
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post
121# Add proper symlinks in %{_sysconfdir}/rc*.d
122/sbin/chkconfig --add apport
123%update_mime_database
124%update_icon_cache hicolor
125
126%preun
127if [ "$1" == "0" ]; then
128 %service apport stop > /dev/null
129 /sbin/chkconfig --del apport
130fi
131
132%postun
133if [ "$1" -ge "1" ]; then
134 %service apport condrestart > /dev/null || :
135fi
136%update_mime_database
137%update_icon_cache hicolor
138
139%files
140%defattr(644,root,root,755)
141%dir /var/crash
142%{_mandir}/man1/*
143%{_iconsdir}/hicolor/*/apps/apport.svg
144%{_datadir}/mime/packages/apport.xml
145%{py_sitescriptdir}/apport-0.0.0-py*.egg-info
146%dir %{_datadir}/apport
147%attr(755,root,root) %{_datadir}/apport/apport
148%attr(755,root,root) %{_datadir}/apport/apport-cli
149%attr(755,root,root) %{_datadir}/apport/gcc_ice_hook
150%attr(755,root,root) %{_datadir}/apport/apport-checkreports
151%attr(755,root,root) %{_datadir}/apport/package_hook
152%attr(755,root,root) %{_datadir}/apport/kernel_hook
153%attr(755,root,root) %{_datadir}/apport/apport-unpack
154%attr(755,root,root) %{_datadir}/apport/testsuite/
155%dir %{_datadir}/apport/general-hooks/
156%attr(755,root,root) %{_datadir}/apport/general-hooks/*.py
157%dir %{_datadir}/apport/package-hooks/
158%attr(755,root,root) %{_datadir}/apport/package-hooks/*.py
159%{py_sitescriptdir}/apport_python_hook.py[co]
160%{py_sitescriptdir}/problem_report*.py[co]
161%dir %{py_sitescriptdir}/apport
162%{py_sitescriptdir}/apport/*.py[co]
163%dir %{py_sitescriptdir}/apport/crashdb_impl
164%{py_sitescriptdir}/apport/crashdb_impl/*.py[co]
165%{_sysconfdir}/cron.daily/apport
166%attr(754,root,root) %{_sysconfdir}/rc.d/init.d/apport
167%dir %{_sysconfdir}/apport
168%config %{_sysconfdir}/apport/crashdb.conf
169%{_sysconfdir}/apport/blacklist.d
170
171%files gtk
172%defattr(644,root,root,755)
173%attr(755,root,root) %{_datadir}/apport/apport-gtk
174%{_datadir}/apport/apport-gtk.glade
175
176%files qt
177%defattr(644,root,root,755)
178%attr(755,root,root) %{_datadir}/apport/apport-qt
179%{_datadir}/apport/*.ui
180
181%files retrace
182%defattr(644,root,root,755)
183%{_mandir}/man1/apport-retrace.1*
184%attr(755,root,root) %{_datadir}/apport/apport-retrace
185%attr(755,root,root) %{_datadir}/apport/apport-chroot
186%attr(755,root,root) %{_datadir}/apport/dupdb-admin
This page took 0.122981 seconds and 4 git commands to generate.