]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blame_incremental - apache-mod_auth_mysql.spec
- use http://ftp.debian.org/ url
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
... / ...
CommitLineData
1%define mod_name auth_mysql
2%define apxs /usr/sbin/apxs
3Summary: This is the MySQL authentication module for Apache
4Summary(cs.UTF-8): Základní autentizace pro WWW server Apache pomocí MySQL
5Summary(da.UTF-8): Autenticering for webtjeneren Apache fra en MySQL-database
6Summary(de.UTF-8): Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7Summary(es.UTF-8): Autenticación vía MySQL para Apache
8Summary(fr.UTF-8): Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9Summary(it.UTF-8): Autenticazione di base per il server Web Apache mediante un database MySQL
10Summary(ja.UTF-8): MySQL データベースを使った Apache Web サーバーへの基本認証
11Summary(nb.UTF-8): Autentisering for webtjeneren Apache fra en MySQL-database
12Summary(pl.UTF-8): Moduł uwierzytelnienia MySQL dla Apache
13Summary(pt_BR.UTF-8): Autenticação via MySQL para o Apache
14Summary(sv.UTF-8): Grundläggande autenticering för webbservern Apache med en MySQL-databas
15Name: apache-mod_%{mod_name}
16Version: 4.3.9
17Release: 0.2
18License: GPL
19Group: Networking/Daemons/HTTP
20Source0: http://ftp.debian.org/debian/pool/main/liba/libapache-mod-auth-mysql/libapache-mod-auth-mysql_%{version}.orig.tar.gz
21# Source0-md5: 9c1ecbe5fb64d4c93444311ff34bfe35
22Patch0: %{name}-ac.patch
23# Needs review:
24# https://rhn.redhat.com/errata/RHSA-2009-0259.html
25BuildRequires: security(CVE-2008-2384)
26BuildRequires: %{apxs}
27BuildRequires: apache-devel >= 2.0.0
28BuildRequires: apr-util >= 1:1.0
29BuildRequires: autoconf
30BuildRequires: automake
31BuildRequires: libtool
32BuildRequires: mysql-devel
33BuildRequires: rpmbuild(macros) >= 1.268
34Requires: apache(modules-api) = %apache_modules_api
35Requires: apache-mod_auth
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
39%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
40
41%description
42This is an authentication module for Apache that allows you to
43authenticate HTTP clients using MySQL RDBMS.
44
45%description -l cs.UTF-8
46Balíček mod_auth_mysql slouží pro omezení přístupu k dokumentům, které
47poskytuje WWW server Apache. Jména a hesla jsou uložena v databázi
48MySQL.
49
50%description -l de.UTF-8
51mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
52Web- Server bediente Dokumente zu beschränken, indem es die Daten in
53einer MySQL-Datenbank prüft.
54
55%description -l es.UTF-8
56mod_auth_mysql puede usarse para limitar el acceso a documentos
57servidos por un servidor web verificando datos en una base de datos
58MySQL.
59
60%description -l fr.UTF-8
61mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
62servis par un serveur Web en vérifiant les données dans une base de
63données MySQL.
64
65%description -l it.UTF-8
66mod_auth_mysql può essere usato per limitare l'accesso a documenti
67serviti da un server Web controllando i dati in un database MySQL.
68
69%description -l ja.UTF-8
70mod_auth_mysql は、MySQL データベースのデータをチェックすること
71によって、Web サーバーが提供するドキュメントへのアクセスを制限すること
72ができます。
73
74%description -l pl.UTF-8
75To jest moduł uwierzytelnienia dla Apache pozwalający na
76uwierzytelnianie klientów HTTP z użyciem bazy danych MySQL.
77
78%description -l pt_BR.UTF-8
79Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
80MySQL.
81
82%description -l sv.UTF-8
83mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
84servade av en webbserver genom att kontrollera data i en
85MySQL-databas.
86
87%prep
88%setup -q -n mod-auth-mysql-%{version}
89%patch0 -p1
90
91%build
92%{__aclocal}
93%{__autoconf}
94%configure \
95 --disable-static \
96 --disable-apache13 \
97 --enable-apache2 \
98 --with-apxs2=%{apxs} \
99 --with-mysql=%{_prefix}
100%{__make}
101
102%install
103rm -rf $RPM_BUILD_ROOT
104install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
105
106libtool install apache2_mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
107rm -f $RPM_BUILD_ROOT%{_pkglibdir}/*.{l,}a
108
109echo 'LoadModule %{mod_name}_module modules/apache2_mod_%{mod_name}.so' > \
110 $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post
116%service -q httpd restart
117
118%postun
119if [ "$1" = "0" ]; then
120 %service -q httpd restart
121fi
122
123%files
124%defattr(644,root,root,755)
125%doc DIRECTIVES USAGE
126%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
127%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.625895 seconds and 4 git commands to generate.