]> git.pld-linux.org Git - packages/LDL.git/blame - LDL.spec
- updated to 2.1.0; switched to SuiteSparse_config
[packages/LDL.git] / LDL.spec
CommitLineData
becce9b4
JB
1Summary: LDL: a simple LDL^T factorization for sparse matrices
2Summary(pl.UTF-8): LDL - prosty rozkład LDL^T dla macierzy rzadkich
3Name: LDL
89178688 4Version: 2.1.0
becce9b4
JB
5Release: 1
6License: LGPL v2.1+
7Group: Libraries
8Source0: http://www.cise.ufl.edu/research/sparse/ldl/%{name}-%{version}.tar.gz
89178688 9# Source0-md5: 654e7b8a45a123b7cab7182dd01a2dc9
becce9b4
JB
10Patch0: %{name}-ufconfig.patch
11Patch1: %{name}-shared.patch
12URL: http://www.cise.ufl.edu/research/sparse/ldl/
89178688 13BuildRequires: SuiteSparse_config >= 4.0.0
becce9b4
JB
14BuildRequires: libtool >= 2:1.5
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18LDL is a set of concise routines for factorizing symmetric
19positive-definite sparse matrices, with some applicability to
20symmetric indefinite matrices. Its primary purpose is to illustrate
21much of the basic theory of sparse matrix algorithms in as concise a
22code as possible, including an elegant new method of sparse symmetric
23factorization that computes the factorization row-by-row but stores it
24column-by-column. The entire symbolic and numeric factorization
25consists of a total of only 49 lines of code. The package is written
26in C, and includes a MATLAB interface.
27
28%description -l pl.UTF-8
29LDL to zbiór zwięzłych procedur do dokonywania rozkładów
30symetrycznych, dodatnio określonych macierzy rzadkich, z częściową
31możliwością stosowania do macierzy symetrycznych nieokreślonych.
32Główny cel tych procedur to zademonstrowanie dużej części podstawowej
33teorii algorytmów dla macierzy rzadkich w jak najbardziej zwięzłym
34kodzie, w tym eleganckiej nowej metody rozkładu symetrycznych macierzy
35rzadkich, liczącej rozkład wierszami, ale zapisującej go kolumnami.
36Cały rozkład symboliczny i numeryczny składa się z jedynie 49 linii
37kodu. Pakiet został napisany w C i zawiera interfejs dla MATLAB-a.
38
39%package devel
40Summary: Header files for LDL library
41Summary(pl.UTF-8): Pliki nagłówkowe biblioteki LDL
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
89178688 44Requires: SuiteSparse_config >= 4.0.0
becce9b4
JB
45
46%description devel
47Header files for LDL library.
48
49%description devel -l pl.UTF-8
50Pliki nagłówkowe biblioteki LDL.
51
52%package static
53Summary: Static LDL library
54Summary(pl.UTF-8): Statyczna biblioteka LDL
55Group: Development/Libraries
56Requires: %{name}-devel = %{version}-%{release}
57
58%description static
59Static LDL library.
60
61%description static -l pl.UTF-8
62Statyczna biblioteka LDL.
63
64%prep
65%setup -q -n %{name}
66%patch0 -p1
67%patch1 -p1
68
69%build
70%{__make} \
71 CC="%{__cc}" \
72 CFLAGS="%{rpmcflags}" \
73 LDFLAGS="%{rpmldflags}" \
74 libdir=%{_libdir}
75
76%install
77rm -rf $RPM_BUILD_ROOT
78install -d $RPM_BUILD_ROOT%{_includedir}/ldl
79
80%{__make} -C Lib install \
81 DESTDIR=$RPM_BUILD_ROOT \
82 libdir=%{_libdir}
83
84install Include/*.h $RPM_BUILD_ROOT%{_includedir}/ldl
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post -p /sbin/ldconfig
90%postun -p /sbin/ldconfig
91
92%files
93%defattr(644,root,root,755)
94%doc README.txt Doc/ChangeLog
95%attr(755,root,root) %{_libdir}/libldl.so.*.*.*
96%attr(755,root,root) %ghost %{_libdir}/libldl.so.0
97
98%files devel
99%defattr(644,root,root,755)
100%doc Doc/ldl_userguide.pdf
101%attr(755,root,root) %{_libdir}/libldl.so
102%{_libdir}/libldl.la
103%{_includedir}/ldl
104
105%files static
106%defattr(644,root,root,755)
107%{_libdir}/libldl.a
This page took 0.073639 seconds and 4 git commands to generate.