]> git.pld-linux.org Git - packages/FHS.git/blobdiff - FHS.spec
introduce /usr/{,local/}libexec directories
[packages/FHS.git] / FHS.spec
index f6f8c5faba1a97ba7a0331da5124bec61450214b..3291fdd6afe2e7e3db0cdd0b1d75beabf48f8923 100644 (file)
--- a/FHS.spec
+++ b/FHS.spec
@@ -5,14 +5,14 @@
 #   But: root %attr+chown in %post means integrity verification (rpm -V) error.
 #   Maybe use non-root %attr+numeric chown in %post (without setup dependency)? The only disadvantage
 #   seems to be a warning message on install.
-Summary:       Basic FHS %{version} filesystem layout
+Summary:       Basic FHS 3.0 filesystem layout
 Summary(de.UTF-8):     Grundlegende Dateisystemstruktur
 Summary(fr.UTF-8):     Arborescence de base du système de fichiers
-Summary(pl.UTF-8):     Podstawowy układ katalogów systemu Linux zgodny z FHS %{version}
+Summary(pl.UTF-8):     Podstawowy układ katalogów systemu Linux zgodny z FHS 3.0
 Summary(tr.UTF-8):     Temel dosya sistemi yapısı
 Name:          FHS
 Version:       3.0
-Release:       1
+Release:       2
 License:       GPL
 Group:         Base
 URL:           http://refspecs.linuxfoundation.org/fhs.shtml
@@ -48,7 +48,6 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define        no_install_post_compress_modules        1
 
 # we have to use numeric uids/groups. see comment above
-
 %define                gid_uucp        14
 %define                gid_mail        12
 
@@ -84,10 +83,10 @@ install -d \
        $RPM_BUILD_ROOT/etc/{X11,opt} \
        $RPM_BUILD_ROOT/lib/modules \
        $RPM_BUILD_ROOT/{mnt,media,proc,root/tmp,sbin,tmp} \
-       $RPM_BUILD_ROOT/usr/{bin,games,include,lib,sbin,share,src} \
+       $RPM_BUILD_ROOT/usr/{bin,games,include,lib{,exec},sbin,share,src} \
        $RPM_BUILD_ROOT/usr/share/{color/icc,dict,doc,games,info,misc,ppd,tmac,xml} \
        $RPM_BUILD_ROOT/usr/lib/games \
-       $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,sbin,share/{color/icc,doc,info,man},src} \
+       $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib{,exec},sbin,share/{color/icc,doc,info,man},src} \
        $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/{color/icc,misc},local,lock,log,mail,opt,run,spool,tmp,yp}
 
 %if %{with lib64}
@@ -115,10 +114,9 @@ cd $RPM_BUILD_ROOT
 check_filesystem_dirs() {
        RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
        TMPFILE=$(mktemp)
-       find | sed -e 's|^\.||g' -e 's|^$||g' | LC_ALL=C sort > $TMPFILE
+       find | sed -e 's|^\.||g' -e '/^$/d' | LC_ALL=C sort > $TMPFILE
 
-       # find finds also '.', so use option -B for diff
-       if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
+       if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -u $TMPFILE - ; then
                rm -rf $RPM_BUILD_ROOT
        else
                echo -e "\nNot so good, some directories are not included in package\n"
@@ -167,6 +165,7 @@ posix.chown("/var/lock", 0, %{gid_uucp})
 %dir /usr/games
 %dir /usr/include
 %dir /usr/lib
+%dir /usr/libexec
 %dir /usr/lib/games
 %dir /usr/sbin
 %dir /usr/share
@@ -189,6 +188,7 @@ posix.chown("/var/lock", 0, %{gid_uucp})
 %dir /usr/local/games
 %dir /usr/local/include
 %dir /usr/local/lib
+%dir /usr/local/libexec
 %dir /usr/local/sbin
 %dir /usr/local/share
 %dir /usr/local/share/color
This page took 0.048557 seconds and 4 git commands to generate.