]> git.pld-linux.org Git - packages/Atlas-C++.git/blobdiff - Atlas-C++.spec
- tabs in preamle
[packages/Atlas-C++.git] / Atlas-C++.spec
index 63059f4e74a20416f8022f384540786e8c8854bf..174bdbb14b830db6bd800c6ddb90a92e94a71768 100644 (file)
@@ -1,15 +1,22 @@
+# TODO:
+# add tutorial subpackage
 Summary:       C++ reference implementation of the Atlas protocol
-Summary(pl):   Implementacja protoko³u Atlas
+Summary(pl.UTF-8):     Implementacja protokołu Atlas
 Name:          Atlas-C++
-Version:       0.4.4
-Release:       1
+Version:       0.6.0
+Release:       0.2
+Epoch:         1
 License:       LGPL
 Group:         Libraries
-Source0:       ftp://victor.worldforge.org/pub/worldforge/libs/Atlas-C++/%{name}-%{version}.tar.gz
-BuildRequires: autoconf
+Source0:       http://dl.sourceforge.net/worldforge/%{name}-%{version}.tar.bz2
+# Source0-md5: 1343d74747a831f2b7b080a51cb4747a
+Patch0:                %{name}-link.patch
+BuildRequires: autoconf >= 2.50
 BuildRequires: automake
-BuildRequires: libtool
+BuildRequires: bzip2-devel
 BuildRequires: libstdc++-devel
+BuildRequires: libtool >= 2:1.5
+BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -18,17 +25,18 @@ communications layer designed to be used in the WorldForge MMORPG
 gaming system. This library is suitable for linking to either clients
 or servers.
 
-%description -l pl
-Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
-komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
-tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
+%description -l pl.UTF-8
+Atlas-C++ jest implementacją (w języku C++) protokołu Atlas, warstwy
+komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekę
+tę przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
 
 %package devel
 Summary:       Header files for Atlas-C++ development
-Summary(pl):   Pliki nag³ówkowe do biblioteki Atlas-C++
+Summary(pl.UTF-8):     Pliki nagłówkowe do biblioteki Atlas-C++
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      libstdc++-devel
+# libAtlasFilters additionally R: bzip2-devel,zlib-devel
 
 %description devel
 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
@@ -39,19 +47,19 @@ or servers.
 This package contains the header files needed to develop programs that
 use these Atlas-C++
 
-%description devel -l pl
-Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
-komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
-tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
+%description devel -l pl.UTF-8
+Atlas-C++ jest implementacją (w języku C++) protokołu Atlas, warstwy
+komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekę
+tę przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
 
-Pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania programów
-u¿ywaj±cych bibliotek Atlas-C++.
+Pakiet zawiera pliki nagłówkowe niezbędne do kompilowania programów
+używających bibliotek Atlas-C++.
 
 %package static
 Summary:       Static libraries for Atlas-C++ development
-Summary(pl):   Statyczne biblioteki Atlas-C++
+Summary(pl.UTF-8):     Statyczne biblioteki Atlas-C++
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 
 %description static
 Atlas-C++ is the current C++ implementation of the Atlas protocol, a
@@ -61,31 +69,32 @@ or servers.
 
 This package contains the static Atlas-C++ libraries.
 
-%description static -l pl
-Atlas-C++ jest implementacj± (w jêzyku C++) protoko³u Atlas, warstwy
-komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekê
-tê przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
+%description static -l pl.UTF-8
+Atlas-C++ jest implementacją (w języku C++) protokołu Atlas, warstwy
+komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekę
+tę przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
 
 Pakiet zawiera statyczne biblioteki Atlas-C++.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
-aclocal
-autoheader
-libtoolize --automake --copy --force
-automake --add-missing --copy --gnu --force
-autoconf
-%configure
+%{__libtoolize}
+%{__aclocal}
+%{__autoheader}
+%{__autoconf}
+%{__automake}
+%configure \
+       --enable-static
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-
-gzip -9nf AUTHORS ChangeLog NEWS README
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -95,17 +104,17 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%doc AUTHORS ChangeLog NEWS README
+%attr(755,root,root) %{_bindir}/atlas_convert
+%attr(755,root,root) %{_libdir}/libAtlas*.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/atlas-config
-%{_includedir}/Atlas
-%attr(755,root,root) %{_libdir}/lib*.la
-%{_libdir}/lib*.so
-%{_aclocaldir}/atlas.m4
+%attr(755,root,root) %{_libdir}/libAtlas*.so
+%{_libdir}/libAtlas*.la
+%{_includedir}/Atlas*
+%{_pkgconfigdir}/atlascpp*.pc
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libAtlas*.a
This page took 0.056156 seconds and 4 git commands to generate.