]> git.pld-linux.org Git - packages/xemacs.git/blobdiff - xemacs.spec
- up to 21.5.27
[packages/xemacs.git] / xemacs.spec
index e8f1dca2fbcce654aca3972ae6a6b40023cc7c24..6dbe7315d9841f7d1fd64efc5c14674210a4ef5d 100644 (file)
@@ -5,9 +5,9 @@
 %bcond_with    gtk             # GTK+ enabled version
 #
 %define                ver             21.5
-%define                sver            23
+%define                sver            27
 %define                xver            %{ver}-b%{sver}
-%define                basepkgver      1.97
+%define                basepkgver      2.08
 Summary:       The XEmacs -- Emacs: The Next Generation
 Summary(es):   El editor XEmacs
 Summary(ja):   XEmacs ¥¨¥Ç¥£¥¿
@@ -20,10 +20,10 @@ Version:    %{ver}.%{sver}
 Release:       1
 License:       GPL
 Group:         Applications/Editors/Emacs
-Source0:       ftp://ftp.xemacs.org/xemacs/%{name}-%{ver}/%{name}-%{version}.tar.gz
-# Source0-md5: 3a8111472fa7ae47d74374f85f1d0aae
-Source2:       ftp://ftp.xemacs.org/xemacs/packages/%{name}-base-%{basepkgver}-pkg.tar.gz
-# Source2-md5: d51d8afe507a0bb17f08ef211f9f6f5a
+Source0:       http://ftp.xemacs.org/xemacs/xemacs-%{ver}/%{name}-%{version}.tar.gz
+# Source0-md5: c415348d58eb18a9f4ed57d97e2acc62
+Source2:       http://ftp.xemacs.org/xemacs/packages/%{name}-base-%{basepkgver}-pkg.tar.gz
+# Source2-md5: 0cb5bfa17dab40ab16c4e7aec19ce2d4
 Source3:       %{name}.desktop
 Source4:       %{name}.ad-pl
 Source5:       %{name}-default.el
@@ -34,30 +34,30 @@ Patch0:             %{name}-info.patch
 Patch1:                %{name}-fix_ldflafs.patch
 Patch3:                %{name}-no-memory-warnings.patch
 Patch4:                %{name}-dump-paths-lispdir.patch
-Patch5:                xemacs-destdir.patch
-Patch6:                xemacs-do-not-create-backups-in-temp-directories.patch
-Patch7:                xemacs-level3.patch
-Patch8:                xemacs-ptmx.patch
-Patch9:                xemacs-set-locale-to-c-when-not-supported-by-x.patch
-Patch10:       xemacs-vendor.patch
+Patch5:                %{name}-destdir.patch
+Patch6:                %{name}-do-not-create-backups-in-temp-directories.patch
+Patch7:                %{name}-level3.patch
+Patch8:                %{name}-ptmx.patch
+Patch9:                %{name}-set-locale-to-c-when-not-supported-by-x.patch
+Patch10:       %{name}-vendor.patch
 URL:           http://www.xemacs.org/
 # for X11/bitmaps/gray
-BuildRequires: XFree86
-BuildRequires: XFree86-devel
 BuildRequires: automake
+BuildRequires: gpm-devel
+%{?with_gtk:BuildRequires:     gtk+-devel >= 1.2.10}
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel >= 1.0.8
 BuildRequires: libtiff-devel
-BuildRequires: gpm-devel
-%{?with_gtk:BuildRequires:     gtk+-devel >= 1.2.10}
 BuildRequires: motif-devel
 BuildRequires: ncurses-devel >= 5.0
 %{?with_postgresql:BuildRequires:      postgresql-devel >= 7.1}
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
+BuildRequires: xorg-data-xbitmaps
+BuildRequires: xorg-lib-libX11-devel
 BuildRequires: zlib-devel
-Requires:      ctags
 Requires:      %{name}-common = %{version}-%{release}
+Requires:      ctags
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _ulibdir        /usr/lib
@@ -143,8 +143,8 @@ control-h 
 Summary:       Common part of XEmacs distribution
 Summary(pl):   Wspólne czê¶ci XEmacsa
 Group:         Applications/Editors/Emacs
-Provides:      xemacs-base-pkg
 Requires:      emacscommon
+Provides:      xemacs-base-pkg
 
 %description common
 Common files of XEmacs distribution. This package does not contain
@@ -291,7 +291,7 @@ cp lib-src/gnuserv lib-src/gnuserv-nox
        --without-ldap \
        --without-dragndrop \
        --without-msw \
-%if %{without pdump}
+%if !%{with pdump}
        --pdump=no
 %endif
 
@@ -354,7 +354,7 @@ mv -f $RPM_BUILD_ROOT%{_bindir}/xemacs-%{xver} \
        $RPM_BUILD_ROOT%{_bindir}/xemacs
 
 %if %{with pdump}
-install src/xemacs.dmp $RPM_BUILD_ROOT/%{_bindir}
+install src/xemacs.dmp $RPM_BUILD_ROOT%{_bindir}
 %endif
 
 find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{xver}/* -type f -name "ChangeLog*" | xargs gzip -9nf
@@ -368,6 +368,9 @@ install src/xemacs-nox.dmp $RPM_BUILD_ROOT%{_bindir}
 install lib-src/gnuserv-nox $RPM_BUILD_ROOT%{_bindir}
 mv -f $RPM_BUILD_ROOT%{_ulibdir}/%{name}-%{xver}/*-linux*/gnuserv $RPM_BUILD_ROOT%{_bindir}
 
+# remove some .elc files
+find $RPM_BUILD_ROOT -name '_pkg.elc' -exec rm "{}" ";"
+
 # remove .el file if corresponding .elc file exists
 find $RPM_BUILD_ROOT -type f -name "*.el" | while read i; do test ! -f ${i}c || rm -f $i; done
 rm -f $RPM_BUILD_ROOT%{_bindir}/{c,e}tags
@@ -395,7 +398,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/gnuserv
 %attr(755,root,root) %{_bindir}/xemacs
 %if %{with pdump}
-%attr(644,root,root) %{_bindir}/xemacs.dmp
+%{_bindir}/xemacs.dmp
 %endif
 %attr(755,root,root) %{_bindir}/ootags
 %attr(755,root,root) %{_bindir}/ellcc
@@ -407,7 +410,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/%{name}-%{xver}/etc/*.xpm
 %{_appdefsdir}/Emacs
 %lang(pl) %{_appdefsdir}/pl/Emacs
-%{_desktopdir}/*
+%{_desktopdir}/*.desktop
 %{_pixmapsdir}/*
 %{_mandir}/man1/gnuattach.1*
 %{_mandir}/man1/gnuclient.1*
@@ -468,7 +471,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/xemacs-nox
 %if %{with pdump}
-%attr(644,root,root) %{_bindir}/xemacs-nox.dmp
+%{_bindir}/xemacs-nox.dmp
 %endif
 %attr(755,root,root) %{_bindir}/gnuserv-nox
 
This page took 0.03538 seconds and 4 git commands to generate.