]> git.pld-linux.org Git - packages/vim.git/blobdiff - vim.spec
updated to 7.4.436
[packages/vim.git] / vim.spec
index 52e66d2f3e5c6a4004650af8c77df32765057876..01fead61b5535e0d2bd61954ed1803e989571823 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -7,6 +7,7 @@
 %bcond_without gnome           # don't build GNOME-based gvim support
 %bcond_without heavy           # don't build heavy (full-featured GNOME-based gvim/vim)
 %bcond_without gui             # don't build any GUI
+%bcond_without light           # don't build light (minimal, ncurses, but not static)
 %bcond_with    perl            # with Perl interp in vim package
 %bcond_with    python          # with Python interp in vim package
 %bcond_with    ruby            # with Ruby interp in vim package
@@ -27,8 +28,8 @@
 # VCS Commits: https://code.google.com/p/vim/source/browse/
 
 %define                ver             7.4
-%define                patchlevel      192
-%define                rel             2
+%define                patchlevel      436
+%define                rel             1
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
 Summary(es.UTF-8):     Editor visual incrementado
@@ -331,6 +332,20 @@ tartalmazza, amelyben benne van a Perl, Python, Ruby és Tcl támogatás.
 Pakiet ten dostarcza w pełni funkcjonalną wersję Vima, czyli
 zawierającą obsługę skryptów w językach Perl, Python, Ruby oraz Tcl.
 
+%package light
+Summary:       Minimal build of Vim
+Summary(pl.UTF-8):     Minimalna wersja vima
+Group:         Applications/Editors/Vim
+Provides:      vi-editor
+Provides:      vi
+Provides:      vim-editor = %{epoch}:%{version}-%{release}
+
+%description light
+This package provides light featured version of Vim.
+
+%description light -l pl.UTF-8
+Pakiet ten dostarcza minimalną wersję Vima.
+
 %package -n vimx
 Summary:       Vi IMproved - a Vi clone
 Summary(pl.UTF-8):     Vi IMproved - klon edytora Vi
@@ -809,7 +824,7 @@ build() {
                --with-tlib="ncursesw"
 %endif
 
-       %{__make} distclean
+       %{__make} -j1 distclean
        # add common options, can override (disable) if needed with args
        %configure \
                --%{!?with_perl:dis}%{?with_perl:en}able-perlinterp \
@@ -852,6 +867,20 @@ build vim.static \
 LDFLAGS="%{rpmldflags}"
 %endif
 
+%if %{with light}
+build vim.light \
+       --disable-gui \
+       --without-x \
+       --with-features=small \
+       --disable-perlinterp \
+       --disable-pythoninterp \
+       --disable-rubyinterp \
+       --disable-tclinterp \
+       --disable-cscope \
+       --disable-gpm \
+       --disable-nls
+%endif
+
 build vim.ncurses \
        --disable-gui \
        --without-x \
@@ -1021,6 +1050,9 @@ cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_desktopdir}
 install -p src/bin/vim.heavy   $RPM_BUILD_ROOT%{_bindir}
 install -p src/bin/gvim.heavy  $RPM_BUILD_ROOT%{_bindir}
 %endif
+%if %{with light}
+install -p src/bin/vim.light   $RPM_BUILD_ROOT%{_bindir}
+%endif
 
 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
 cp -p runtime/vim48x48.png $RPM_BUILD_ROOT%{_pixmapsdir}/vim.png
@@ -1162,6 +1194,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %dir %{_datadir}/vim
 %dir %{_datadir}/vim/doc
+%verify(not md5 mtime size) %{_datadir}/vim/doc/tags
+%lang(pl) %verify(not md5 mtime size) %{_datadir}/vim/doc/tags-pl
+%verify(not md5 mtime size) %{_datadir}/vim/vimfiles/doc/tags
 
 %dir %{_datadir}/vim/vimfiles
 %dir %{_datadir}/vim/vimfiles/doc
@@ -1180,7 +1215,6 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/vim/vimfiles/plugin
 %dir %{_datadir}/vim/vimfiles/spell
 %dir %{_datadir}/vim/vimfiles/syntax
-%verify(not md5 mtime size) %{_datadir}/vim/vimfiles/doc/tags
 
 %{_datadir}/vim/*.vim
 
@@ -1294,11 +1328,9 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 # English
 %{_datadir}/vim/doc/*.txt.gz
-%verify(not md5 mtime size) %{_datadir}/vim/doc/tags
 
 # Polish
 %lang(pl) %{_datadir}/vim/doc/*.plx.gz
-%lang(pl) %verify(not md5 mtime size) %{_datadir}/vim/doc/tags-pl
 
 %files tutor
 %defattr(644,root,root,755)
@@ -1386,6 +1418,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/vim.heavy
 %endif
 
+%if %{with light}
+%files light
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/vim.light
+%endif
+
 %files spell-en
 %defattr(644,root,root,755)
 %{_datadir}/vim/spell/en.*.*
This page took 0.397992 seconds and 4 git commands to generate.