]> git.pld-linux.org Git - packages/ulogd.git/blobdiff - ulogd.spec
- release 5
[packages/ulogd.git] / ulogd.spec
index 0915aa9d88f42d4fd969e7187b117e90ea6555fe..842c8e0f5651d4f5d2633088c948da5c9ddbcfaa 100644 (file)
 Summary:       ULOGD - the Userspace Logging Daemon for iptables
+Summary(pl.UTF-8):     Demon logujący w trybie użytkownika dla iptables
 Name:          ulogd
-Version:       0.95
-Release:       2
+Version:       1.24
+Release:       5
 License:       GPL
 Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
-Source0:       ftp://ftp.sunbeam.franken.de/pub/netfilter/%{name}-%{version}.tar.gz
+Source0:       ftp://ftp.netfilter.org/pub/ulogd/%{name}-%{version}.tar.bz2
+# Source0-md5: 05b4ed2926b9a22aaeaf642917bbf8ff
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.logrotate
-Source4:       %{name}.conf
-Patch0:                %{name}-DESTDIR.patch
-BuildRequires: sgml-tools
-BuildRequires: sgmls
+Patch0:                %{name}-includes.patch
+Patch1:                %{name}-mysql.patch
+Patch2:                %{name}-BASE.patch
+URL:           http://netfilter.org/projects/ulogd/
+BuildRequires: autoconf
+BuildRequires: libpcap-devel
 BuildRequires: mysql-devel
-#Requires:     kernel >= 2.4.0test9
+BuildRequires: postgresql-devel
+BuildRequires: sqlite3-devel
+BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: sed >= 4.0
+Requires(post):        fileutils
+Requires(post,preun):  /sbin/chkconfig
 Requires:      iptables
-Prereq:                /sbin/chkconfig
+#Requires:     kernel >= 2.4.0test9
+Requires:      rc-scripts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir     /etc
-
 %description
 This packages is intended for passing packets from the kernel to
 userspace to do some logging there. It should work like that:
-
-- Register a target called ULOG with netfilter
+- register a target called ULOG with netfilter
 - if the target is hit:
- - send the packet out using netlink multicast facility
- - return NF_ACCEPT immediately
+  - send the packet out using netlink multicast facility
+  - return NF_ACCEPT immediately.
+
+%description -l pl.UTF-8
+Ten pakiet ma służyć do wysyłania pakietów z jądra do przestrzeni
+użytkownika w celu logowania. Powinien działać tak:
+- zarejestrować w netfilterze cel o nazwie ULOG
+- jeżeli cel został osiągnięty:
+  - wysłać pakiet poprzez netlink
+  - zwrócić natychmiast NF_ACCEPT.
 
 %package mysql
-Summary:       Mysql plugin for ulogd
+Summary:       MySQL plugin for ulogd
+Summary(pl.UTF-8):     Wtyczka MySQL dla ulogd
 Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
-Requires:      mysql
 Obsoletes:     iptables-ulogd-mysql
 
 %description mysql
-mysql plugin for ulogd
+MySQL plugin for ulogd.
+
+%description mysql -l pl.UTF-8
+Wtyczka MySQL dla ulogd.
+
+%package pgsql
+Summary:       PostgreSQL plugin for ulogd
+Summary(pl.UTF-8):     Wtyczka PostgreSQL dla ulogd
+Group:         Networking/Daemons
+
+%description pgsql
+PostgreSQL plugin for ulogd.
+
+%description pgsql -l pl.UTF-8
+Wtyczka PostgreSQL dla ulogd.
+
+%package sqlite
+Summary:       SQLite plugin for ulogd
+Summary(pl.UTF-8):     Wtyczka SQLite dla ulogd
+Group:         Networking/Daemons
+
+%description sqlite
+SQLite plugin for ulogd.
+
+%description sqlite -l pl.UTF-8
+Wtyczka SQLite dla ulogd.
 
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p0
+%patch2 -p0
 
 %build
+%if "%{_lib}" != "lib"
+sed -e 's@lib/@%{_lib}/@g' -i configure.in
+%endif
+
+%{__autoconf}
 %configure \
-       --with-mysql
-%{__make}
+       --with-mysql \
+       --with-pgsql \
+       --with-sqlite3
+%{__make} -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sbindir},/etc/{sysconfig,logrotate.d,rc.d/init.d}} \
+install -d $RPM_BUILD_ROOT{%{_sbindir},/etc/{sysconfig,logrotate.d,rc.d/init.d,ulogd}} \
        $RPM_BUILD_ROOT/var/log
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install -j1 \
+       DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ulogd
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ulogd
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/ulogd
-install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/
-
-gzip -9nf Changes doc/*.{ps,txt,table}
+install -D %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8/%{name}.8
 
 touch $RPM_BUILD_ROOT/var/log/ulogd{,.pktlog}
 
@@ -75,25 +119,46 @@ if [ ! -f /var/log/ulogd ]; then
        touch /var/log/ulogd{,.pktlog}
        chmod 640 /var/log/ulogd{,.pktlog}
 fi
-DESC="ulogd daemon"; %chkconfig_add
+
+/sbin/chkconfig --add ulogd
+%service ulogd restart "ulogd daemon"
 
 %preun
-%chkconfig_del
+if [ "$1" = "0" ]; then
+       %service ulogd stop
+       /sbin/chkconfig --del ulogd
+fi
 
 %files
 %defattr(644,root,root,755)
-%doc Changes.gz doc/*.{ps,txt}.gz
-%attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/ulogd
-%attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) %{_sysconfdir}/ulogd.conf
-%attr(640,root,root) /etc/logrotate.d/ulogd
+%doc Changes doc/*.{ps,txt,html}
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ulogd
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ulogd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/ulogd
+%attr(750,root,root) %dir %{_sysconfdir}/ulogd
 %attr(754,root,root) /etc/rc.d/init.d/ulogd
 
 %attr(755,root,root) %{_sbindir}/*
-%attr(755,root,root) %{_libdir}/ulogd/ulogd_[BLOP]*.so
+%dir %{_libdir}/ulogd
+%attr(755,root,root) %{_libdir}/ulogd/ulogd_[BLO]*.so
+%attr(755,root,root) %{_libdir}/ulogd/ulogd_PCAP*.so
+%attr(755,root,root) %{_libdir}/ulogd/ulogd_PWSNIFF*.so
+%attr(755,root,root) %{_libdir}/ulogd/ulogd_SYSLOG*.so
 
 %attr(640,root,root) %ghost /var/log/*
+%{_mandir}/man?/%{name}.*
 
 %files mysql
 %defattr(644,root,root,755)
 %doc doc/mysql*
 %attr(755,root,root) %{_libdir}/ulogd/ulogd_MYSQL.so
+
+%files pgsql
+%defattr(644,root,root,755)
+%doc doc/pgsql*
+%attr(755,root,root) %{_libdir}/ulogd/ulogd_PGSQL.so
+
+%files sqlite
+%defattr(644,root,root,755)
+%doc doc/sqlite*
+%attr(755,root,root) %{_libdir}/ulogd/ulogd_SQLITE3.so
This page took 0.122718 seconds and 4 git commands to generate.