]> git.pld-linux.org Git - packages/swig.git/blobdiff - swig.spec
- rel 2
[packages/swig.git] / swig.spec
index 1c7a4acf901a2c6f45808465bfc32419d29a0d50..c1fae8af3c42bf73b67061b8cd7de560dec2f054 100644 (file)
--- a/swig.spec
+++ b/swig.spec
@@ -1,33 +1,43 @@
+#
+# Conditional build:
+%bcond_without guile   # disable guile support
+%bcond_without ocaml   # disable ocaml support
+%bcond_without perl    # disable perl support
+%bcond_without php     # disable php support
+%bcond_without ruby    # disable ruby support
+%bcond_without tcl     # disable tcl support
+#
 Summary:       Interface generator for Perl, Tcl, Guile and Python
 Summary(pl):   Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
 Summary(pt_BR):        Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
 Name:          swig
-Version:       1.3.21
+Version:       1.3.29
 Release:       2
 License:       distributable
 Group:         Development/Languages
 Source0:       http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
-# Source0-md5: 88ff5b99be3eafebb8a6e20f4f986c04
+# Source0-md5: 44c6f6d8d724cf7fa4a5109e6f63c9b1
 Patch0:                %{name}-format.patch
 Patch1:                %{name}-php.patch
-Patch2:                %{name}-php-tsrm.patch
-Patch3:                %{name}-php-freearg.patch
-Patch4:                %{name}-php-vdecl.patch
-Patch5:                %{name}-python-lib64.patch
+Patch2:                %{name}-php-freearg.patch
+Patch3:                %{name}-php-vdecl.patch
+Patch4:                %{name}-python25.patch
 URL:           http://www.swig.org/
-Icon:          swig.gif
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: guile-devel
+%{?with_guile:BuildRequires:   guile-devel}
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
-BuildRequires: ocaml
-BuildRequires: perl-devel >= 1:5.6.1
-BuildRequires: php-devel >= 4.1.0
-BuildRequires: php-cgi
-BuildRequires: python-devel >= 2.3.2
-BuildRequires: ruby >= 1.6.3
-BuildRequires: tcl-devel >= 8.3.3
+%{?with_ocaml:BuildRequires:   ocaml}
+%{?with_perl:BuildRequires:    perl-devel >= 1:5.6.1}
+%{?with_php:BuildRequires:     php-cli}
+%{?with_php:BuildRequires:     php-devel >= 4.1.0}
+BuildRequires: python-devel >= 1:2.3.2
+%if %{with ruby}
+BuildRequires: rpmbuild(macros) >= 1.277
+BuildRequires: ruby-devel >= 1:1.6.3
+%endif
+%{?with_tcl:BuildRequires:     tcl-devel >= 8.3.3}
 Obsoletes:     swig-ocaml
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -62,7 +72,7 @@ osobno, ale bez ich wsparcia SWIG nie by
 narzêdziem, ani tak fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
 
 %description -l pt_BR
-O SWIG gera interfaces para perl, python e tcl a partir de uma arquivo
+O SWIG gera interfaces para perl, python e Tcl a partir de uma arquivo
 com uma interface de descrição que consiste de uma combinação de C/C++
 e diretivas especiais. Permite que linguagens tipo script usem C/C++
 com um mínimo de esforço.
@@ -71,6 +81,7 @@ com um m
 Summary:       SWIG library: guile
 Summary(pl):   Biblioteka SWIG: guile
 Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description guile
 SWIG library: guile.
@@ -82,6 +93,7 @@ Biblioteka SWIG: guile.
 Summary:       SWIG library: Perl
 Summary(pl):   Biblioteka SWIG: Perl
 Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description perl
 SWIG library: perl.
@@ -93,6 +105,7 @@ Biblioteka SWIG: perl.
 Summary:       SWIG library: php
 Summary(pl):   Biblioteka SWIG: php
 Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description php
 SWIG library: php.
@@ -104,6 +117,7 @@ Biblioteka SWIG: php.
 Summary:       SWIG library: python
 Summary(pl):   Biblioteka SWIG: python
 Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description python
 SWIG library: python.
@@ -115,6 +129,8 @@ Biblioteka SWIG: python.
 Summary:       SWIG library: ruby
 Summary(pl):   Biblioteka SWIG: ruby
 Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+%{?ruby_mod_ver_requires_eq}
 
 %description ruby
 SWIG library: ruby.
@@ -126,6 +142,7 @@ Biblioteka SWIG: ruby.
 Summary:       SWIG library: tcl
 Summary(pl):   Biblioteka SWIG: tcl
 Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description tcl
 SWIG library: tcl.
@@ -134,30 +151,28 @@ SWIG library: tcl.
 Biblioteka SWIG: tcl.
 
 %prep
-%setup -q -n SWIG-%{version}
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%if "%{_lib}" == "lib64"
-%patch5 -p1
-%endif
 
 %build
 %{__libtoolize}
 %{__aclocal} -I Tools/config
 %{__autoconf}
+%{__automake}
 %configure
 
-%{__make} source runtime \
+%{__make} \
        OPT="%{rpmcflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
 
-%{__make} install install-runtime \
+%{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        M4_INSTALL_DIR=$RPM_BUILD_ROOT%{_aclocaldir}
 
@@ -190,43 +205,46 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc Doc CHANGES NEW README ANNOUNCE TODO LICENSE
-%{_libdir}/%{name}*
 %attr(755,root,root) %{_bindir}/swig
-%{_aclocaldir}/swig.m4
+%{_datadir}/%{name}
+%{?with_guile:%exclude %{_datadir}/%{name}/%{version}/guile}
+%{?with_perl:%exclude %{_datadir}/%{name}/%{version}/perl5}
+%{?with_php:%exclude %{_datadir}/%{name}/%{version}/php4}
+%exclude %{_datadir}/%{name}/%{version}/python
+%{?with_ruby:%exclude %{_datadir}/%{name}/%{version}/ruby}
+%{?with_tcl:%exclude %{_datadir}/%{name}/%{version}/tcl}
 %{_examplesdir}/%{name}-%{version}
 
+%if %{with guile}
 %files guile
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libswigguile*.so.*.*.*
-%attr(755,root,root) %{_libdir}/libswigguile*.so
-%{_libdir}/libswigguile*.la
+%{_datadir}/%{name}/%{version}/guile
+%endif
 
+%if %{with perl}
 %files perl
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libswigpl.so.*.*.*
-%attr(755,root,root) %{_libdir}/libswigpl.so
-%{_libdir}/libswigpl.la
+%{_datadir}/%{name}/%{version}/perl5
+%endif
 
+%if %{with php}
 %files php
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libswigphp4.so.*.*.*
-%attr(755,root,root) %{_libdir}/libswigphp4.so
-%{_libdir}/libswigphp4.la
+%{_datadir}/%{name}/%{version}/php4
+%endif
 
 %files python
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libswigpy.so.*.*.*
-%attr(755,root,root) %{_libdir}/libswigpy.so
-%{_libdir}/libswigpy.la
+%{_datadir}/%{name}/%{version}/python
 
+%if %{with ruby}
 %files ruby
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libswigrb.so.*.*.*
-%attr(755,root,root) %{_libdir}/libswigrb.so
-%{_libdir}/libswigrb.la
+%{_datadir}/%{name}/%{version}/ruby
+%endif
 
+%if %{with tcl}
 %files tcl
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libswigtcl*.so.*.*.*
-%attr(755,root,root) %{_libdir}/libswigtcl*.so
-%{_libdir}/libswigtcl*.la
+%{_datadir}/%{name}/%{version}/tcl
+%endif
This page took 0.075664 seconds and 4 git commands to generate.