]> git.pld-linux.org Git - packages/subversion.git/blobdiff - subversion.spec
- release 6 (by relup.sh)
[packages/subversion.git] / subversion.spec
index 6aad668b9e58d40801030e004ec8f037cdf011fa..398af53b0ff59e2b587be49687a27e95f5e8106b 100644 (file)
@@ -9,8 +9,8 @@
 %bcond_without apache                  # build without Apache support (webdav, etc)
 %bcond_without java                    # build without javahl support (Java high-level bindings)
 %bcond_with    tests                   # don't perform "make check"
-%bcond_without kwallet                 # build without kde4 wallet support
-%bcond_without kde                     # build without kde4 support (alias for kwallet)
+%bcond_without kwallet                 # build without kde5 wallet support
+%bcond_without kde                     # build without kde5 support (alias for kwallet)
 %bcond_without gnome                   # build without gnome keyring support
 %bcond_without db                      # disable Subversion Berkeley DB based filesystem library
 %bcond_with    db6                     # allow BDB6 (not tested by upstream, released on AGPL)
@@ -51,7 +51,7 @@ Summary(pl.UTF-8):    System kontroli wersji podobny, ale lepszy, niż CVS
 Summary(pt_BR.UTF-8):  Sistema de versionamento concorrente
 Name:          subversion
 Version:       1.10.0
-Release:       1
+Release:       6
 License:       Apache v2.0
 Group:         Development/Version Control
 Source0:       http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
@@ -70,6 +70,7 @@ Patch2:               %{name}-ruby-datadir-path.patch
 Patch3:                %{name}-tests.patch
 Patch4:                x32-libdir.patch
 Patch5:                %{name}-rdoc.patch
+Patch6:                with_gnome_keyring_sefault.patch
 URL:           http://subversion.apache.org/
 %{?with_apache:BuildRequires:  apache-devel >= 2.4.14}
 BuildRequires: apr-devel >= 1:1.3
@@ -86,19 +87,24 @@ BuildRequires:      db-devel >= 4.1.25
 BuildRequires: expat-devel
 BuildRequires: gettext-tools
 %{?with_gnome:BuildRequires:   glib2-devel >= 2.0}
-%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
+%{?with_kde:BuildRequires:     kf5-kdelibs4support-devel}
+%{?with_kwallet:BuildRequires: kf5-kwallet-devel}
 %{?with_gnome:BuildRequires:   libgnome-keyring-devel}
+%{?with_gnome:BuildRequires:   libsecret-devel}
 BuildRequires: libmagic-devel
 BuildRequires: libtool >= 1.4-9
+BuildRequires: libutf8proc-devel >= 1.3.1-4
+BuildRequires: lz4-devel
 BuildRequires: pkgconfig
 %{?with_csvn:BuildRequires:    python-ctypesgen}
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.656
 BuildRequires: sed >= 4.0
 BuildRequires: serf-devel >= 1.3.4
-BuildRequires: sqlite3-devel >= 3.7.12
+BuildRequires: sqlite3-devel >= 3.8.11.1
 BuildRequires: texinfo
 BuildRequires: which
+BuildRequires: zlib-devel >= 1.2
 %if %{with java}
 BuildRequires: jdk >= 1.5
 BuildRequires: libstdc++-devel
@@ -178,6 +184,7 @@ Group:              Libraries
 Requires:      apr >= 1:1.3
 Requires:      apr-util >= 1:1.3
 Requires:      serf >= 1.3.4
+Requires:      zlib >= 1.2
 Obsoletes:     libsubversion0
 
 %description libs
@@ -424,17 +431,17 @@ to authenticate using GNOME Keyring.
 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
 
-%package -n kde4-kwallet-subversion
+%package -n kde5-kwallet-subversion
 Summary:       KDE Wallet authentication provider for Subversion
 Summary(pl.UTF-8):     Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
 Group:         X11/Applications
 Requires:      %{name}-libs = %{version}-%{release}
 
-%description -n kde4-kwallet-subversion
+%description -n kde5-kwallet-subversion
 Authentication provider module for Subversion which allows SVN client
 to authenticate using KDE Wallet.
 
-%description -n kde4-kwallet-subversion -l pl.UTF-8
+%description -n kde5-kwallet-subversion -l pl.UTF-8
 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
 uwierzytelniać się przy użyciu Portfela KDE.
 
@@ -446,6 +453,7 @@ uwierzytelniać się przy użyciu Portfela KDE.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p0
 
 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
 
@@ -457,7 +465,6 @@ chmod +x ./autogen.sh && ./autogen.sh
 %{__libtoolize}
 %configure \
        --with-editor=vi \
-       --with-utf8proc=internal \
        --with-zlib=%{_libdir} \
        --disable-runtime-module-search \
        --disable-mod-activation \
@@ -684,8 +691,8 @@ rm -rf $RPM_BUILD_ROOT
 %post  -n gnome-keyring-subversion -p /sbin/ldconfig
 %postun        -n gnome-keyring-subversion -p /sbin/ldconfig
 
-%post  -n kde4-kwallet-subversion -p /sbin/ldconfig
-%postun        -n kde4-kwallet-subversion -p /sbin/ldconfig
+%post  -n kde5-kwallet-subversion -p /sbin/ldconfig
+%postun        -n kde5-kwallet-subversion -p /sbin/ldconfig
 
 %post svnserve
 /sbin/chkconfig --add svnserve
@@ -885,7 +892,7 @@ fi
 %endif
 
 %if %{with kwallet}
-%files -n kde4-kwallet-subversion
+%files -n kde5-kwallet-subversion
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
This page took 0.074654 seconds and 4 git commands to generate.