]> git.pld-linux.org Git - packages/rust.git/blobdiff - rust.spec
up to 1.63.0
[packages/rust.git] / rust.spec
index 1d495f1fe377cfa46fe04127d73f4b909ccdebbf..53249e9e1fd2ba7e6356e81a7ba9f8341f443f40 100644 (file)
--- a/rust.spec
+++ b/rust.spec
@@ -21,9 +21,9 @@
 # To bootstrap from scratch, set the channel and date from src/stage0.json
 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
 # or nightly wants some beta-YYYY-MM-DD
-%define                bootstrap_rust  1.56.1
-%define                bootstrap_cargo 1.56.1
-%define                bootstrap_date  2021-11-01
+%define                bootstrap_rust  1.62.0
+%define                bootstrap_cargo %{bootstrap_rust}
+%define                bootstrap_date  2022-06-30
 
 %ifarch x32
 %define                with_cross      1
 Summary:       The Rust Programming Language
 Summary(pl.UTF-8):     JÄ™zyk programowania Rust
 Name:          rust
-Version:       1.57.0
+Version:       1.63.0
 Release:       1
 # Licenses: (rust itself) and (bundled libraries)
 License:       (Apache v2.0 or MIT) and (BSD and ISC and MIT)
 Group:         Development/Languages
 Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
-# Source0-md5: 0c7d63d9c456c4ec0f95bb6bb729c13e
+# Source0-md5: 8aee73557c576c844c9636128766b1cc
 Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
-# Source1-md5: 9c12561dff9debea38e4b93f881ae2bb
+# Source1-md5: 55015a247c79c07e33010aa5f84ba379
 Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
-# Source2-md5: 947bd95b9c8a9943d43af1bbabf1a8e1
+# Source2-md5: da4968bc99f76ebe69bbb9f6479b7186
 Source3:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
-# Source3-md5: 64d78bc0747c975fe0451e4fd5b8ac4b
+# Source3-md5: 03ba177dc69d8c8545ddd997d5aeb478
 Source4:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
-# Source4-md5: a13652efd627b5e5f8bd278f378acea4
+# Source4-md5: 15b2af8a9ab19cdef7dae36b1654ecb9
 Source5:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
-# Source5-md5: 3fb69008b1b0141d464a4a48317709b3
+# Source5-md5: e4abf4a8d96be76e0aadb2a7e2260e32
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
 BuildRequires: cmake >= 3.4.3
@@ -65,15 +65,16 @@ BuildRequires:      rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.752
 %if %{without cross}
 BuildRequires: curl-devel
-BuildRequires: libgit2-devel >= 1.3.0
+BuildRequires: libgit2-devel >= 1.4.0
 BuildRequires: libstdc++-devel
 %if %{with system_llvm}
-BuildRequires: llvm >= 10.0
-BuildRequires: llvm-devel >= 10.0
+BuildRequires: llvm >= 12.0
+BuildRequires: llvm-devel >= 12.0
 %endif
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
+BuildRequires: xz-devel
 BuildRequires: zlib-devel
 %endif
 %if %{without bootstrap}
@@ -88,25 +89,28 @@ BuildRequires:      glibc-devel(x86-x32)
 # building on x86_64 host with --target x32-pld-linux
 BuildRequires: curl-devel
 BuildRequires: gcc-multilib-x32
-BuildRequires: libgit2-devel >= 1.3.0
+BuildRequires: libgit2-devel >= 1.4.0
 BuildRequires: libstdc++-devel
-%{?with_system_llvm:BuildRequires:     llvm-devel >= 10.0}
+%{?with_system_llvm:BuildRequires:     llvm-devel >= 12.0}
 BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: xz-devel
 BuildRequires: zlib-devel
 %else
 # building x86_64-hosted crosscompiler on x32 host
 BuildRequires: curl-devel(x86-64)
 BuildRequires: curl-devel(x86-x32)
 BuildRequires: gcc-multilib-64
-BuildRequires: libgit2-devel(x86-64) >= 1.3.0
-BuildRequires: libgit2-devel(x86-x32) >= 1.3.0
+BuildRequires: libgit2-devel(x86-64) >= 1.4.0
+BuildRequires: libgit2-devel(x86-x32) >= 1.4.0
 BuildRequires: libstdc++-multilib-64-devel
 %if %{with system_llvm}
-BuildRequires: llvm-devel(x86-64) >= 10.0
-BuildRequires: llvm-devel(x86-x32) >= 10.0
+BuildRequires: llvm-devel(x86-64) >= 12.0
+BuildRequires: llvm-devel(x86-x32) >= 12.0
 %endif
 BuildRequires: openssl-devel(x86-64)
 BuildRequires: openssl-devel(x86-x32)
+BuildRequires: xz-devel(x86-64)
+BuildRequires: xz-devel(x86-x32)
 BuildRequires: zlib-devel(x86-64)
 BuildRequires: zlib-devel(x86-x32)
 %endif
@@ -118,6 +122,7 @@ Requires:   gcc
 Requires:      %{name}-std%{?_isa} = %{version}-%{release}
 %ifarch x32
 Requires:      %{name}-std(x86-64) = %{version}-%{release}
+Requires:      gcc-multilib-64
 %endif
 Obsoletes:     rust-analyzer < 1.53.0
 # Only x86_64 and i686 are Tier 1 platforms at this time.
@@ -143,6 +148,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                rust_triple             armv7-unknown-linux-gnueabihf
 %define                rust_host_triple        %{rust_triple}
 %define                rust_bootstrap_triple   %{rust_triple}
+%define                rust_suppl_targets      thumbv7neon-unknown-linux-gnueabihf
 %else
 %define                rust_triple             %{_target_cpu}-unknown-linux-gnu
 %define                rust_host_triple        %{rust_triple}
@@ -411,7 +417,8 @@ export AR="%{__ar}"
        --enable-vendor \
        --local-rust-root=%{local_rust_root} \
        --llvm-root=%{_prefix} \
-       --release-channel=%{channel}
+       --release-channel=%{channel} \
+       --set=llvm.static-libstdcpp=false
 
 export RUST_BACKTRACE=full
 %x_py dist --verbose
@@ -421,6 +428,9 @@ export RUST_BACKTRACE=full
 %install
 rm -rf $RPM_BUILD_ROOT
 
+export CC="%{__cc}"
+export CXX="%{__cxx}"
+export AR="%{__ar}"
 export DESTDIR=$RPM_BUILD_ROOT
 %x_py install
 
@@ -511,8 +521,6 @@ cat <<EOF
 EOF
 done
 )
-%dir %{rustlibdir}/%{rust_triple}/bin
-%attr(755,root,root) %{rustlibdir}/%{rust_triple}/bin/rust-llvm-dwp
 
 %files debugger-common
 %defattr(644,root,root,755)
This page took 0.052521 seconds and 4 git commands to generate.