]> git.pld-linux.org Git - packages/rust.git/blobdiff - rust.spec
- fixed build
[packages/rust.git] / rust.spec
index 11a2384df97efc9a7da8b714e98bfb132a59cf8b..3625f3f6b86eb5e9be5e9f83ff9d2a9381c705fa 100644 (file)
--- a/rust.spec
+++ b/rust.spec
@@ -3,8 +3,8 @@
 #   This might allow multilib cross-compilation to work naturally.
 #
 # Conditional build:
-%bcond_with    bootstrap
-%bcond_without tests           # build without tests
+%bcond_with    bootstrap       # bootstrap using precompiled binaries
+%bcond_with    tests           # build without tests
 
 # The channel can be stable, beta, or nightly
 %define                channel         stable
 # To bootstrap from scratch, set the channel and date from src/stage0.txt
 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
 # or nightly wants some beta-YYYY-MM-DD
-%define                bootstrap_rust  1.17.0
-%define                bootstrap_cargo 0.18.0
-%define                bootstrap_date  2017-04-27
+%define                bootstrap_rust  1.20.0
+%define                bootstrap_cargo 0.21.0
+%define                bootstrap_date  2017-08-31
 
 Summary:       The Rust Programming Language
+Summary(pl.UTF-8):     Język programowania Rust
 Name:          rust
-Version:       1.18.0
-Release:       0.1
+Version:       1.21.0
+Release:       1
 # Licenses: (rust itself) and (bundled libraries)
-License:       (ASL 2.0 or MIT) and (BSD and ISC and MIT)
+License:       (Apache v2.0 or MIT) and (BSD and ISC and MIT)
 Group:         Development/Languages
 Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
-# Source0-md5: c37c0cd9d500f6a9d1f2f44401351f88
+# Source0-md5: bc494706b764276613064aad52922f53
 Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.gz
-# Source1-md5: 98e8f479515969123b4c203191104a54
+# Source1-md5: 5b63778b4877bcfd431b56c485f4876b
 Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.gz
-# Source2-md5: 2d5de850c32aa8d40c8c21abacf749f8
+# Source2-md5: 5e8c3a6a7b94e6a32f85230111a684a3
+Patch0:                rust-1.21.0-44203-exclude-compiler-rt-test.patch
 URL:           https://www.rust-lang.org/
-BuildRequires: cmake
+# for src/compiler-rt
+BuildRequires: cmake >= 3.4.3
 BuildRequires: curl
-BuildRequires: gcc
-BuildRequires: libstdc++-devel
 BuildRequires: libstdc++-devel
 BuildRequires: llvm-devel
 BuildRequires: ncurses-devel
-BuildRequires: python
+BuildRequires: python >= 1:2.7
 BuildRequires: zlib-devel
 %if %{without bootstrap}
-BuildRequires: %{name} < %{version}-%{release}
 BuildRequires: %{name} >= %{bootstrap_rust}
 BuildRequires: cargo >= %{bootstrap_cargo}
+BuildConflicts:        %{name} > %{version}
 %endif
 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
 BuildRequires: procps
@@ -70,6 +71,13 @@ ExclusiveArch:       %{x8664} %{ix86}
 %define                local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
 %endif
 
+# We're going to override --libdir when configuring to get rustlib into a
+# common path, but we'll fix the shared libraries during install.
+# Without this ugly hack, rust would not be able to buld itself
+# for non-bootstrap build, lib64 is just too complicated for it.
+%define                common_libdir   %{_prefix}/lib
+%define                rustlibdir      %{common_libdir}/rustlib
+
 # once_call/once_callable non-function libstdc++ symbols
 %define                skip_post_check_so      'librustc_llvm-.*\.so.*'
 
@@ -84,17 +92,27 @@ prevents segfaults, and guarantees thread safety.
 This package includes the Rust compiler, standard library, and
 documentation generator.
 
+%description -l pl.UTF-8
+Rust to systemowy język programowania działający bardzo szybko,
+zapobiegający naruszeniom ochrony pamięci i gwarantujący
+bezpieczną wielowątkowość.
+
 %package debugger-common
 Summary:       Common debugger pretty printers for Rust
+Summary(pl.UTF-8):     Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
 Group:         Development/Debuggers
 BuildArch:     noarch
 
 %description debugger-common
-This package includes the common functionality for %{name}-gdb and
-%{name}-lldb.
+This package includes the common functionality for rust-gdb and
+rust-lldb.
+
+%description debugger-common -l pl.UTF-8
+Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
 
 %package gdb
 Summary:       GDB pretty printers for Rust
+Summary(pl.UTF-8):     Ładne wypisywanie struktur Rusta w GDB
 Group:         Development/Debuggers
 Requires:      %{name}-debugger-common = %{version}-%{release}
 Requires:      gdb
@@ -104,20 +122,29 @@ BuildArch:        noarch
 This package includes the rust-gdb script, which allows easier
 debugging of Rust programs.
 
+%description gdb -l pl.UTF-8
+Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
+odpluskwianie programów w języku Rust.
+
 %package lldb
 Summary:       LLDB pretty printers for Rust
+Summary(pl.UTF-8):     Ładne wypisywanie struktur Rusta w LLDB
 Group:         Development/Debuggers
 Requires:      %{name}-debugger-common = %{version}-%{release}
 Requires:      lldb
-Requires:      python-lldb
 BuildArch:     noarch
 
 %description lldb
 This package includes the rust-lldb script, which allows easier
 debugging of Rust programs.
 
+%description lldb -l pl.UTF-8
+Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
+odpluskwianie programów w języku Rust.
+
 %package doc
 Summary:       Documentation for Rust
+Summary(pl.UTF-8):     Dokumentacja do Rusta
 Group:         Documentation
 BuildArch:     noarch
 
@@ -125,8 +152,14 @@ BuildArch: noarch
 This package includes HTML documentation for the Rust programming
 language and its standard library.
 
+%description doc -l pl.UTF-8
+Ten pakiet zawiera dokumentację w formacie HTML do języka
+programowania Rust i jego biblioteki standardowej.
+
 %prep
 %setup -q -n %{rustc_package}
+%patch0 -p1
+
 %if %{with bootstrap}
 %ifarch %{x8664}
 tar xf %{SOURCE1}
@@ -144,8 +177,9 @@ test -f %{local_rust_root}/bin/rustc
 %endif
 
 # unbundle
-rm -r src/jemalloc/
-rm -r src/llvm/
+# We're disabling jemalloc, but rust-src still wants it.
+#%{__rm} -r src/jemalloc/
+%{__rm} -r src/llvm/
 
 # extract bundled licenses for packaging
 cp -p src/rt/hoedown/LICENSE src/rt/hoedown/LICENSE-hoedown
@@ -156,32 +190,29 @@ sed -e '/*\//q' src/libbacktrace/backtrace.h \
 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
        src/etc/rust-gdb
 
-# These tests assume that alloc_jemalloc is present
-sed -i -e '1i // ignore-test jemalloc is disabled' \
-       src/test/compile-fail/allocator-dylib-is-system.rs \
-       src/test/compile-fail/allocator-rust-dylib-is-jemalloc.rs \
-       src/test/run-pass/allocator-default.rs
-
-# Fedora's LLVM doesn't support any mips targets -- see "llc -version".
-# Fixed properly by Rust PR36344, which should be released in 1.13.
-sed -i -e '/target=mips/,+1s/^/# unsupported /' \
-       src/test/run-make/atomic-lock-free/Makefile
-
-%if %{without bootstrap}
-# The hardcoded stage0 "lib" is inappropriate when using Fedora's own rustc
-sed -i -e '/^HLIB_RELATIVE/s/lib$/$$(CFG_LIBDIR_RELATIVE)/' mk/main.mk
-%endif
+# The configure macro will modify some autoconf-related files, which upsets
+# cargo when it tries to verify checksums in those files.  If we just truncate
+# that file list, cargo won't have anything to complain about.
+find src/vendor -name .cargo-checksum.json \
+       -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
 
 %build
 %configure \
-       --disable-option-checking \
-       --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
-       --enable-local-rust --local-rust-root=%{local_rust_root} \
-       --llvm-root=%{_prefix} --disable-codegen-tests \
+       --build=%{rust_triple} \
+       --host=%{rust_triple} \
+       --target=%{rust_triple} \
+       --libdir=%{common_libdir} \
+       --disable-codegen-tests \
        --disable-jemalloc \
+       --disable-option-checking \
        --disable-rpath \
+       --disable-debuginfo-lines \
+       --disable-debuginfo-only-std \
        --enable-debuginfo \
+       --enable-llvm-link-shared \
+       --enable-local-rust --local-rust-root=%{local_rust_root} \
        --enable-vendor \
+       --llvm-root=%{_prefix} \
        --release-channel=%{channel}
 
 ./x.py dist
@@ -193,27 +224,34 @@ rm -rf $RPM_BUILD_ROOT
 
 DESTDIR=$RPM_BUILD_ROOT ./x.py dist --install
 
+# Make sure the shared libraries are in the proper libdir
+%if "%{_libdir}" != "%{common_libdir}"
+mkdir -p %{buildroot}%{_libdir}
+find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
+       -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
+%endif
+
 # The shared libraries should be executable for debuginfo extraction.
 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
 
 # The libdir libraries are identical to those under rustlib/.  It's easier on
 # library loading if we keep them in libdir, but we do need them in rustlib/
 # to support dynamic linking for compiler plugins, so we'll symlink.
-(cd "$RPM_BUILD_ROOT%{_libdir}/rustlib/%{rust_triple}/lib" &&
+(cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
        find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
        -exec ln -v -f -s -t . '{}' '+')
 
 # Remove installer artifacts (manifests, uninstall scripts, etc.)
-find $RPM_BUILD_ROOT%{_libdir}/rustlib/ -maxdepth 1 -type f -exec rm -v '{}' '+'
+find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
 
 # FIXME: __os_install_post will strip the rlibs
 # -- should we find a way to preserve debuginfo?
 
 # Remove unwanted documentation files (we already package them)
-rm $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
-rm $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
-rm $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
-rm $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
 
 # Sanitize the HTML documentation
 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
@@ -221,7 +259,7 @@ find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
 
 # Move rust-gdb's python scripts so they're noarch
 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
-mv -v $RPM_BUILD_ROOT%{_libdir}/rustlib%{_sysconfdir} $RPM_BUILD_ROOT%{_datadir}/%{name}/
+%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -231,17 +269,32 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT
-%doc src/libbacktrace/LICENSE-libbacktrace
-%doc src/rt/hoedown/LICENSE-hoedown
-%doc README.md
+%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md src/libbacktrace/LICENSE-libbacktrace src/rt/hoedown/LICENSE-hoedown
 %attr(755,root,root) %{_bindir}/rustc
 %attr(755,root,root) %{_bindir}/rustdoc
+%attr(755,root,root) %{_libdir}/libarena-*.so
+%attr(755,root,root) %{_libdir}/libflate-*.so
+%attr(755,root,root) %{_libdir}/libfmt_macros-*.so
+%attr(755,root,root) %{_libdir}/libgetopts-*.so
+%attr(755,root,root) %{_libdir}/libgraphviz-*.so
+%attr(755,root,root) %{_libdir}/libproc_macro-*.so
+%attr(755,root,root) %{_libdir}/libproc_macro_plugin-*.so
+%attr(755,root,root) %{_libdir}/librustc*-*.so
+%attr(755,root,root) %{_libdir}/librustdoc-*.so
+%attr(755,root,root) %{_libdir}/libserialize-*.so
+%attr(755,root,root) %{_libdir}/libstd-*.so
+%attr(755,root,root) %{_libdir}/libsyntax-*.so
+%attr(755,root,root) %{_libdir}/libsyntax_ext-*.so
+%attr(755,root,root) %{_libdir}/libsyntax_pos-*.so
+%attr(755,root,root) %{_libdir}/libterm-*.so
+%attr(755,root,root) %{_libdir}/libtest-*.so
 %{_mandir}/man1/rustc.1*
 %{_mandir}/man1/rustdoc.1*
-%{_libdir}/lib*
-%dir %{_libdir}/rustlib
-%{_libdir}/rustlib/%{rust_triple}
+%dir %{rustlibdir}
+%dir %{rustlibdir}/%{rust_triple}
+%dir %{rustlibdir}/%{rust_triple}/lib
+%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
+%{rustlibdir}/%{rust_triple}/lib/*.rlib
 
 %files debugger-common
 %defattr(644,root,root,755)
This page took 0.041986 seconds and 4 git commands to generate.