]> git.pld-linux.org Git - packages/rpm.git/blobdiff - rpm.spec
- php-<name> only deps for php5
[packages/rpm.git] / rpm.spec
index df9b1089e9dfc0ee31e4e224dacbe7b1e476e45a..aa5ead8a67eed2c9213d37fb25c2c1f98d26c5e8 100644 (file)
--- a/rpm.spec
+++ b/rpm.spec
@@ -1,18 +1,14 @@
 #
 # TODO:
+# - check if glob() patch needs resurrecting/rewriting
 # - check if we want shell autodeps: Requires: executable(ln) executable(mv)
-# - %{_arch} = i686 not as used to be i386:
+# - %{_arch} = i686 not as used to be i386 (platform file thing?):
 #   5.0.2: rpm -E '%_target_base_arch %_arch'
 #          i386 i686
 #   4.4.9: rpm -E '%_target_base_arch %_arch'
 #          i386 i386
 # - python(abi) cap is not provided automatically because /usr/lib*/libpython2*.so.*
 #   matches ELF first
-# - repackaging when lzma is not installed (todo: fix digest signature of header)
-#   rpmbuild computes digest when writing package to temporary file, then adds a few
-#   tags (incl. digest) and writes whole package to destination file;
-#   repackaging uses unchanged "immutable header" image from original rpm, also
-#   preserving payload format and compressor from original rpm, _not_ current settings
 # - TODO: add macros for some ppc, mipsel, alpha and sparc
 # - uppackaged list:
 #   /usr/lib/rpm/http.req
 #   /usr/lib/rpm/vcheck
 #   /usr/share/man/man8/rpmconstant.8
 #
+# - headerGet() making poldek segfault http://rpm5.org/cvs/tktview?tn=38,1
+# - rpm doesn't exit when no sources/patches available http://rpm5.org/cvs/tktview?tn=40,1
+# - http://rpm5.org/cvs/tktview?tn=41&_submit=Show
+#
 # Conditional build:
 %bcond_with    static          # build static rpm+rpmi
-%bcond_without apidocs         # don't generate documentation with doxygen
+%bcond_with    apidocs         # don't generate documentation with doxygen
 %bcond_with    autoreqdep      # autogenerate package name deps in addition to sonames/perl(X)
 %bcond_without python          # don't build python bindings
 %bcond_without selinux         # build without selinux support
@@ -51,7 +51,7 @@ ERROR
 
 # versions of required libraries
 %define                reqdb_ver       4.7.25
-%define                reqpopt_ver     1.10.8
+%define                reqpopt_ver     1.15
 %define                beecrypt_ver    2:4.1.2-4
 %define                sover   5.0
 
@@ -63,12 +63,12 @@ Summary(pt_BR.UTF-8):       Gerenciador de pacotes RPM
 Summary(ru.UTF-8):     Менеджер пакетов от RPM
 Summary(uk.UTF-8):     Менеджер пакетів від RPM
 Name:          rpm
-Version:       5.1.4
-Release:       0.3
+Version:       5.1.9
+Release:       0.1
 License:       LGPL
 Group:         Base
 Source0:       http://rpm5.org/files/rpm/rpm-5.1/%{name}-%{version}.tar.gz
-# Source0-md5: 9a04c22ce1dffc81a7e43d39b002aaa1
+# Source0-md5: 2b6ff8f7abb1fe919402f00cc0ca56f7
 Source1:       %{name}.groups
 Source2:       %{name}.platform
 Source3:       %{name}-install-tree
@@ -89,7 +89,7 @@ Source16:     %{name}-java-requires
 Source17:      banner.sh
 Source18:      %{name}-pld.macros
 Source19:      ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
-# Source19-md5:  08b29584dd349aac9caa7610131a0a88
+# Source19-md5:        08b29584dd349aac9caa7610131a0a88
 Source20:      %{name}-mimetypedeps
 Source100:     %{name}-macros-athlon
 Source101:     %{name}-macros-i386
@@ -116,11 +116,13 @@ Patch8:           %{name}-php-macros.patch
 Patch9:                %{name}-gettext-in-header.patch
 Patch10:       %{name}-compress-doc.patch
 Patch11:       %{name}-lua.patch
+Patch12:       %{name}-am.patch
 
 Patch14:       %{name}-etc_dir.patch
 Patch16:       %{name}-php-deps.patch
 Patch17:       %{name}-macros.patch
 Patch18:       %{name}-macros-th.patch
+Patch19:       %{name}-glob.patch
 
 Patch23:       %{name}-pkgconfigdeps.patch
 
@@ -132,6 +134,9 @@ Patch34:    %{name}-epoch0.patch
 Patch35:       %{name}-perl_req-INC_dirs.patch
 Patch36:       %{name}-debuginfo.patch
 Patch37:       %{name}-doxygen_hack.patch
+Patch38:       %{name}-perl_req-use_base.patch
+Patch39:       %{name}-perl_req-skip_multiline.patch
+Patch40:       %{name}-perl_req-heredocs_pod.patch
 
 Patch42:       %{name}-old-fileconflicts-behaviour.patch
 
@@ -142,10 +147,10 @@ Patch52:  %{name}-morearchs.patch
 
 Patch55:       %{name}-truncate-cvslog.patch
 
-Patch58:       %{name}-repackage-wo-lzma.patch
 Patch59:       %{name}-libtool-deps.patch
 Patch60:       %{name}-mimetype.patch
 Patch61:       %{name}-sparc64.patch
+Patch62:       %{name}-gendiff.patch
 URL:           http://rpm5.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1.4
@@ -155,6 +160,8 @@ BuildRequires:      bzip2-devel >= 1.0.2-17
 BuildRequires: elfutils-devel >= 0.108
 BuildRequires: gettext-autopoint >= 0.11.4-2
 BuildRequires: gettext-devel >= 0.11.4-2
+BuildRequires: keyutils-devel
+BuildRequires: lzma-devel >= 4.999.3
 BuildRequires: libmagic-devel
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
@@ -201,6 +208,8 @@ Obsoletes:  rpm-getdeps
 Conflicts:     glibc < 2.2.92
 # db4.6 poldek needed
 Conflicts:     poldek < 0.21-0.20070703.00.3
+# segfaults with lzma 0.42.2
+Conflicts:     lzma-libs < 4.999.3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _binary_payload         w9.gzdio
@@ -302,7 +311,6 @@ Requires:   beecrypt >= %{beecrypt_ver}
 Requires:      libmagic >= 1.15-2
 %{?with_selinux:Requires:      libselinux >= 1.18}
 Requires:      popt >= %{reqpopt_ver}
-%{?with_suggest_tags:Suggests: lzma}
 Obsoletes:     rpm-libs
 # avoid SEGV caused by mixed db versions
 Conflicts:     poldek < 0.18.1-16
@@ -327,6 +335,7 @@ Requires:   beecrypt-devel >= %{beecrypt_ver}
 Requires:      bzip2-devel
 %{?with_db:Requires:   db-devel >= %{reqdb_ver}}
 Requires:      elfutils-devel
+Requires:      keyutils-devel
 Requires:      libmagic-devel
 %{?with_selinux:Requires:      libselinux-devel}
 Requires:      popt-devel >= %{reqpopt_ver}
@@ -390,6 +399,7 @@ Requires:   beecrypt-static >= %{beecrypt_ver}
 Requires:      bzip2-static
 %{?with_db:Requires:   db-static >= %{reqdb_ver}}
 Requires:      elfutils-static
+Requires:      keyutils-static
 Requires:      libmagic-static
 Requires:      popt-static >= %{reqpopt_ver}
 Requires:      zlib-static
@@ -426,7 +436,6 @@ Requires:   popt >= %{reqpopt_ver}
 %if %{with suggest_tags}
 Suggests:      bzip2
 Suggests:      gzip
-Suggests:      lzma
 %endif
 Conflicts:     filesystem-debuginfo < 3.0-16
 
@@ -504,7 +513,6 @@ Requires:   gcc
 Requires:      glibc-devel
 Requires:      grep
 Requires:      gzip
-Requires:      lzma
 Requires:      make
 Requires:      patch
 Requires:      sed
@@ -655,18 +663,20 @@ Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
 
 %prep
 %setup -q -n %{name}-%{version}%{?subver}
-%patch0 -p1
+#patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
+#%patch6 -p1 // in upstream
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+# compress doc in upstream
 %patch10 -p1
 %{?with_system_lua:%patch11 -p1}
+%patch12 -p1
 # CHECK ME - macrofiles: ~/etc could be used
 #%%patch14 -p1
 %patch16 -p1
@@ -680,32 +690,41 @@ echo '%%define    __mono_requires /usr/lib/rpm/mono-find-requires' >> macros.mono
 install %{SOURCE9} scripts/php.prov.in
 install %{SOURCE10} scripts/php.req.in
 install %{SOURCE12} scripts/perl.prov
-%patch23 -p1
+# looks like upstream??
+#%patch23 -p1
 
 %ifarch i386 i486
 # disable TSC
 %patch26 -p1
 %endif
 %patch27 -p1
-%patch32 -p1
+# to port 
+#%patch32 -p1
 %patch34 -p1
 %patch35 -p0
 %patch36 -p1
 %patch37 -p1
+%patch38 -p1
+%patch39 -p1
+%patch40 -p1
 %patch42 -p1
 %patch46 -p1
-%patch47 -p1
+# port to new implementation
+#%patch47 -p1
 # OLD COMMENTED OUT
 #%%patch52 -p1 -- morearchs (rpmrc patch) adds ppc7400, ppc7400
 %patch55 -p1
-%patch58 -p1
 %patch59 -p1
 %patch17 -p1
 %patch18 -p1
-%patch60 -p1
+# Maybe, at last we can remove this?
+#patch19 -p1
+# port to new implementation
+#%patch60 -p1
 %ifarch sparc64
 %patch61 -p1
 %endif
+%patch62 -p1
 
 cd scripts
 mv -f perl.req perl.req.in
@@ -733,7 +752,7 @@ awk -f %{SOURCE6} %{SOURCE1}
 # rpm checks for CPU type at runtime, but it looks better
 #sed -i -e 's|@host@|%{_target_cpu}-%{_target_vendor}-linux-gnu|' -e 's|@host_cpu@|%{_target_cpu}|' macros.in
 
-%{?with_system_lua:CPPFLAGS=-I/usr/include/lua51}
+%{?with_system_lua:CPPFLAGS="-I/usr/include/lua51 %{rpmcppflags}"}
 # pass CC and CXX too in case of building with some older configure macro
 %configure \
        CC="%{__newcc}" \
@@ -751,6 +770,7 @@ awk -f %{SOURCE6} %{SOURCE1}
        --with-zlib=external \
        --with-bzip2=external \
        --with-beecrypt=external \
+       --with-lzma=external \
        --with-neon=%{?with_neon:external}%{!?with_neon:no} \
        --with-file=external \
        --with-popt=external \
@@ -1034,7 +1054,7 @@ touch $RPM_BUILD_ROOT/var/lock/rpm/transaction
 # move rpm to /bin
 mv $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
 # move essential libs to /lib (libs that /bin/rpm links to)
-for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so; do
+for a in librpm-%{sover}.so librpmdb-%{sover}.so librpmio-%{sover}.so librpmbuild-%{sover}.so librpmmisc-%{sover}.so; do
        mv -f $RPM_BUILD_ROOT%{_libdir}/$a $RPM_BUILD_ROOT/%{_lib}
        ln -s /%{_lib}/$a $RPM_BUILD_ROOT%{_libdir}/$a
 done
@@ -1062,8 +1082,6 @@ rm $RPM_BUILD_ROOT%{py_sitedir}/rpm/*.{la,a,py}
 rm $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log,xinetd}
 # utils dropped in 4.4.8 -- their manuals
 rm $RPM_BUILD_ROOT%{_mandir}/{,*/}/man8/rpmgraph.8
-# unpackaged in 4.4.9, reasons unknown
-rm $RPM_BUILD_ROOT%{_rpmlibdir}/symclash.{sh,py}
 
 %find_lang %{name}
 
@@ -1107,7 +1125,6 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 #%attr(755,root,root) %{_bindir}/rpmsign
 #%attr(755,root,root) %{_bindir}/rpmverify
 
-%dir %{_sysconfdir}/rpm
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
 %dir %{_sysconfdir}/rpm/sysinfo
 # these are ok to be replaced
@@ -1137,6 +1154,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 #%attr(755,root,root) %{_rpmlibdir}/rpmk
 #%attr(755,root,root) %{_rpmlibdir}/rpm[qv]
 
+%{_rpmlibdir}/qf
 %{_rpmlibdir}/rpmpopt*
 %{_rpmlibdir}/macros
 %{_rpmlibdir}/macros.pld
@@ -1145,6 +1163,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 
 %files base
 %defattr(644,root,root,755)
+%dir %{_sysconfdir}/rpm
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
 %dir %{_rpmlibdir}
 %attr(755,root,root) %{_bindir}/banner.sh
@@ -1157,6 +1176,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) /%{_lib}/librpmdb-%{sover}.so
 %attr(755,root,root) /%{_lib}/librpmio-%{sover}.so
 %attr(755,root,root) /%{_lib}/librpmbuild-%{sover}.so
+%attr(755,root,root) /%{_lib}/librpmmisc-%{sover}.so
 
 %files devel
 %defattr(644,root,root,755)
@@ -1198,6 +1218,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{_mandir}/man1/rpmgrep.1*
 %{_mandir}/man8/rpm2cpio.8*
 %{_mandir}/man8/rpmcache.8*
+%{_mandir}/man8/rpmconstant.8*
 %{_mandir}/man8/rpmdeps.8*
 %{_mandir}/man8/rpmmtree.8*
 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
@@ -1230,6 +1251,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_rpmlibdir}/cross-build
 %attr(755,root,root) %{_rpmlibdir}/find-spec-bcond
 %attr(755,root,root) %{_rpmlibdir}/getpo.sh
+%attr(755,root,root) %{_rpmlibdir}/install-sh
 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
 %attr(755,root,root) %{_rpmlibdir}/u_pkg.sh
@@ -1240,6 +1262,7 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
 #%attr(755,root,root) %{_rpmlibdir}/rpmb
 #%attr(755,root,root) %{_rpmlibdir}/rpmt
+%attr(755,root,root) %{_rpmlibdir}/vcheck
 %{_rpmlibdir}/noarch-*
 %ifarch %{ix86}
 %{_rpmlibdir}/i?86*
@@ -1272,15 +1295,21 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %{_rpmlibdir}/macros.perl
 %{_rpmlibdir}/macros.php
 # not used yet ... these six depend on perl
-#%attr(755,root,root) %{_rpmlibdir}/http.req
+%attr(755,root,root) %{_rpmlibdir}/http.req
 #%attr(755,root,root) %{_rpmlibdir}/magic.prov
 #%attr(755,root,root) %{_rpmlibdir}/magic.req
 #%{_rpmlibdir}/sql.prov
 #%{_rpmlibdir}/sql.req
 #%{_rpmlibdir}/tcl.req
+%attr(755,root,root) %{_rpmlibdir}/mono*
 
 %attr(755,root,root) %{_bindir}/gendiff
 %attr(755,root,root) %{_bindir}/rpmbuild
+%attr(755,root,root) %{_bindir}/rpmspecdump
+%attr(755,root,root) %{_bindir}/rpmwget
+
+%dir %{_rpmlibdir}/helpers
+%attr(755,root,root) %{_rpmlibdir}/helpers/makeshlibs
 
 %{_mandir}/man1/gendiff.1*
 %{_mandir}/man8/rpmbuild.8*
@@ -1297,7 +1326,8 @@ find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
 %files perlprov
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_rpmlibdir}/perl.*
-#%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
+%attr(755,root,root) %{_rpmlibdir}/osgideps.pl
+%attr(755,root,root) %{_rpmlibdir}/perldeps.pl
 #%attr(755,root,root) %{_rpmlibdir}/find-perl-*
 #%attr(755,root,root) %{_rpmlibdir}/find-*.perl
 #%attr(755,root,root) %{_rpmlibdir}/find-prov.pl
This page took 0.069612 seconds and 4 git commands to generate.