]> git.pld-linux.org Git - packages/qt5-qtwebchannel.git/blobdiff - qt5-qtwebchannel.spec
- release 2 (by relup.sh)
[packages/qt5-qtwebchannel.git] / qt5-qtwebchannel.spec
index f8f573abd6a579e68b798559e94100461d353b87..c28367ce8e0293b3d88cc1418e463c943536bfe1 100644 (file)
@@ -1,6 +1,6 @@
 #
 # Conditional build:
-%bcond_without qch     # documentation in QCH format
+%bcond_without doc     # Documentation
 
 %define                orgname         qtwebchannel
 %define                qtbase_ver              %{version}
@@ -9,18 +9,18 @@
 Summary:       The Qt5 WebChannel library
 Summary(pl.UTF-8):     Biblioteka Qt5 WebChannel
 Name:          qt5-%{orgname}
-Version:       5.8.0
-Release:       1
+Version:       5.15.2
+Release:       2
 License:       LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
 Group:         X11/Libraries
-Source0:       http://download.qt.io/official_releases/qt/5.8/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
-# Source0-md5: 9cb74ebedb6e7ca1f2a4dc3f8e2fbc08
+Source0:       http://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
+# Source0-md5: 77937260f831c0d9a68900ca10a3bff0
 URL:           http://www.qt.io/
 BuildRequires: Qt5Core-devel >= %{qtbase_ver}
 BuildRequires: Qt5Network-devel >= %{qtbase_ver}
 BuildRequires: Qt5Qml-devel >= %{qtdeclarative_ver}
 BuildRequires: Qt5Quick-devel >= %{qtdeclarative_ver}
-%if %{with qch}
+%if %{with doc}
 BuildRequires: qt5-assistant >= %{qttools_ver}
 %endif
 BuildRequires: qt5-build >= %{qtbase_ver}
@@ -124,23 +124,30 @@ Qt5 WebChannel examples.
 PrzykĹ‚ady do biblioteki Qt5 WebChannel.
 
 %prep
-%setup -q -n %{orgname}-opensource-src-%{version}
+%setup -q -n %{orgname}-everywhere-src-%{version}
+
+%{__sed} -i -e '1{
+       s,^#!.*bin/env node,#!/usr/bin/node,
+}' \
+       examples/webchannel/qwclient/qwclient.js
 
 %build
 qmake-qt5
 %{__make}
-%{__make} %{!?with_qch:html_}docs
+%{?with_doc:%{__make} docs}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
-%{__make} install_%{!?with_qch:html_}docs \
+%if %{with doc}
+%{__make} install_docs \
        INSTALL_ROOT=$RPM_BUILD_ROOT
+%endif
 
 # useless symlinks
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.?
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
 # actually drop *.la, follow policy of not packaging them when *.pc exist
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
 
@@ -177,7 +184,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n Qt5WebChannel
 %defattr(644,root,root,755)
-%doc LGPL_EXCEPTION.txt README.md
+%doc LICENSE.GPL3-EXCEPT README.md
 %attr(755,root,root) %{_libdir}/libQt5WebChannel.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQt5WebChannel.so.5
 %dir %{qt5dir}/qml/QtWebChannel
@@ -195,11 +202,11 @@ rm -rf $RPM_BUILD_ROOT
 %{qt5dir}/mkspecs/modules/qt_lib_webchannel.pri
 %{qt5dir}/mkspecs/modules/qt_lib_webchannel_private.pri
 
+%if %{with doc}
 %files doc
 %defattr(644,root,root,755)
 %{_docdir}/qt5-doc/qtwebchannel
 
-%if %{with qch}
 %files doc-qch
 %defattr(644,root,root,755)
 %{_docdir}/qt5-doc/qtwebchannel.qch
This page took 0.081645 seconds and 4 git commands to generate.