]> git.pld-linux.org Git - packages/qt4.git/blobdiff - qt4.spec
add moc-boost-workaround.patch
[packages/qt4.git] / qt4.spec
index 3eed01fbeb96a8f89bc9b5e4dcb6b38d215ab087..349a2169982036af58297d4cd778dee07e0b7e22 100644 (file)
--- a/qt4.spec
+++ b/qt4.spec
@@ -13,6 +13,7 @@
 %bcond_without pch             # pch (pre-compiled headers) in qmake
 %bcond_without system_phonon   # phonon libraries from phonon.spec intead of qt4.spec
 %bcond_with    wkhtml          # WKHTMLTOPDF patch (affects QtGui ABI)
+%bcond_with    openvg          # OpenVG support
 # -- databases
 %bcond_without mysql           # MySQL plugin
 %bcond_without odbc            # unixODBC plugin
@@ -50,7 +51,7 @@
 %define                _withsql        1
 %{!?with_sqlite3:%{!?with_sqlite:%{!?with_ibase:%{!?with_mysql:%{!?with_pgsql:%{!?with_odbc:%undefine _withsql}}}}}}
 
-%define                icu_abi         53
+%define                icu_abi         54
 %define                next_icu_abi    %(echo $((%{icu_abi} + 1)))
 
 Summary:       The Qt GUI application framework
@@ -59,7 +60,7 @@ Summary(pl.UTF-8):    Biblioteka Qt do tworzenia GUI
 Summary(pt_BR.UTF-8):  Estrutura para rodar aplicações GUI Qt
 Name:          qt4
 Version:       4.8.6
-Release:       2
+Release:       12
 License:       LGPL v2.1 or GPL v3.0
 Group:         X11/Libraries
 Source0:       http://download.qt-project.org/official_releases/qt/4.8/%{version}/qt-everywhere-opensource-src-%{version}.tar.gz
@@ -87,14 +88,26 @@ Patch10:    webkit-no_Werror.patch
 Patch11:       %{name}-wkhtml.patch
 Patch12:       fix-crash-in-assistant.patch
 Patch13:       improve-cups-support.patch
+Patch14:       x32.patch
 # backported from Qt5 (essentially)
 # http://bugzilla.redhat.com/702493
 # https://bugreports.qt-project.org/browse/QTBUG-5545
 Patch15:       qt-everywhere-opensource-src-4.8.4-qgtkstyle_disable_gtk_theme_check.patch
 Patch16:       qt-everywhere-opensource-src-4.8.3-QTBUG-4862.patch
+Patch17:       l-qclipboard_delay.patch
+Patch18:       l-qclipboard_fix_recursive.patch
+Patch19:       qtcore-4.8.5-honor-ExcludeSocketNotifiers-in-glib-event-loop.patch
+Patch20:       0010-QDbus-Fix-a-b-comparison.patch
+Patch21:       0023-Don-t-crash-on-broken-GIF-images.patch
+Patch22:       0025-Fix-visual-index-lookup-in-QTreeViewPrivate-adjustVi.patch
+Patch23:       0030-Memory-and-file-descriptor-leak-in-QFontCache.patch
+Patch24:       0034-Fix-raster-graphics-on-X11-RGB30.patch
+Patch25:       0065-Fix-QPainter-drawPolyline-painting-errors-with-cosme.patch
+Patch26:       0072-Fix-font-cache-check-in-QFontEngineFT-recalcAdvances.patch
+Patch27:       moc-boost-workaround.patch
 URL:           http://qt-project.org/
 %{?with_ibase:BuildRequires:   Firebird-devel}
-BuildRequires: Mesa-libOpenVG-devel
+%{?with_openvg:BuildRequires:  Mesa-libOpenVG-devel}
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: OpenGL-devel
 BuildRequires: alsa-lib-devel
@@ -102,7 +115,7 @@ BuildRequires:      alsa-lib-devel
 BuildRequires: dbus-devel >= 0.93
 BuildRequires: fontconfig-devel
 BuildRequires: freetds-devel
-BuildRequires: freetype-devel >= 1:2.0.0
+BuildRequires: freetype-devel >= 2.1.3
 %{?with_pch:BuildRequires:     gcc >= 5:4.0}
 BuildRequires: glib2-devel >= 2.0.0
 BuildRequires: gstreamer0.10-plugins-base-devel
@@ -273,8 +286,12 @@ Group:             X11/Libraries
 %ifarch %{x8664} ppc64 sparc64 s390x
 Requires:      libicui18n.so.%{icu_abi}()(64bit)
 %else
+%ifarch x32
+Requires:      libicui18n.so.%{icu_abi}()(x32bit)
+%else
 Requires:      libicui18n.so.%{icu_abi}
 %endif
+%endif
 Obsoletes:     QtAssistant
 
 %description -n QtCore
@@ -486,7 +503,7 @@ Group:              X11/Development/Libraries
 Requires:      QtCore-devel = %{version}-%{release}
 Requires:      QtGui = %{version}-%{release}
 Requires:      fontconfig-devel
-Requires:      freetype-devel >= 1:2.0.0
+Requires:      freetype-devel >= 2.1.3
 Requires:      libpng-devel >= 2:1.0.8
 Requires:      xorg-lib-libSM-devel
 Requires:      xorg-lib-libXcursor-devel
@@ -1477,9 +1494,20 @@ Programas exemplo para o Qt versão.
 %{?with_wkhtml:%patch11 -p1}
 %patch12 -p1
 %patch13 -p1
-
+%patch14 -p1
 %patch15 -p1
 %patch16 -p1
+%patch17 -p0
+%patch18 -p0
+%patch19 -p1
+%patch20 -p1
+%patch21 -p1
+%patch22 -p1
+%patch23 -p1
+%patch24 -p1
+%patch25 -p1
+%patch26 -p1
+%patch27 -p1
 
 %{__sed} -i -e 's,usr/X11R6/,usr/g,' mkspecs/linux-g++-64/qmake.conf \
        mkspecs/common/linux.conf
@@ -1570,6 +1598,7 @@ COMMONOPT=" \
        %{?with_nas:-system-nas-sound} \
        %{?debug:-debug} \
        %{!?debug:-release} \
+       -%{!?with_openvg:no-}openvg \
        -qt3support \
        -fontconfig \
        -largefile \
@@ -1643,6 +1672,9 @@ install -d $RPM_BUILD_ROOT{/etc/{env.d,qt4},%{_bindir},%{_desktopdir},%{_pixmaps
 install -d $RPM_BUILD_ROOT%{_qtdir}/plugins/{crypto,network}
 install -d $RPM_BUILD_ROOT%{_qtdir}/imports/org
 
+# for QtSolutions (qtlockedfile, qtsingleapplication, etc)
+install -d $RPM_BUILD_ROOT%{_includedir}/qt4/QtSolutions
+
 echo '#QT_GRAPHICSSYSTEM=raster' > $RPM_BUILD_ROOT/etc/env.d/QT_GRAPHICSSYSTEM
 
 %{__make} install \
@@ -1834,7 +1866,7 @@ mkdevfl QtGui
 mkdevfl QtMultimedia
 mkdevfl QtNetwork
 mkdevfl QtOpenGL
-mkdevfl QtOpenVG
+%{?with_openvg:mkdevfl QtOpenVG}
 mkdevfl QtScript
 mkdevfl QtScriptTools
 mkdevfl QtSql
@@ -2121,10 +2153,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libQtOpenGL.so.4
 %attr(755,root,root) %{_qtdir}/plugins/graphicssystems/libqglgraphicssystem.so
 
+%if %{with openvg}
 %files -n QtOpenVG
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQtOpenVG.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtOpenVG.so.4
+%endif
 
 %files -n QtScript
 %defattr(644,root,root,755)
@@ -2369,6 +2403,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n QtCore-devel -f QtCore-devel.files
 %defattr(644,root,root,755)
+%dir %{_includedir}/qt4/QtSolutions
 
 %files -n QtDBus-devel -f QtDBus-devel.files
 %defattr(644,root,root,755)
@@ -2394,8 +2429,10 @@ rm -rf $RPM_BUILD_ROOT
 %files -n QtOpenGL-devel -f QtOpenGL-devel.files
 %defattr(644,root,root,755)
 
+%if %{with openvg}
 %files -n QtOpenVG-devel -f QtOpenVG-devel.files
 %defattr(644,root,root,755)
+%endif
 
 %files -n QtScript-devel -f QtScript-devel.files
 %defattr(644,root,root,755)
@@ -2471,9 +2508,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libQtOpenGL.a
 
+%if %{with openvg}
 %files -n QtOpenVG-static
 %defattr(644,root,root,755)
 %{_libdir}/libQtOpenVG.a
+%endif
 
 %files -n QtScript-static
 %defattr(644,root,root,755)
This page took 0.101579 seconds and 4 git commands to generate.