]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
adapter (tab reformat)
[packages/qemu.git] / qemu.spec
index 7bbbcae6a1a5fa01075ed50b0111622d5e3fccdb..fc0bd8e38361cd1d501990f5f336a314fdba90c6 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,6 +1,7 @@
 #
 # Conditional build:
 %bcond_without sdl             # SDL UI and audio support
+%bcond_without gl              # Don't require gl deps
 %bcond_without ceph            # Ceph/RBD support
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
@@ -37,7 +38,7 @@ Summary:      QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
 Version:       2.6.0
-Release:       1
+Release:       2
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
@@ -64,11 +65,9 @@ Patch4:              %{name}-xattr.patch
 Patch5:                libjpeg-boolean.patch
 Patch6:                x32.patch
 Patch7:                %{name}-sh.patch
-# Proof of concept, for reference, do not remove
-Patch400:      %{name}-kde_virtual_workspaces_hack.patch
 URL:           http://www.qemu-project.org/
-BuildRequires: OpenGL-devel
-BuildRequires: OpenGL-GLX-devel
+%{?with_gl:BuildRequires:      OpenGL-GLX-devel}
+%{?with_gl:BuildRequires:      OpenGL-devel}
 %{?with_sdl:BuildRequires:     SDL2-devel >= 2.0}
 BuildRequires: alsa-lib-devel
 BuildRequires: bcc >= 0.16.21-2
@@ -86,7 +85,7 @@ BuildRequires:        libaio-devel
 %{?with_smartcard:BuildRequires:       libcacard-devel}
 BuildRequires: libcap-devel
 BuildRequires: libcap-ng-devel
-BuildRequires: libepoxy-devel
+%{?with_gl:BuildRequires:      libepoxy-devel}
 BuildRequires: libfdt-devel
 %{?with_rdma:BuildRequires:    libibverbs-devel}
 %{?with_iscsi:BuildRequires:   libiscsi-devel >= 1.9.0}
@@ -823,13 +822,15 @@ ln -s ../error.h qapi/error.h
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
-       $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
+       $RPM_BUILD_ROOT/etc/{qemu,sysconfig,udev/rules.d,modules-load.d} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
 
 %{__make} install \
        %{!?with_smartcard:CONFIG_USB_SMARTCARD=n} \
        DESTDIR=$RPM_BUILD_ROOT
 
+echo "#allow br0" > $RPM_BUILD_ROOT/etc/qemu/bridge.conf
+
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 #!/bin/sh
@@ -957,6 +958,8 @@ fi
 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
+%dir /etc/qemu
+%attr(640,root,qemu) %config(noreplace) %verify(not md5 mtime size) /etc/qemu/bridge.conf
 %{systemdunitdir}/ksm.service
 %{systemdunitdir}/ksmtuned.service
 %attr(755,root,root) %{_bindir}/ivshmem-client
This page took 0.029145 seconds and 4 git commands to generate.