]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- more BRs checked by configure to build documentation
[packages/qemu.git] / qemu.spec
index 6b1d293afb547b89caa6d6adddaf3212e9eac2cc..a1e2f57b7ad1ab17fbee9506d9864304f7adf56e 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,63 +1,63 @@
 #
 # TODO:
 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
+# - kqemu could be distributable if somebody bothers to contact qemu
+#   author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
 #
 # Conditional build:
-%bcond_with    kqemu                   # with QEMU accelerator module
+%bcond_without kqemu                   # disable QEMU accelerator support
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
+%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
-%bcond_without kernel                  # don't build kernel modules
+%bcond_with    kernel                  # build kqemu kernel modules
 %bcond_without smp                     # don't build SMP module
 %bcond_without userspace               # don't build userspace utilities
-
-%define        _kqemu_version  0.7.2
 #
+%define        _kqemu_version  1.3.0pre7
+%define                _rel    0.4
 Summary:       QEMU CPU Emulator
 Summary(pl):   QEMU - emulator procesora
 Name:          qemu
-Version:       0.8.0
-%define                _rel    1
+Version:       0.8.1
 Release:       %{_rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
 Source0:       http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
-# Source0-md5: eb175b26583280706fe7e4d8910d320d
-%if %{with kqemu}
-Source1:       http://fabrice.bellard.free.fr/qemu/kqemu-%{_kqemu_version}.tar.gz
-# NoSource1-md5:       02cfdecda90458d6393781496ec6b48b
+# Source0-md5: 67d924324a5ab79d017bd97a1e767285
+Source1:       http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
+# NoSource1-md5:       3b77edbada790f924456aa4675edd0be
 NoSource:      1
-%endif
 Patch0:                %{name}-nostatic.patch
-Patch1:                %{name}-DESTDIR.patch
+Patch1:                %{name}-cc.patch
 Patch2:                %{name}-longjmp.patch
 Patch3:                %{name}-dot.patch
-Patch4:                %{name}-initrd_load_addr.patch
-Patch5:                %{name}-gcc4_x86.patch
-Patch6:                %{name}-gcc4_ppc.patch
-Patch7:                %{name}-parallel.patch
-Patch8:                %{name}-nosdlgui.patch
-Patch9:                %{name}-ifup.patch
+Patch4:                %{name}-gcc4_x86.patch
+Patch5:                %{name}-gcc4_ppc.patch
+Patch6:                %{name}-nosdlgui.patch
+Patch7:                %{name}-ifup.patch
+Patch8:        %{name}-gcc33.patch
+Patch9:                %{name}-parallel.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
 BuildRequires: SDL-devel >= 1.2.1
+BuildRequires: alsa-lib-devel
+%{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
 %if %{with kqemu} && %{with dist_kernel}
-BuildRequires: kernel-module-build >= 2.6.7
+BuildRequires: kernel-module-build >= 3:2.6.7
 %endif
+BuildRequires: perl-tools-pod
 BuildRequires: rpmbuild(macros) >= 1.217
+BuildRequires: tetex
 BuildRequires: sed >= 4.0
 Requires:      SDL >= 1.2.1
-ExclusiveArch: %{ix86} %{x8664} ppc
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
+ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # some SPARC boot image in ELF format
 %define                _noautostrip    .*%{_datadir}/qemu/proll.elf
 
-%if !%{with kqemu}
-%undefine      with_kernel
-%endif
-
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
 achieves a reasonnable speed while being easy to port on new host
@@ -69,9 +69,8 @@ CPUs. QEMU has two operating modes:
   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
 
 - Full system emulation. In this mode, QEMU emulates a full system,
-  including a processor and various peripherials. 
-  It can also be used to provide virtual hosting of several 
-  virtual PC on a single server.
+  including a processor and various peripherials. It can also be used to
+  provide virtual hosting of several virtual PC on a single server.
 
 %description -l pl
 QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
@@ -80,15 +79,15 @@ aby dzia
 
 - Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
   procesy linuksowe skompilowane dla jednego procesora na innym
-  procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu
-  na niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
+  procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu na
+  niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
   s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
   cele QEMU.
 
 - Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
-  w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne.
-  Mo¿e byæ tak¿e u¿ywane do wirtualnego hostowania kilku wirtualnych 
-  pecetów na pojedynczym serwerze.
+  w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne. Mo¿e byæ tak¿e
+  u¿ywane do wirtualnego hostowania kilku wirtualnych pecetów na
+  pojedynczym serwerze.
 
 %package -n kernel-misc-kqemu
 Summary:       kqemu - kernel module
@@ -99,6 +98,7 @@ Group:                Base/Kernel
 %{?with_dist_kernel:%requires_releq_kernel_up}
 License:       Free to use, non-distributable
 Requires(post,postun): /sbin/depmod
+Requires:      module-init-tools >= 3.2.2-2
 
 %description -n kernel-misc-kqemu
 kqemu - kernel module.
@@ -115,6 +115,7 @@ Group:              Base/Kernel
 %{?with_dist_kernel:%requires_releq_kernel_up}
 License:       Free to use, non-distributable
 Requires(post,postun): /sbin/depmod
+Requires:      module-init-tools >= 3.2.2-2
 
 %description -n kernel-smp-misc-kqemu
 kqemu - SMP kernel module.
@@ -123,18 +124,20 @@ kqemu - SMP kernel module.
 kqemu - modu³ j±dra SMP.
 
 %prep
-%setup -q %{?with_kqemu:-a1}
+%setup -q %{?with_kernel:-a1}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-%patch5 -p0
-%patch6 -p1
+%if %{with gcc4}
+%patch4 -p0
+%patch5 -p1
+%endif
+%{?with_nosdlgui:%patch6 -p1}
+%patch7 -p1
+%patch8 -p1
 # probably not needed
-# %patch7 -p1
-%{?with_nosdlgui:%patch8 -p1}
-%patch9 -p1
+#%%patch9 -p1
 
 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
@@ -146,30 +149,51 @@ kqemu - modu
 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
 %endif
 
-%{?with_kqemu:echo -n > kqemu/install.sh}
+%if %{with kernel}
+echo -n > kqemu-%{_kqemu_version}/install.sh
+
+cat <<'EOF' > modprobe.conf
+# enable dynamic major
+options kqemu major=0
+# for autoloading from static dev
+#alias char-major-250 kqemu
+EOF
+
+cat <<'EOF' > udev.conf
+KERNEL=="kqemu", NAME="%k", MODE="0666"
+EOF
+%endif
 
 %build
 %if %{with kernel}
-cd kqemu
+cd kqemu-%{_kqemu_version}
+mv -f kqemu-linux.c{,.orig}
 for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
        if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
                exit 1
        fi
-       rm -rf include
-       install -d include/{linux,config}
-       ln -sf %{_kernelsrcdir}/config-$cfg .config
-       ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h include/linux/autoconf.h
-       ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} include/asm
-       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg Module.symvers
-%if %{without dist_kernel}
-       ln -sf %{_kernelsrcdir}/scripts
+       install -d o/include/linux
+       ln -sf %{_kernelsrcdir}/config-$cfg o/.config
+       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg o/Module.symvers
+       ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h o/include/linux/autoconf.h
+%if %{with dist_kernel}
+       %{__make} -C %{_kernelsrcdir} O=$PWD/o prepare scripts
+%else
+       install -d o/include/config
+       touch o/include/config/MARKER
+       ln -sf %{_kernelsrcdir}/scripts o/scripts
 %endif
-       touch include/config/MARKER
-       %{__make} -C %{_kernelsrcdir} clean \
-               RCS_FIND_IGNORE="-name 'kqemu-mod-*.*' -o" \
-               M=$PWD O=$PWD
+       if grep -q "^CONFIG_PREEMPT_RT=y$" o/.config; then
+               sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
+                       kqemu-linux.c.orig > kqemu-linux.c
+       else
+               cat kqemu-linux.c.orig > kqemu-linux.c
+       fi
+
        %{__make} -C %{_kernelsrcdir} modules \
-               M=$PWD O=$PWD
+               CC="%{__cc}" CPP="%{__cpp}" \
+               M=$PWD O=$PWD/o \
+               %{?with_verbose:V=1}
        mv kqemu.ko kqemu-mod-$cfg.ko
 done
 cd -
@@ -181,8 +205,16 @@ cd -
 ./configure \
        --prefix=%{_prefix} \
        --cc="%{__cc}" \
-       %{!?with_kqemu:--disable-kqemu} \
-       --make="%{__make}"
+       --host-cc="%{__cc}" \
+       --make="%{__make}" \
+%if %{with kqemu}
+       --kernel-path=%{_kernelsrcdir} \
+%else
+       --disable-kqemu \
+%endif
+       %{?with_gcc4:--disable-gcc-check} \
+       --enable-alsa \
+       --interp-prefix=%{_libdir}/%{name}
 %{__make}
 %endif
 
@@ -206,19 +238,23 @@ EOF
 
 %if %{with kernel}
 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
-install kqemu/kqemu-mod-up.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/kqemu.ko
+install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
+install kqemu-%{_kqemu_version}/kqemu-mod-up.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/kqemu.ko
+install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
 %if %{with smp} && %{with dist_kernel}
-install kqemu/kqemu-mod-smp.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/kqemu.ko
+install kqemu-%{_kqemu_version}/kqemu-mod-smp.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/kqemu.ko
+install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
 %endif
+install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
 %endif
 
-# This dir is unneeded
-rm -rf $RPM_BUILD_ROOT/usr/share/doc/qemu
+# already packaged
+rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with kqemu}
+%if %{with kernel}
 %post
 %banner %{name} -e <<EOF
 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
@@ -228,20 +264,12 @@ EOF
 
 %post  -n kernel-misc-kqemu
 %depmod %{_kernel_ver}
-%banner %{name}-module -e <<EOF
-To autoload kqemu module, add to /etc/modprobe.conf:
-alias char-major-250 kqemu
-EOF
 
 %postun -n kernel-misc-kqemu
 %depmod %{_kernel_ver}
 
 %post  -n kernel-smp-misc-kqemu
 %depmod %{_kernel_ver}smp
-%banner %{name}-module -e <<EOF
-To autoload kqemu module, add to /etc/modprobe.conf:
-alias char-major-250 kqemu
-EOF
 
 %postun -n kernel-smp-misc-kqemu
 %depmod %{_kernel_ver}smp
@@ -255,22 +283,22 @@ EOF
 %{_datadir}/qemu
 %{_mandir}/man1/qemu.1*
 %{_mandir}/man1/qemu-img.1*
-# FIXME: maybe better moved this into dev.spec
-%if %{with kqemu}
-%dev(c,250,0) %attr(666,root,root) /dev/kqemu
-%endif
 %endif
 
 %if %{with kernel}
 %files -n kernel-misc-kqemu
 %defattr(644,root,root,755)
+%doc kqemu-%{_kqemu_version}/LICENSE
+%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
+%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
-%doc kqemu/LICENSE
 
 %if %{with smp} && %{with dist_kernel}
 %files -n kernel-smp-misc-kqemu
 %defattr(644,root,root,755)
+%doc kqemu-%{_kqemu_version}/LICENSE
+%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
+%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
 /lib/modules/%{_kernel_ver}smp/misc/kqemu.ko*
-%doc kqemu/LICENSE
 %endif
 %endif
This page took 0.049892 seconds and 4 git commands to generate.