]> git.pld-linux.org Git - packages/python-recaptcha.git/blobdiff - python-recaptcha.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-recaptcha.git] / python-recaptcha.spec
index 172701a0a882ffb719447ceb6eb895816a681c87..31d3a68ff4427ba87454f23bde0218203f4b3cb7 100644 (file)
@@ -2,18 +2,18 @@
 Summary:       A client for reCAPTCHA and reCAPTCHA Mailhide
 Summary(pl.UTF-8):     Klient usług reCAPTCHA i reCAPTCHA Mailhide
 Name:          python-recaptcha
-Version:       1.0.3
-Release:       2
+Version:       1.0.6
+Release:       4
 License:       MIT
 Group:         Libraries/Python
 Source0:       http://pypi.python.org/packages/source/r/recaptcha-client/%{fname}-%{version}.tar.gz
-# Source0-md5: 5aaa88d703f1003ecc63a0ced00baad6
-URL:           http://recaptcha.net
+# Source0-md5: 74228180f7e1fb76c4d7089160b0d919
+URL:           http://www.google.com/recaptcha
 BuildRequires: python >= 1:2.5
 BuildRequires: python-setuptools
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
-%pyrequires_eq python-modules
+BuildRequires: rpmbuild(macros) >= 1.710
+Requires:      python-modules
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -22,9 +22,9 @@ Provides a CAPTCHA for Python using the reCAPTCHA service. Does not
 require any imaging libraries because the CAPTCHA is served directly
 from reCAPTCHA. Also allows you to securely obfuscate emails with
 Mailhide. This functionality requires pycrypto. This library requires
-two types of API keys. If you'd like to use the CAPTCHA, you'll need
-a key from <http://recaptcha.net/api/getkey>. For Mailhide, you'll
-need a key from <http://mailhide.recaptcha.net/apikey>.
+two types of API keys. If you'd like to use the CAPTCHA, you'll need a
+key from <http://recaptcha.net/api/getkey>. For Mailhide, you'll need
+a key from <http://mailhide.recaptcha.net/apikey>.
 
 %description -l pl.UTF-8
 Ten moduł obsługuje CAPTCHA (kod do wpisania z obrazka) w Pythonie w
@@ -40,16 +40,14 @@ strony <http://mailhide.recaptcha.net/apikey>.
 %setup -qn %{fname}-%{version}
 
 %build
-%{__python} setup.py build
+%py_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__python} setup.py install \
-       --root=$RPM_BUILD_ROOT \
-       --optimize=2
+%py_install
 
 # structure of this module is an incredible fuckup. anyone knows how to fix this?
-cp recaptcha/__init__.pyc $RPM_BUILD_ROOT%{py_sitescriptdir}/recaptcha
+cp -p recaptcha/__init__.py[co] $RPM_BUILD_ROOT%{py_sitescriptdir}/recaptcha
 
 %py_postclean
 
@@ -58,5 +56,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%{py_sitescriptdir}/recaptcha
+%dir %{py_sitescriptdir}/recaptcha
+%{py_sitescriptdir}/recaptcha/__init__.py[co]
+%dir %{py_sitescriptdir}/recaptcha/client
+%{py_sitescriptdir}/recaptcha/client/*.py[co]
 %{py_sitescriptdir}/recaptcha_client-%{version}-py*.egg-info
+%{py_sitescriptdir}/recaptcha_client-%{version}-py*-nspkg.pth
This page took 0.069722 seconds and 4 git commands to generate.