]> git.pld-linux.org Git - packages/python3-pygments.git/blobdiff - python-pygments.spec
- conditional BRs
[packages/python3-pygments.git] / python-pygments.spec
index 636f3488d60ad090e65a59a1bea6bac2a0949cc9..936be7440cfda3140607d35c3aea27f23e0e5f0a 100644 (file)
@@ -1,29 +1,62 @@
-
-%define module pygments
+%bcond_without python2
+%bcond_without python3
+%define module pygments
+#
 Summary:       Generic syntax highlighter
 Name:          python-%{module}
-Version:       1.1.1
-Release:       1
+Version:       1.3.1
+Release:       2
 License:       BSD
 Group:         Development/Languages/Python
 Source0:       http://pypi.python.org/packages/source/P/Pygments/Pygments-%{version}.tar.gz
-# Source0-md5: 80ac64669a75e2d6647822b2778e38c8
+# Source0-md5: 54be67c04834f13d7e255e1797d629a5
 URL:           http://pygments.org/
+%if %{with python2}
+BuildRequires: python
 BuildRequires: python-devel
+BuildRequires: python-modules
+%endif
+%if %{with python3}
+BuildRequires: python3
+BuildRequires: python3-2to3
+BuildRequires: python3-devel
+BuildRequires: python3-distribute
+BuildRequires: python3-modules
+%endif
+BuildRequires: rpm-pythonprov
 %pyrequires_eq python-modules
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Pygments is a generic syntax highlighter for general use in all kinds of
-software such as forum systems, wikis or other applications that need to
-prettify source code. Highlights are
+Pygments is a generic syntax highlighter for general use in all kinds
+of software such as forum systems, wikis or other applications that
+need to prettify source code. Highlights are
 - a wide range of common languages and markup formats is supported
-- special attention is paid to details that increase highlighting quality
-- support for new languages and formats are added easily; most languages
-  use a simple regex-based lexing mechanism
-- a number of output formats is available, among them HTML, RTF, LaTeX and
-  ANSI sequences
+- special attention is paid to details that increase highlighting
+  quality
+- support for new languages and formats are added easily; most
+  languages use a simple regex-based lexing mechanism
+- a number of output formats is available, among them HTML, RTF, LaTeX
+  and ANSI sequences
+- it is usable as a command-line tool and as a library
+- ... and it highlights even Brainf*ck!
+
+%package -n python3-%{module}
+Summary:       Generic syntax highlighter
+Group:         Development/Languages/Python
+
+%description -n python3-%{module}
+Pygments is a generic syntax highlighter for general use in all kinds
+of software such as forum systems, wikis or other applications that
+need to prettify source code. Highlights are
+- a wide range of common languages and markup formats is supported
+- special attention is paid to details that increase highlighting
+  quality
+- support for new languages and formats are added easily; most
+  languages use a simple regex-based lexing mechanism
+- a number of output formats is available, among them HTML, RTF, LaTeX
+  and ANSI sequences
 - it is usable as a command-line tool and as a library
 - ... and it highlights even Brainf*ck!
 
@@ -31,23 +64,61 @@ prettify source code. Highlights are
 %setup -q -n Pygments-%{version}
 
 %build
-%{__python} setup.py build
+%if %{with python2}
+%{__python} setup.py build -b build-2
+%endif
+
+%if %{with python3}
+%{__python3} setup.py build -b build-3
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__python} setup.py install \
-               --optimize=2 \
-               --root=$RPM_BUILD_ROOT
+%if %{with python2}
+%{__python} setup.py \
+       build -b build-2 \
+       install \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+
+mv $RPM_BUILD_ROOT%{_bindir}/pygmentize{,-2}
 
 %py_postclean
+%endif
+
+%if %{with python3}
+%{__python3} setup.py \
+       build -b build-3 \
+       install \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+
+mv $RPM_BUILD_ROOT%{_bindir}/pygmentize{,-3}
+
+%py3_postclean
+%endif
+
+ln -s pygmentize-2 $RPM_BUILD_ROOT%{_bindir}/pygmentize
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with python2}
 %files
 %defattr(644,root,root,755)
 %doc PKG-INFO TODO AUTHORS
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/pygmentize
+%attr(755,root,root) %{_bindir}/pygmentize-2
 %{py_sitescriptdir}/%{module}
 %{py_sitescriptdir}/*Pygments*.egg*
+%endif
+
+%if %{with python3}
+%files -n python3-%{module}
+%defattr(644,root,root,755)
+%doc PKG-INFO TODO AUTHORS
+%attr(755,root,root) %{_bindir}/pygmentize-3
+%{py3_sitescriptdir}/%{module}
+%{py3_sitescriptdir}/*Pygments*.egg*
+%endif
This page took 0.106664 seconds and 4 git commands to generate.