]> git.pld-linux.org Git - packages/python-pybind11.git/blobdiff - python-pybind11.spec
- cleanup, updated to 2.4.3
[packages/python-pybind11.git] / python-pybind11.spec
index 3b48f7419e2d302bed022ca1f5c73d428b7fd581..bda5035910dbb513339a85dff096a5e60418444f 100644 (file)
@@ -1,42 +1,35 @@
 #
-# This is template for pure python modules (noarch)
-# use template-specs/python-ext.spec for binary python packages
-#
-#
 # Conditional build:
 %bcond_without python2 # CPython 2.x module
 %bcond_without python3 # CPython 3.x module
 
-# NOTES:
-# - 'module' should match the Python import path (first component?)
-# - 'egg_name' should equal to Python egg name
-# - 'pypi_name' must match the Python Package Index name
 %define                module          pybind11
 %define                egg_name        pybind11
 %define                pypi_name       pybind11
 Summary:       Seamless operability between C++11 and Python
+Summary(pl.UTF-8):     Gładka współpraca między C++11 a Pythonem
 Name:          python-%{pypi_name}
-Version:       2.2.4
-Release:       2
+Version:       2.4.3
+Release:       1
 License:       BSD
 Group:         Libraries/Python
-Source0:       https://files.pythonhosted.org/packages/source/p/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
-# Source0-md5: 159d9ac0b6570c2888511b14019a2578
+#Source0Download: https://pypi.org/simple/pybind11/
+Source0:       https://files.pythonhosted.org/packages/source/p/pybind11/%{pypi_name}-%{version}.tar.gz
+# Source0-md5: 23fdca8191b16ce3e7f38fb9e4252b2d
 URL:           https://pypi.org/project/pybind11/
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
-BuildRequires: python-modules
+BuildRequires: python-modules >= 1:2.7
 BuildRequires: python-setuptools
-BuildRequires: rpm-pythonprov
 %endif
 %if %{with python3}
-BuildRequires: python3-modules
+BuildRequires: python3-modules >= 1:3.2
 BuildRequires: python3-setuptools
 %endif
-# when using /usr/bin/env or other in-place substitutions
-#BuildRequires:        sed >= 4.0
-# replace with other requires if defined in setup.py
-Requires:      python-modules
+Requires:      libstdc++-devel >= 6:4.7
+Requires:      python-devel >= 1:2.7
+Conflicts:     eigen3 < 3.2.7
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -48,10 +41,22 @@ Boost.Python library by David Abrahams: to minimize boilerplate code
 in traditional extension modules by inferring type information using
 compile-time introspection.
 
+%description -l pl.UTF-8
+pybind11 to lekka, składająca się z samych nagłówków biblioteka
+udostępniająca typy C++ w Pythonie i na odwrót, służąca głównie do
+tworzenia wiązań Pythona do istniejącego kodu w C++. Cele i składnia
+są podobne do biblioteki Boost.Python autorstwa Davida Abrahamsa - aby
+zminimalizować kod wiążący w tradycyjnych modułach rozszerzeń poprzez
+wnioskowanie informacji o typach przy użyciu introspekcji w trakcie
+kompilacji.
+
 %package -n python3-%{pypi_name}
 Summary:       Seamless operability between C++11 and Python
+Summary(pl.UTF-8):     Gładka współpraca między C++11 a Pythonem
 Group:         Libraries/Python
-Requires:      python3-modules
+Requires:      libstdc++-devel >= 6:4.7
+Requires:      python3-devel >= 1:3.2
+Conflicts:     eigen3 < 3.2.7
 
 %description -n python3-%{pypi_name}
 pybind11 is a lightweight header-only library that exposes C++ types
@@ -61,6 +66,15 @@ Boost.Python library by David Abrahams: to minimize boilerplate code
 in traditional extension modules by inferring type information using
 compile-time introspection.
 
+%description -n python3-%{pypi_name} -l pl.UTF-8
+pybind11 to lekka, składająca się z samych nagłówków biblioteka
+udostępniająca typy C++ w Pythonie i na odwrót, służąca głównie do
+tworzenia wiązań Pythona do istniejącego kodu w C++. Cele i składnia
+są podobne do biblioteki Boost.Python autorstwa Davida Abrahamsa - aby
+zminimalizować kod wiążący w tradycyjnych modułach rozszerzeń poprzez
+wnioskowanie informacji o typach przy użyciu introspekcji w trakcie
+kompilacji.
+
 %prep
 %setup -q -n %{pypi_name}-%{version}
 
@@ -79,12 +93,6 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %py_install
 
-# when files are installed in other way that standard 'setup.py
-# they need to be (re-)compiled
-# change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
-%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
-%py_comp $RPM_BUILD_ROOT%{py_sitedir}
-
 %py_postclean
 %endif
 
@@ -98,7 +106,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc CONTRIBUTING.md README.md
+%doc LICENSE README.md
 %{py_sitescriptdir}/%{module}
 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
 %{py_incdir}/pybind11
@@ -107,7 +115,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-%{pypi_name}
 %defattr(644,root,root,755)
-%doc CONTRIBUTING.md README.md
+%doc LICENSE README.md
 %{py3_sitescriptdir}/%{module}
 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
 %{py3_incdir}/pybind11
This page took 0.032567 seconds and 4 git commands to generate.