]> git.pld-linux.org Git - packages/python-hunspell.git/blobdiff - python-hunspell.spec
- rebuild with hunspell 1.4.1
[packages/python-hunspell.git] / python-hunspell.spec
index 932bd42971d764275a257faafe752004eee30ac6..8b7f2c4b5939fe08d716ec795dc6edb1a0c8d7a2 100644 (file)
@@ -7,24 +7,24 @@
 Summary:       Pyhunspell - Python 2.x bindings for the Hunspell spellchecker engine
 Summary(pl.UTF-8):     Pyhunspell - wiązania Pythona 2.x do silnika sprawdzania pisowni Hunspell
 Name:          python-%{module}
-Version:       0.3.1
+Version:       0.4.1
 Release:       2
-License:       LGPL v3+
+License:       GPL v3+
 Group:         Libraries/Python
+#Source0Download: https://pypi.python.org/simple/hunspell/
 Source0:       https://pypi.python.org/packages/source/h/hunspell/hunspell-%{version}.tar.gz
-# Source0-md5: 85d57a3bc056e3b302141c37378bfdf1
-Patch0:                %{name}-lib_fix.patch
+# Source0-md5: d8b69c71a1e4d9a74c00972f76ea06bc
 URL:           http://github.com/blatinier/pyhunspell
-BuildRequires: hunspell-devel
+BuildRequires: hunspell-devel >= 1.3
+BuildRequires: pkgconfig
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: rpmbuild(macros) >= 1.714
+BuildRequires: sed >= 4.0
 %if %{with python2}
 BuildRequires: python-devel >= 2
-BuildRequires: python-distribute
 %endif
 %if %{with python3}
 BuildRequires: python3-devel >= 1:3.2
-BuildRequires: python3-distribute
 BuildRequires: python3-modules >= 1:3.2
 %endif
 Requires:      python-modules >= 2
@@ -61,42 +61,30 @@ do podstawowywch metod analizy morfologicznej.
 
 %prep
 %setup -q -n %{module}-%{version}
-%patch0 -p1
+
+hunspell_abi="$(pkg-config --modversion hunspell | cut -d. -f1-2)"
+%{__sed} -i -e "/libraries/s/'hunspell'/'hunspell-${hunspell_abi}'/" setup.py
 
 %build
 %if %{with python2}
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python} setup.py build \
-       --build-base build-2
+%py_build
 %endif
 
 %if %{with python3}
-CC="%{__cc}" \
-CFLAGS="%{rpmcflags}" \
-%{__python3} setup.py build \
-       --build-base build-3
+%py3_build
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %if %{with python2}
-%{__python} setup.py \
-       build --build-base build-2 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 
 %py_postclean
 %endif
 
 %if %{with python3}
-%{__python3} setup.py \
-       build --build-base build-3 \
-       install --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 %endif
 
 %clean
@@ -105,7 +93,6 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc README
 %attr(755,root,root) %{py_sitedir}/hunspell.so
 %if "%{py_ver}" > "2.4"
 %{py_sitedir}/hunspell-%{version}-py*.egg-info
@@ -115,7 +102,6 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc README
 %attr(755,root,root) %{py3_sitedir}/hunspell.cpython-*.so
 %{py3_sitedir}/hunspell-%{version}-py*.egg-info
 %endif
This page took 0.068667 seconds and 4 git commands to generate.