]> git.pld-linux.org Git - packages/pylint.git/blobdiff - pylint.spec
Version: 1.5.1
[packages/pylint.git] / pylint.spec
index add2d809a9df6fa1ea3fbbc28f20203649f4107f..17cb0e37ee8e1aac1524b4dc66a939f4bb2cf4e2 100644 (file)
@@ -8,34 +8,39 @@
 Summary:       Python tool that checks if a module satisfy a coding standard
 Summary(pl.UTF-8):     Pythonowe narzędzie sprawdzające zgodność modułu ze standardem kodowania
 Name:          pylint
-Version:       1.0.0
-Release:       3
-License:       GPL
+Version:       1.5.1
+Release:       1
+License:       GPL v2+
 Group:         Development/Languages/Python
-Source0:       https://bitbucket.org/logilab/pylint/get/%{name}-version-%{version}.tar.bz2
-# Source0-md5: 9a83c079c2c608a9156feecf909b7b8a
-Patch0:                %{name}-type_error.patch
+#Source0Download: https://pypi.python.org/pypi/pylint
+Source0:       https://pypi.python.org/packages/source/p/pylint/pylint-%{version}.tar.gz
+# Source0-md5: 60d4be0d6d8d41b251985d7ad65c99eb
 URL:           http://www.pylint.org/
 %if %{with python2}
 BuildRequires: python-devel
-BuildRequires: python-modules >= 2.2.1
+BuildRequires: python-modules >= 1:2.5
+BuildRequires: python-setuptools >= 7.0
 %endif
 %if %{with python3}
-BuildRequires: python-2to3
+BuildRequires: python3-2to3
 BuildRequires: python3-devel
-BuildRequires: python3-distribute
 BuildRequires: python3-modules >= 1:3.2
+BuildRequires: python3-setuptools >= 7.0
 %endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sphinx-pdg
-Requires:      python-logilab-astroid >= 0.24.3
+Requires:      python-astroid >= 1.3.2
 Requires:      python-logilab-common >= 0.53.0
 Requires:      python-modules
+Requires:      python-six
 Suggests:      python-devel-src
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# /etc/pylintrc is deliberately packaged to both packages with same name
+%define                _duplicate_files_terminate_build        0
+
 %description
 Python tool that checks if a module satisfy a coding standard.
 
@@ -60,8 +65,9 @@ Oparty na bibliotece Tk graficzny interfejs użytkownika dla pylinta.
 Summary:       Python tool that checks if a module satisfy a coding standard
 Summary(pl.UTF-8):     Pythonowe narzędzie sprawdzające zgodność modułu ze standardem kodowania
 Group:         Development/Languages/Python
-Requires:      python3-logilab-astroid >= 0.24.3
+Requires:      python3-astroid >= 1.3.2
 Requires:      python3-logilab-common >= 0.53.0
+Requires:      python3-six
 Obsoletes:     pylint-python3 < 1.0.0-2
 
 %description -n py3lint
@@ -90,35 +96,27 @@ Tk based GUI for pylint.
 Oparty na bibliotece Tk graficzny interfejs użytkownika dla pylinta.
 
 %prep
-%setup -qc
-mv logilab-pylint-*/* .
-%patch0 -p1
+%setup -q
 
 %build
 %if %{with python2}
-%{__python} setup.py build
+%py_build
 %endif
 
 %if %{with python3}
-export NO_SETUPTOOLS=1
-%{__python3} setup.py build --build-base=build3
-unset NO_SETUPTOOLS
+%py3_build
 %endif
 
-%{__make} -C doc text
+%{__make} -C doc text \
+       PYTHONPATH=$PWD
 
 %install
 rm -rf $RPM_BUILD_ROOT
-rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1}
 
 %if %{with python3}
-export NO_SETUPTOOLS=1
-%{__python3} setup.py build --build-base=build3 install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 
-unset NO_SETUPTOOLS
 mv $RPM_BUILD_ROOT%{_bindir}/epylint $RPM_BUILD_ROOT%{_bindir}/epy3lint
 mv $RPM_BUILD_ROOT%{_bindir}/pylint $RPM_BUILD_ROOT%{_bindir}/py3lint
 mv $RPM_BUILD_ROOT%{_bindir}/pylint-gui $RPM_BUILD_ROOT%{_bindir}/py3lint-gui
@@ -130,9 +128,7 @@ cp -p man/pyreverse.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3reverse.1
 %endif
 
 %if %{with python2}
-%{__python} setup.py install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 %py_postclean
 cp -p man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 %endif
This page took 0.101441 seconds and 4 git commands to generate.