]> git.pld-linux.org Git - packages/pylint.git/blobdiff - pylint.spec
Version: 1.5.1
[packages/pylint.git] / pylint.spec
index a784f1f2b4d2e6158ff71b0e049635eb3e87d206..17cb0e37ee8e1aac1524b4dc66a939f4bb2cf4e2 100644 (file)
@@ -8,40 +8,45 @@
 Summary:       Python tool that checks if a module satisfy a coding standard
 Summary(pl.UTF-8):     Pythonowe narzędzie sprawdzające zgodność modułu ze standardem kodowania
 Name:          pylint
-Version:       1.0.0
+Version:       1.5.1
 Release:       1
-License:       GPL
+License:       GPL v2+
 Group:         Development/Languages/Python
-Source0:       https://bitbucket.org/logilab/pylint/get/%{name}-version-%{version}.tar.bz2
-# Source0-md5: 9a83c079c2c608a9156feecf909b7b8a
-Patch0:                %{name}-type_error.patch
+#Source0Download: https://pypi.python.org/pypi/pylint
+Source0:       https://pypi.python.org/packages/source/p/pylint/pylint-%{version}.tar.gz
+# Source0-md5: 60d4be0d6d8d41b251985d7ad65c99eb
 URL:           http://www.pylint.org/
 %if %{with python2}
 BuildRequires: python-devel
-BuildRequires: python-modules >= 2.2.1
+BuildRequires: python-modules >= 1:2.5
+BuildRequires: python-setuptools >= 7.0
 %endif
 %if %{with python3}
 BuildRequires: python3-2to3
 BuildRequires: python3-devel
-BuildRequires: python3-distribute
 BuildRequires: python3-modules >= 1:3.2
+BuildRequires: python3-setuptools >= 7.0
 %endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sphinx-pdg
-%pyrequires_eq python-modules
-Requires:      python-logilab-astng >= 0.24.3
+Requires:      python-astroid >= 1.3.2
 Requires:      python-logilab-common >= 0.53.0
+Requires:      python-modules
+Requires:      python-six
 Suggests:      python-devel-src
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# /etc/pylintrc is deliberately packaged to both packages with same name
+%define                _duplicate_files_terminate_build        0
+
 %description
 Python tool that checks if a module satisfy a coding standard.
 
 %description -l pl.UTF-8
-Narzędzie sprawdzające zgodność modułów napisanych w języku Python
-regułami tworzenia kodu źródłowego.
+Narzędzie sprawdzające zgodność modułów napisanych w języku Python z
+regułami tworzenia kodu źródłowego.
 
 %package gui
 Summary:       GUI for pylint
@@ -56,87 +61,79 @@ Tk based GUI for pylint.
 %description gui -l pl.UTF-8
 Oparty na bibliotece Tk graficzny interfejs użytkownika dla pylinta.
 
-%package python3
+%package -n py3lint
 Summary:       Python tool that checks if a module satisfy a coding standard
 Summary(pl.UTF-8):     Pythonowe narzędzie sprawdzające zgodność modułu ze standardem kodowania
 Group:         Development/Languages/Python
-Requires:      python3-logilab-astng >= 0.24.3
+Requires:      python3-astroid >= 1.3.2
 Requires:      python3-logilab-common >= 0.53.0
+Requires:      python3-six
+Obsoletes:     pylint-python3 < 1.0.0-2
 
-%description python3
+%description -n py3lint
 Python tool that checks if a module satisfy a coding standard.
 
 Python 3.x version, available via the 'py3lint' command.
 
-%description python3 -l pl.UTF-8
-Narzędzie sprawdzające zgodność modułów napisanych w języku Python
-regułami tworzenia kodu źródłowego.
+%description -n py3lint -l pl.UTF-8
+Narzędzie sprawdzające zgodność modułów napisanych w języku Python z
+regułami tworzenia kodu źródłowego.
 
 Wersja dla Pythona 3.x, dostępna przez polecenie 'py3lint'.
 
-%package python3-gui
+%package -n py3lint-gui
 Summary:       GUI for pylint
 Summary(pl.UTF-8):     Graficzny interfejs użytkownika dla pylinta
 Group:         Development/Languages/Python
-Requires:      %{name}-python3 = %{version}-%{release}
+Requires:      py3lint = %{version}-%{release}
 Requires:      python3-tkinter
+Obsoletes:     pylint-python3-gui < 1.0.0-2
 
-%description python3-gui
+%description -n py3lint-gui
 Tk based GUI for pylint.
 
-%description python3-gui -l pl.UTF-8
+%description -n py3lint-gui -l pl.UTF-8
 Oparty na bibliotece Tk graficzny interfejs użytkownika dla pylinta.
 
 %prep
-%setup -q -c
-cd logilab-pylint-*
-%patch0 -p1
+%setup -q
 
 %build
-cd logilab-pylint-*
 %if %{with python2}
-%{__python} setup.py build
+%py_build
 %endif
 
 %if %{with python3}
-export NO_SETUPTOOLS=1
-%{__python3} setup.py build --build-base=build3
-unset NO_SETUPTOOLS
+%py3_build
 %endif
 
-%{__make} -C doc text
+%{__make} -C doc text \
+       PYTHONPATH=$PWD
 
 %install
-cd logilab-pylint-*
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1}
 
 %if %{with python3}
-export NO_SETUPTOOLS=1
-%{__python3} setup.py build --build-base=build3 install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py3_install
 
-unset NO_SETUPTOOLS
 mv $RPM_BUILD_ROOT%{_bindir}/epylint $RPM_BUILD_ROOT%{_bindir}/epy3lint
 mv $RPM_BUILD_ROOT%{_bindir}/pylint $RPM_BUILD_ROOT%{_bindir}/py3lint
 mv $RPM_BUILD_ROOT%{_bindir}/pylint-gui $RPM_BUILD_ROOT%{_bindir}/py3lint-gui
 mv $RPM_BUILD_ROOT%{_bindir}/pyreverse $RPM_BUILD_ROOT%{_bindir}/py3reverse
-install man/epylint.1 $RPM_BUILD_ROOT%{_mandir}/man1/epy3lint.1
-install man/pylint.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3lint.1
-install man/pylint-gui.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3lint-gui.1
-install man/pyreverse.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3reverse.1
+cp -p man/epylint.1 $RPM_BUILD_ROOT%{_mandir}/man1/epy3lint.1
+cp -p man/pylint.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3lint.1
+cp -p man/pylint-gui.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3lint-gui.1
+cp -p man/pyreverse.1 $RPM_BUILD_ROOT%{_mandir}/man1/py3reverse.1
 %endif
 
 %if %{with python2}
-%{__python} setup.py install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%py_install
 %py_postclean
-install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
+cp -p man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 %endif
 
-install examples/pylintrc $RPM_BUILD_ROOT%{_sysconfdir}/pylintrc
+cp -p examples/pylintrc $RPM_BUILD_ROOT%{_sysconfdir}/pylintrc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -144,7 +141,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc logilab-pylint-*/{ChangeLog,README,examples/*,doc/_build/text/*.txt}
+%doc ChangeLog README examples/* doc/_build/text/*.txt
 %attr(755,root,root) %{_bindir}/epylint
 %attr(755,root,root) %{_bindir}/pylint
 %attr(755,root,root) %{_bindir}/pyreverse
@@ -164,22 +161,21 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %if %{with python3}
-%files python3
+%files -n py3lint
 %defattr(644,root,root,755)
-%doc logilab-pylint-*/{ChangeLog,README,examples/*,doc/_build/text/*.txt}
+%doc ChangeLog README examples/* doc/_build/text/*.txt
 %attr(755,root,root) %{_bindir}/epy3lint
 %attr(755,root,root) %{_bindir}/py3lint
 %attr(755,root,root) %{_bindir}/py3reverse
-#%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
 %{py3_sitescriptdir}/pylint
 %{py3_sitescriptdir}/pylint-%{version}-py*.egg-info
 %{_mandir}/man1/epy3lint.1*
 %{_mandir}/man1/py3lint.1*
 %{_mandir}/man1/py3reverse.1*
 
-%files python3-gui
+%files -n py3lint-gui
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/py3lint-gui
 %{_mandir}/man1/py3lint-gui.1*
 %endif
-
This page took 0.105115 seconds and 4 git commands to generate.