]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
option --with-onig has been removed. Unless --disable-mbregex has been passed, liboni...
[packages/php.git] / php.spec
index b3eaf0c3db89ff8adc5a14e4e754a169ece15fc7..8416bdf0f6c74d37719d6bff3afd85079b301a24 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2,7 +2,6 @@
 # - mysqlnd driver doesn't support reconnect: https://bugs.php.net/bug.php?id=52561
 # TODO 7.4:
 # - follow upstream: drop spl, pcre, hash subpackages (tired of maintaining them)
-# - handle acinclude.m4 -> build/php.m4 rename
 # TODO 7.3:
 # - branch php-7.2 and merge dev-7.3 into head once official announcement ready
 # TODO 7.2:
 %undefine      with_filter
 %endif
 
-%define                subver %{nil}
+%define                subver alpha1
 %define                orgname php
 %define                ver_suffix 74
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -165,10 +164,9 @@ Epoch:             4
 # TSRM is licensed under BSD
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
-#Source0:      https://downloads.php.net/~cmb/php-%{version}%{subver}.tar.xz
 #Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
-Source0:       https://github.com/php/php-src/archive/PHP-7.4/%{orgname}-%{version}.tar.gz
-# Source0-md5: 5ddd943d45880a2fa7389b6fc4aeec3a
+Source0:       https://downloads.php.net/~derick/php-%{version}%{subver}.tar.xz
+# Source0-md5: 29592e9a73c0ae615c4b7e2b4761184f
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -309,9 +307,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20180731
-%define                zend_module_api         20180731
-%define                zend_extension_api      320180731
+%define                php_api_version         20190529
+%define                zend_module_api         %{php_api_version}
+%define                zend_extension_api      3%{zend_module_api}
 %define                php_pdo_api_version     20170320
 
 # Extension versions
@@ -1956,11 +1954,7 @@ compression support to PHP.
 Moduł PHP umożliwiający używanie kompresji zlib.
 
 %prep
-%if 0
 %setup -q -n %{orgname}-%{version}%{?subver}
-%else
-%setup -q -n php-src-PHP-7.4
-%endif
 cp -p php.ini-production php.ini
 %patch0 -p1
 %patch1 -p1
@@ -2209,8 +2203,13 @@ export EXTENSION_DIR="%{php_extensiondir}"
 if [ ! -f _built-conf ]; then
        # now remove Makefile copies
        rm -f Makefile.{cgi-fcgi,fpm,cli,apxs1,apxs2,litespeed,phpdbg,milter}
+
+       # Force use of system libtool:
+       mv build/libtool.m4 build/libtool.m4.saved
+       cat %{_aclocaldir}/{libtool,ltoptions,ltsugar,ltversion,lt~obsolete}.m4 > build/libtool.m4
        %{__libtoolize}
        %{__aclocal}
+
        cp -f /usr/share/automake/config.* .
        ./buildconf --force
        touch _built-conf
@@ -2314,9 +2313,8 @@ for sapi in $sapis; do
        %{__enable_disable fileinfo fileinfo shared} \
        %{__enable_disable ftp ftp shared} \
        %{?with_intl:--enable-intl=shared} \
-       --enable-libxml \
+       --with-libxml \
        %{__enable_disable mbstring mbstring shared,all} \
-       --with-onig=/usr \
        --enable-mbregex \
        %{__enable_disable pcntl pcntl shared} \
        %{__enable_disable pdo pdo shared} \
This page took 0.037675 seconds and 4 git commands to generate.