]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
Up to 8.1.3.
[packages/php.git] / php.spec
index 967dd40e99046ee26970521ce6d2d730b01456ec..4ec9c3b8d4cc101fe1991afc94a0f584be8ceed6 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -85,6 +85,7 @@
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
 %bcond_with    mm              # without mm support for session storage
 %bcond_without system_gd       # system gd
+%bcond_without avif            # Without AVIF support in GD extension (imagecreatefromavif and imageavif)
 %bcond_without webp            # Without WebP support in GD extension (imagecreatefromwebp)
 
 %define        apxs2           /usr/sbin/apxs
 %endif
 
 %define                orgname php
-%define                ver_suffix 80
+%define                ver_suffix 81
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
@@ -147,7 +148,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       8.0.7
+Version:       8.1.3
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -156,7 +157,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: ee5d675f8e9d58fcdc4c887d3d9e8412
+# Source0-md5: 495972570d055fef1255e296051a13a5
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -174,7 +175,6 @@ Patch2:             %{orgname}-mail.patch
 Patch3:                %{orgname}-link-libs.patch
 Patch4:                intl-stdc++.patch
 Patch7:                %{orgname}-sapi-ini-file.patch
-Patch9:                libtool-tag.patch
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
 Patch14:       %{orgname}-no_pear_install.patch
@@ -226,6 +226,7 @@ BuildRequires:      gmp-devel >= 4.2
 %{?with_gcov:BuildRequires:    lcov}
 %{?with_fpm:BuildRequires:     libapparmor-devel}
 %{?with_argon2:BuildRequires:  libargon2-devel >= 20161029}
+%{?with_avif:BuildRequires:    libavif-devel >= 0.8.2}
 %{?with_ffi:BuildRequires:     libffi-devel}
 %{?with_intl:BuildRequires:    libicu-devel >= 50.1}
 BuildRequires: libjpeg-devel
@@ -234,7 +235,7 @@ BuildRequires:      libpng-devel >= 1.0.8
 %{?with_sodium:BuildRequires:  libsodium-devel >= 1.0.8}
 %{?with_intl:BuildRequires:    libstdc++-devel}
 BuildRequires: libtool >= 2:2.4.6
-%{?with_webp:BuildRequires:    libwebp-devel}
+%{?with_webp:BuildRequires:    libwebp-devel >= 0.2.0}
 BuildRequires: libxml2-devel >= 1:2.7.6-4
 %{?with_xsl:BuildRequires:     libxslt-devel >= 1.1.0}
 %{?with_zip:BuildRequires:     libzip-devel >= 1.3.1}
@@ -246,7 +247,7 @@ BuildRequires:      libxml2-devel >= 1:2.7.6-4
 BuildRequires: oniguruma-devel
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
 %if %{with openssl} || %{with ldap}
-BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: openssl-devel >= 1.0.2
 %endif
 %{?with_oci:%{?with_instantclient:BuildRequires:       oracle-instantclient-devel}}
 BuildRequires: pam-devel
@@ -259,7 +260,7 @@ BuildRequires:      rpm-build >= 4.4.0
 BuildRequires: rpmbuild(macros) >= 1.566
 BuildRequires: sed >= 4.0
 %if %{with sqlite3} || %{with pdo_sqlite}
-BuildRequires: sqlite3-devel >= 3.7.4
+BuildRequires: sqlite3-devel >= 3.7.7
 %endif
 %{?with_systemtap:BuildRequires:       systemtap-sdt-devel}
 BuildRequires: tar >= 1:1.22
@@ -280,7 +281,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20200930
+%define                php_api_version         20210902
 %define                zend_module_api         %{php_api_version}
 %define                zend_extension_api      4%{zend_module_api}
 %define                php_pdo_api_version     20170320
@@ -294,7 +295,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         %{version}
 %define                pharver         %{version}
 %define                sqlite3ver      %{version}
-%define                zipver          1.19.2
+%define                zipver          1.19.5
 %define                phpdbgver       %{version}
 %define                sodiumver       %{version}
 
@@ -460,6 +461,18 @@ Summary(pl.UTF-8): Dowiązanie symboliczne /usr/bin/php
 Group:         Development/Languages/PHP
 Requires:      %{name}-cli = %{epoch}:%{version}-%{release}
 Obsoletes:     php-program < 4:5.3.28-7
+Obsoletes:     php4-program
+Obsoletes:     php52-program
+Obsoletes:     php53-program
+Obsoletes:     php54-program
+Obsoletes:     php55-program
+Obsoletes:     php56-program
+Obsoletes:     php70-program
+Obsoletes:     php71-program
+Obsoletes:     php72-program
+Obsoletes:     php73-program
+Obsoletes:     php74-program
+Obsoletes:     php80-program
 
 %description program
 Package providing /usr/bin/php symlink to PHP CLI.
@@ -618,6 +631,7 @@ Obsoletes:  php70-devel
 Obsoletes:     php71-devel
 Obsoletes:     php73-devel
 Obsoletes:     php74-devel
+Obsoletes:     php80-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -1853,7 +1867,6 @@ cp -p php.ini-production php.ini
 %patch4 -p1
 
 %patch7 -p1 -b .sapi-ini-file
-%patch9 -p1
 %patch10 -p1 -b .ini
 %patch14 -p1
 %patch18 -p1
@@ -2190,6 +2203,7 @@ for sapi in $sapis; do
        %{__enable_disable pcntl pcntl shared} \
        %{__enable_disable pdo pdo shared} \
        --enable-xmlwriter=shared \
+       %{?with_avif:--with-avif} \
 %if %{with fpm}
        --with-fpm-user=http \
        --with-fpm-group=http \
@@ -3229,7 +3243,6 @@ fi
 %{php_data_dir}/tests/php/run-test
 %{php_data_dir}/tests/php/security
 %{php_data_dir}/tests/php/strings
-%{php_data_dir}/tests/php/quicktester.inc
 %attr(755,root,root) %{php_data_dir}/tests/php/run-tests.php
 
 %if %{with tidy}
This page took 0.02989 seconds and 4 git commands to generate.