]> git.pld-linux.org Git - packages/perl-SDL.git/blobdiff - perl-SDL.spec
- rebuild with perl 5.28.0
[packages/perl-SDL.git] / perl-SDL.spec
index d7fd01d9f29a17e0916e68eaa2ec69efcf10aa30..610eb174d36823f488b4a79e4e116b3505322983 100644 (file)
@@ -1,45 +1,34 @@
 #
 # Conditional build:
-# _without_tests - do not perform "make test"
+%bcond_without tests   # do not perform "make test"
 #
 %include       /usr/lib/rpm/macros.perl
-Summary:       SDL Perl module
-Summary(cs):   Modul SDL pro Perl
-Summary(da):   Perlmodul SDL
-Summary(de):   SDL Perl Modul
-Summary(es):   Módulo de Perl SDL
-Summary(fr):   Module Perl SDL
-Summary(it):   Modulo di Perl SDL
-Summary(ja):   SDL Perl ¥â¥¸¥å¡¼¥ë
-Summary(ko):   SDL ÆÞ ¸ðÁÙ
-Summary(no):   Perlmodul SDL
-Summary(pl):   Modu³ Perla SDL
-Summary(pt):   Módulo de Perl SDL
-Summary(pt_BR):        Módulo Perl SDL
-Summary(ru):   íÏÄÕÌØ ÄÌÑ Perl SDL
-Summary(sv):   SDL Perlmodul
-Summary(uk):   íÏÄÕÌØ ÄÌÑ Perl SDL
-Summary(zh_CN):        SDL Perl Ä£¿é
+Summary:       Simple DirectMedia Layer Perl
+Summary(pl.UTF-8):     Interfejs Simple DirectMedia Layer dla Perla
 Name:          perl-SDL
-Version:       1.20.0
-Release:       3
+Version:       2.1.3
+Release:       15
 License:       LGPL
 Group:         Development/Languages/Perl
-Source0:       ftp://sdlperl.org/SDL_perl/SDL_perl-%{version}.tar.gz
-# Source0-md5: 041617aec124677083ecef04aa48f927
-Patch0:                %{name}-detection.patch
-URL:           http://sdlperl.org/
-BuildRequires: OpenGL-devel
+Source0:       http://www.cpan.org/modules/by-authors/id/D/DG/DGOEHRIG/SDL_Perl-%{version}.tar.gz
+# Source0-md5: 6ce26e1b710ce52def4ec22637cd5176
+Patch0:                %{name}-gfxPie.patch
+Patch1:                %{name}-no-mixertest.patch
+URL:           http://search.cpan.org/dist/SDL_Perl/
+BuildRequires: OpenGL-GLU-devel
 BuildRequires: SDL-devel
-BuildRequires: SDL_gfx-devel
+BuildRequires: SDL_gfx-devel >= 2.0.10
 BuildRequires: SDL_image-devel
 BuildRequires: SDL_mixer-devel
 BuildRequires: SDL_net-devel
 BuildRequires: SDL_ttf-devel
-BuildRequires: glut-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
-BuildRequires: perl-devel >= 5.6
+BuildRequires: perl-ExtUtils-CBuilder
+BuildRequires: perl-Module-Build
+BuildRequires: perl-Test-Simple
+BuildRequires: perl-YAML
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: smpeg-devel
 Provides:      perl(SDL::OpenGL)
@@ -51,28 +40,43 @@ and object orient interfaces to the Simple DirectMedia Layer for Perl
 5. This package does take some liberties with the SDL API, and
 attempts to adhere to the spirit of both the SDL and Perl.
 
-%description -l pl
-SDL_perl to pakiet z modu³ami perla udostêpniaj±cy z poziomu Perla
-interfejsy zarówno funkcjonalne, jak i zorientowane obiektowo do
-biblioteki SDL (Simple DirectMedia Layer). Pakiet przejmuje trochê
-swobody z API SDL i próbuje siê dopasowaæ do idei SDL oraz Perla.
+%description -l pl.UTF-8
+SDL_perl to pakiet z modułami Perla udostępniający z poziomu Perla
+interfejsy zarówno funkcjonalne, jak i zorientowane obiektowo do
+biblioteki SDL (Simple DirectMedia Layer). Pakiet przejmuje trochę
+swobody z API SDL i próbuje się dopasować do idei SDL oraz Perla.
 
 %prep
-%setup -q -n SDL_perl-%{version}
-%patch0 -p1
+%setup -q -n SDL_Perl-%{version}
+%patch0 -p0
+%patch1 -p1
+
+mv t/mixerpm.t{,.blah} # requires audio device
 
 %build
-%{__perl} Makefile.PL \
-       INSTALLDIRS=vendor 
-%{__make} OPTIMIZE="%{rpmcflags} -I/usr/X11R6/include"
+%{__perl} Build.PL \
+       installdirs=vendor \
+       perl=%{__perl} \
+       destdir=$RPM_BUILD_ROOT \
+       config='optimize=%{rpmcflags}' \
+       config='lddlflags=-shared %{rpmldflags}'
+./Build
+
+# <sigh> I don't know why but for some reason these dirs get put under
+# blib/arch/auto/src instead of blib/arch/auto causing them to be installed
+# in the wrong location and "./Build test" to fail. We copy them because if
+# we move them the next call to ./Build will recreate them in the wrong
+# location anyways. Unfortunatly with the copy the wrong located originals
+# will also end up getting installed so we must remove those in %%install
+cp -r blib/arch/auto/src/SDL* blib/arch/auto
 
-%{!?_without_tests:%{__make} test}
+%{?with_tests:./Build test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+./Build install
+rm -rf $RPM_BUILD_ROOT%{perl_vendorarch}/auto/src
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -81,8 +85,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc BUGS CHANGELOG TODO README
 %{_mandir}/man3/*
-%{perl_vendorarch}/SDL*
+%{perl_vendorarch}/SDL*.pm
+%{perl_vendorarch}/SDL
+%dir %{perl_vendorarch}/auto/SDL
 %dir %{perl_vendorarch}/auto/SDL_perl
-%{perl_vendorarch}/auto/SDL_perl/SDL_perl.bs
-%{perl_vendorarch}/auto/SDL/autosplit.ix
 %attr(755,root,root) %{perl_vendorarch}/auto/SDL_perl/SDL_perl.so
+%dir %{perl_vendorarch}/auto/SDL/OpenGL
+%attr(755,root,root)%{perl_vendorarch}/auto/SDL/OpenGL/OpenGL.so
+%dir %{perl_vendorarch}/auto/SDL/SFont
+%attr(755,root,root)%{perl_vendorarch}/auto/SDL/SFont/SFont.so
This page took 0.033427 seconds and 4 git commands to generate.