]> git.pld-linux.org Git - packages/perl-PadWalker.git/blobdiff - perl-PadWalker.spec
- release 3 (by relup.sh)
[packages/perl-PadWalker.git] / perl-PadWalker.spec
index 1d0d20e47eb804d47e635517da65eb8a07592d9b..cca13a51d312ea441d98208563dbfe314402b61b 100644 (file)
@@ -1,30 +1,34 @@
 #
 # Conditional build:
-# _without_tests - do not perform "make test"
+%bcond_without tests # do not perform "make test"
 #
 %include       /usr/lib/rpm/macros.perl
-%define        pdir    PadWalker
+%define                pdir    PadWalker
 Summary:       PadWalker - play with other peoples' lexical variables
-#Summary(pl):  
+Summary(pl.UTF-8):     PadWalker - igranie z cudzymi zmiennymi leksykalnymi
 Name:          perl-PadWalker
-Version:       0.10
-Release:       1
+Version:       1.99
+Release:       3
 # same as perl
-License:       GPL/Artistic
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-authors/id/R/RO/ROBIN/%{pdir}-%{version}.tar.gz
-# Source0-md5: e6f48685932c1a1896872daf1aff9e3d
-BuildRequires: perl-devel >= 5.6
+# Source0-md5: 76025e0bb1366ef41bd851c31b7e9a42
+URL:           http://search.cpan.org/dist/PadWalker/
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-PadWalker is a module which allows you to inspect (and even change!)
-lexical variables in any subroutine which called you. It will only show
-those variables which are in scope at the point of the call.
+PadWalker is a Perl module which allows you to inspect (and even
+change!) lexical variables in any subroutine which called you. It will
+only show those variables which are in scope at the point of the call.
 
-# %description -l pl
-# TODO
+%description -l pl.UTF-8
+PadWalker jest modułem Perla umożliwiającym przeglądanie (a nawet
+modyfikacje!) zmiennych leksykalnych w dowolnej wywołanej funkcji.
+Pokazuje on tylko te zmienne, których zasięg obejmuje miejsce
+wywołania.
 
 %prep
 %setup -q -n %{pdir}-%{version}
@@ -32,9 +36,11 @@ those variables which are in scope at the point of the call.
 %build
 %{__perl} Makefile.PL \
        INSTALLDIRS=vendor
-%{__make} OPTIMIZE="%{rpmcflags}"
+%{__make} \
+       CC="%{__cc}" \
+       OPTIMIZE="%{rpmcflags}"
 
-%{!?_without_tests:%{__make} test}
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -51,5 +57,4 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_vendorarch}/*.pm
 %dir %{perl_vendorarch}/auto/%{pdir}
 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/*.so
-%{perl_vendorarch}/auto/%{pdir}/*.bs
 %{_mandir}/man3/*
This page took 0.09638 seconds and 4 git commands to generate.