]> git.pld-linux.org Git - packages/owncloudclient.git/blobdiff - owncloudclient.spec
- release 2 (by relup.sh)
[packages/owncloudclient.git] / owncloudclient.spec
index a015622b79e52f068242d272cc809462a8463238..38348d224392e6df310b4634c775c1e3a909c876 100644 (file)
@@ -1,12 +1,14 @@
 #
 # Conditional build:
 %bcond_without nautilus        # build Nautilus extension
+%bcond_without caja            # build caja extension
 %bcond_with    dolphin         # build dolphin extension
 %bcond_without doc             # build docs
 %bcond_without gui             # build only libraries
 
 %if %{without gui}
 %undefine      with_nautilus
+%undefine      with_caja
 %undefine      with_dolphin
 %undefine      with_doc
 %endif
 %define                qtver   5.4
 Summary:       The ownCloud client
 Name:          owncloudclient
-Version:       2.1.1
-Release:       0.16
+Version:       2.3.3
+Release:       2
 License:       GPL v2+
 Group:         X11/Applications
 Source0:       https://download.owncloud.com/desktop/stable/%{name}-%{version}.tar.xz
-# Source0-md5: 63a971158201a8dffe96a02c54b86819
+# Source0-md5: bba20fc6f38e0b14f6ceb9ab432d1802
+Patch0:                syslibs.patch
 URL:           https://www.owncloud.com/
-BuildRequires: Qt5Concurrent-devel
+BuildRequires: Qt5Concurrent-devel >= %{qtver}
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: Qt5DBus-devel >= %{qtver}
 BuildRequires: Qt5Gui-devel >= %{qtver}
 BuildRequires: Qt5Keychain-devel
 BuildRequires: Qt5Network-devel >= %{qtver}
-BuildRequires: Qt5Sql-devel >= %{qtver}
 BuildRequires: Qt5WebKit-devel >= %{qtver}
 BuildRequires: Qt5Xml-devel >= %{qtver}
-BuildRequires: Qt5XmlPatterns-devel >= %{qtver}
 BuildRequires: cmake >= 2.8.11
 BuildRequires: libstdc++-devel
 BuildRequires: openssl-devel >= 1.0.0
@@ -41,9 +42,16 @@ BuildRequires:       rpmbuild(macros) >= 1.596
 BuildRequires: sqlite3-devel >= 3.8.0
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
+BuildRequires: zlib-devel
+%if %{with gui}
+BuildRequires: Qt5LockedFile-devel >= 2.4
+BuildRequires: Qt5SingleApplication-devel >= 2.6.1-3
+BuildRequires: Qt5Sql-devel >= %{qtver}
+BuildConflicts:        QtLockedFile-devel
+%endif
 %if %{with dolphin}
 BuildRequires: kf5-attica-devel >= 5.16
-BuildRequires: kf5-extra-cmake-modules >= 5.16
+BuildRequires: kf5-extra-cmake-modules >= 1.2.0
 BuildRequires: kf5-kconfig-devel >= 5.16
 BuildRequires: kf5-ki18n-devel >= 5.16
 BuildRequires: kf5-kio-devel >= 5.16
@@ -60,6 +68,7 @@ BuildRequires:        texlive-xetex
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      Qt5Gui-platform-xcb
+Requires:      Qt5SingleApplication >= 2.6.1-3
 Requires:      desktop-file-utils
 Requires:      gtk-update-icon-cache
 Requires:      hicolor-icon-theme
@@ -128,8 +137,22 @@ Requires:  nautilus-python
 This package provides overlay icons to visualize the sync state in the
 Nautilus file manager.
 
+%package caja
+Summary:       Caja overlay icons
+Group:         Applications
+Requires:      %{name} = %{version}-%{release}
+Requires:      caja-python
+
+%description caja
+This package provides overlay icons to visualize the sync state in the
+Caja file manager.
+
 %prep
 %setup -q
+%patch0 -p1
+
+mv src/3rdparty/qtlockedfile .
+mv src/3rdparty/qtsingleapplication .
 
 %build
 install -d build
@@ -146,11 +169,13 @@ cd build
        -DCMAKE_INSTALL_DOCDIR=%{_docdir}/%{name} \
 %else
        -DWITH_DOC=NO \
-       -DSPHINX_FOUND=NO \
-       -DDOXYGEN_FOUND=NO \
+       -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=TRUE \
+       -DCMAKE_DISABLE_FIND_PACKAGE_PdfLatex=TRUE \
+       -DCMAKE_DISABLE_FIND_PACKAGE_Sphinx=TRUE \
 %endif
 %if %{without dolphin}
-       -DKF5_FOUND=NO \
+       -DCMAKE_DISABLE_FIND_PACKAGE_ECM=TRUE \
+       -DCMAKE_DISABLE_FIND_PACKAGE_KF5=TRUE \
 %endif
        %{!?with_gui:-DBUILD_LIBRARIES_ONLY=ON} \
        ..
@@ -171,7 +196,7 @@ mv $RPM_BUILD_ROOT%{_libdir}/owncloud/libocsync.so* $RPM_BUILD_ROOT%{_libdir}
 
 %if %{with nautilus}
 # nemo not in pld
-%{__rm} $RPM_BUILD_ROOT%{_datadir}/nemo-python/extensions/syncstate.py*
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/nemo-python/extensions/syncstate-ownCloud.py*
 %endif
 
 %clean
@@ -192,8 +217,6 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README.md COPYING
-%dir %{_sysconfdir}/ownCloud
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ownCloud/*
 %attr(755,root,root) %{_bindir}/owncloud
 %attr(755,root,root) %{_bindir}/owncloudcmd
 %{_desktopdir}/owncloud.desktop
@@ -208,6 +231,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libs
 %defattr(644,root,root,755)
+%dir %{_sysconfdir}/ownCloud
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ownCloud/sync-exclude.lst
 %attr(755,root,root) %{_libdir}/libowncloudsync.so.*.*.*
 %ghost %{_libdir}/libowncloudsync.so.0
 %attr(755,root,root) %{_libdir}/libocsync.so.*.*.*
@@ -222,7 +247,13 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with nautilus}
 %files nautilus
 %defattr(644,root,root,755)
-%{_datadir}/nautilus-python/extensions/syncstate.py*
+%{_datadir}/nautilus-python/extensions/syncstate-ownCloud.py*
+%endif
+
+%if %{with caja}
+%files caja
+%defattr(644,root,root,755)
+%{_datadir}/caja-python/extensions/syncstate-ownCloud.py*
 %endif
 
 %if %{with doc}
This page took 0.106872 seconds and 4 git commands to generate.