]> git.pld-linux.org Git - packages/netsurf.git/blobdiff - netsurf.spec
- bcond js. Javascript support is very poor
[packages/netsurf.git] / netsurf.spec
index 830391c49e827afc284a5ed3e3d51c15a6a25623..cb5c343889bc256ac4515fab4b3fae16cb1a6a41 100644 (file)
@@ -1,46 +1,48 @@
 #
 # Conditional build:
 %bcond_without gstreamer       # GStreamer-based video support
+%bcond_without js              # Javascript
 %bcond_with    pdf             # PDF export and GTK+ printing support via libharu [needs update?]
 %bcond_without webp            # WebP image support
 #
 Summary:       Light WWW browser with CSS support
 Summary(pl.UTF-8):     Lekka przeglądarka WWW z obsługą CSS
 Name:          netsurf
-Version:       3.1
+Version:       3.2
 Release:       2
 License:       GPL v2 with OpenSSL exception (code), MIT (artwork)
 Group:         Applications/Networking
 Source0:       http://download.netsurf-browser.org/netsurf/releases/source/%{name}-%{version}-src.tar.gz
-# Source0-md5: b83932b311716054a5189f121cdd5fd4
+# Source0-md5: 8b49a31345e2902fd962fcc11a1eedc2
 Source1:       %{name}.desktop
 Patch0:                nsfb-ldflags.patch
 Patch1:                %{name}-link.patch
 Patch2:                no-Werror.patch
+Patch3:                optflags.patch
 URL:           http://netsurf-browser.org/
 BuildRequires: curl-devel
 BuildRequires: freetype-devel >= 2
 %{?with_gstreamer:BuildRequires:       gstreamer0.10-devel >= 0.10}
 BuildRequires: gtk+2-devel >= 2.0
-BuildRequires: js185-devel
-BuildRequires: libCSS-devel >= 0.3.0
-BuildRequires: libdom-devel >= 0.1.0
+%{?with_js:BuildRequires:      js185-devel}
+BuildRequires: libCSS-devel >= 0.4.0
+BuildRequires: libdom-devel >= 0.1.1
 BuildRequires: libglade2-devel
 %{?with_pdf:BuildRequires:     libharu-devel}
 BuildRequires: libhubbub-devel >= 0.3.0
 BuildRequires: libjpeg-devel
 BuildRequires: libnsbmp-devel >= 0.1.1
-BuildRequires: libnsfb-devel >= 0.1.1
+BuildRequires: libnsfb-devel >= 0.1.2
 BuildRequires: libnsgif-devel >= 0.1.1
 BuildRequires: libparserutils-devel >= 0.2.0
 BuildRequires: libpng-devel
 BuildRequires: librsvg-devel
-BuildRequires: libsvgtiny-devel >= 0.1.1
+BuildRequires: libsvgtiny-devel >= 0.1.2
 BuildRequires: libwapcaplet-devel >= 0.2.1
 %{?with_webp:BuildRequires:    libwebp-devel}
 BuildRequires: openssl-devel
-BuildRequires: netsurf-buildsystem >= 1.1
-BuildRequires: nsgenbind >= 0.1.0
+BuildRequires: netsurf-buildsystem >= 1.2
+BuildRequires: nsgenbind >= 0.1.1
 BuildRequires: perl-HTML-Parser
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
@@ -72,13 +74,13 @@ Summary:    NetSurf web browser - GTK+ version
 Summary(pl.UTF-8):     Wersja GTK+ przeglądarki WWW NetSurf
 Group:         Applications/Networking
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      libCSS >= 0.3.0
-Requires:      libdom >= 0.1.0
+Requires:      libCSS >= 0.4.0
+Requires:      libdom >= 0.1.1
 Requires:      libhubbub >= 0.3.0
 Requires:      libnsbmp >= 0.1.1
 Requires:      libnsgif >= 0.1.1
 Requires:      libparserutils >= 0.2.0
-Requires:      libsvgtiny >= 0.1.1
+Requires:      libsvgtiny >= 0.1.2
 Requires:      libwapcaplet >= 0.2.1
 
 %description gtk
@@ -100,14 +102,14 @@ Summary:  NetSurf web browser - SDL version
 Summary(pl.UTF-8):     Wersja SDL przeglądarki WWW NetSurf
 Group:         Applications/Networking
 Requires:      %{name}-common = %{version}-%{release}
-Requires:      libCSS >= 0.3.0
-Requires:      libdom >= 0.1.0
+Requires:      libCSS >= 0.4.0
+Requires:      libdom >= 0.1.1
 Requires:      libhubbub >= 0.3.0
 Requires:      libnsbmp >= 0.1.1
-Requires:      libnsfb >= 0.1.1
+Requires:      libnsfb >= 0.1.2
 Requires:      libnsgif >= 0.1.1
 Requires:      libparserutils >= 0.2.0
-Requires:      libsvgtiny >= 0.1.1
+Requires:      libsvgtiny >= 0.1.2
 Requires:      libwapcaplet >= 0.2.1
 
 %description sdl
@@ -129,6 +131,7 @@ Ten pakiet zawiera wersję SDL.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 cat << EOF > Makefile.config
 NETSURF_FB_FONTLIB := freetype
@@ -138,6 +141,14 @@ NETSURF_USE_RSVG := YES
 %{?with_webp:NETSURF_USE_WEBP := YES}
 %{?with_gstreamer:NETSURF_USE_VIDEO := YES}
 %{?with_pdf:NETSURF_USE_HARU_PDF := YES}
+# js185
+%if %{with js}
+NETSURF_USE_MOZJS := YES
+%else
+NETSURF_USE_MOZJS := NO
+%endif
+# xulrunner
+NETSURF_USE_JS := NO
 EOF
 
 %if %{with gstreamer}
@@ -152,17 +163,22 @@ export CXX="%{__cxx}"
 # silence -Werror:
 #src/surface/vnc.c: In function 'vnc_input':
 #src/surface/vnc.c:489:9: error: variable 'ret' set but not used [-Werror=unused-but-set-variable]
-export CFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable"
+export CFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable -D_GNU_SOURCE"
+export CXXFLAGS="%{rpmcxxflags} -Wno-error=unused-but-set-variable -D_GNU_SOURCE"
 export LDFLAGS="%{rpmldflags}"
 
 # make -j1 or it won't find libwapcaplet/libwapcaplet.h
 
 %{__make} -j1 \
+       OPTFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable -D_GNU_SOURCE" \
+       OPTLDFLAGS="%{rpmldflags}" \
        PREFIX=%{_prefix} \
        Q='' \
        TARGET=gtk
 
 %{__make} -j1 \
+       OPTFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable -D_GNU_SOURCE" \
+       OPTLDFLAGS="%{rpmldflags}" \
        PREFIX=%{_prefix} \
        Q='' \
        TARGET=framebuffer
This page took 0.032945 seconds and 4 git commands to generate.