]> git.pld-linux.org Git - packages/mythtv.git/blobdiff - mythtv.spec
- exclude perl scripts that won't work without perl bindings
[packages/mythtv.git] / mythtv.spec
index 5e79c45e1fe568cd616658ae6ed6a636d2b5e9b9..738ac69e1a450ec589c757456311a767a9d60360 100644 (file)
 %bcond_without oss             # oss support
 %bcond_without jack            # jack audio connection kit
 %bcond_without  pulseaudio     # pulseaudio support
-%bcond_without opengl          # opengl vsync
 %bcond_without dvb             # DVB support
 %bcond_without xrandr          # disable X11 resolution switching
 %bcond_without ivtv            # ivtv support (PVR-250, PVR-350) NFY
 %bcond_without iptv
 %bcond_without firewire        # ieee1394 (NFY)
-%bcond_without xvmc            # do not use XvMCW
 %bcond_without  vdpau          # disable nvidia vdpau support
 %bcond_without  fftw3          # disable fftw3 support
 %bcond_with    mmx             # enable MMX
 %bcond_without nellymoserdec
 %bcond_with    vaapi           # enable vaapi
 %bcond_with     dshowserver    # enable directshow codecs server
-%bcond_with    directfb
-%bcond_with    perl
-%bcond_with    python
-%bcond_with    nvidia_headers  # build vdpau support with nvidia headers 
+%bcond_with    perl
+%bcond_with    php
+%bcond_with    python
+%bcond_with    nvidia_headers  # build vdpau support with nvidia headers
                                # instead of libvdpau
 
 # enable mmx automatically on arches having it
 Summary:       A personal video recorder (PVR) application
 Summary(pl.UTF-8):     Osobista aplikacja do nagrywania obrazu (PVR)
 Name:          mythtv
-Version:       0.24.1
-Release:       0.2
+Version:       0.26.0
+Release:       2
 License:       GPL v2
 Group:         Applications/Multimedia
 Source0:       ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
-# Source0-md5: 6870c679619ec58456e76839745411d8
+# Source0-md5: f57066bf75e6f14824c494d41639f4f9
 Source1:       mythbackend.sysconfig
 Source2:       mythbackend.init
 Source3:       mythbackend.logrotate
+Source4:       %{name}.tmpfiles
 Source5:       pld-mythfrontend.desktop
 # Source5-md5: f37a903ac97463683bebacdf29406951
 Source6:       pld-mythfrontend.png
@@ -74,7 +73,7 @@ Source6:      pld-mythfrontend.png
 Source20:      dshowcodecs
 # Source20-md5:        48327772b9e150f69e1ab8ff44b9a76c
 Patch0:                %{name}-configure.patch
-Patch10:       %{name}-sbinpath.patch
+Patch1:                system-zeromq.patch
 Patch20:       %{name}-compile_fixes_for_qt_4_7.patch
 Patch30:       %{name}-dshowserver-0.22.patch
 URL:           http://www.mythtv.org/
@@ -107,6 +106,15 @@ BuildRequires:     linux-libc-headers >= 7:2.6.10
 BuildRequires: mysql-devel
 BuildRequires: perl-devel
 BuildRequires: perl-tools-pod
+%if %{with perl}
+BuildRequires: perl-DBI
+BuildRequires: perl-DBD-mysql
+BuildRequires: perl-HTTP-Message
+BuildRequires: perl-libwww
+BuildRequires: perl-Net-UPnP-QueryResponse
+BuildRequires: perl-Net-UPnP-ControlPoint
+BuildRequires: perl-IO-Socket-INET6
+%endif
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires: pulseaudio-devel}
 BuildRequires: python-devel
@@ -119,8 +127,8 @@ BuildRequires:      sed >= 4.0
 BuildRequires: which
 %{?with_nvidia_headers:%{?with_vdpau:BuildRequires: xorg-driver-video-nvidia-devel}}
 BuildRequires: xorg-lib-libXext-devel
-%{?with_xvmc:BuildRequires:    xorg-lib-libXvMC-devel}
 BuildRequires: xorg-lib-libXxf86vm-devel
+BuildRequires: zeromq-devel
 %{!?with_pulseaudio:BuildConflicts: pulseaudio-devel}
 %{!?with_nvidia_headers:BuildConflicts:        xorg-driver-video-nvidia-devel}
 # for Perl bindings
@@ -176,6 +184,7 @@ Requires:   mythtv = %{version}-%{release}
 Suggests:      mysql
 Provides:      group(mythtv)
 Provides:      user(mythtv)
+Conflicts:     logrotate < 3.8.0
 
 %description backend
 MythTV provides a unified graphical interface for recording and
@@ -335,6 +344,17 @@ MythTV Python bindings.
 %description -n python-MythTV -l pl.UTF-8
 Ten pakiet zawiera moduły Pythona do tworzenia dodatków dla mythtv.
 
+%package -n php-MythTV
+Summary:       MythTV PHP bindings
+Summary(pl.UTF-8):     Interfejs PHP dla MythTV
+Group:         Libraries
+
+%description -n php-MythTV
+MythTV PHP bindings.
+
+%description -n php-MythTV -l pl.UTF-8
+Ten pakiet zawiera moduły PHP do tworzenia dodatków dla mythtv.
+
 %prep
 
 %setup -q
@@ -343,7 +363,7 @@ Ten pakiet zawiera moduły Pythona do tworzenia dodatków dla mythtv.
        programs/mythbackend/housekeeper.cpp programs/mythwelcome/welcomedialog.cpp
 
 %patch0  -p1
-%patch10 -p1
+%patch1  -p1
 %{?with_dshowserver:%patch20 -p1}
 #%patch30 -p1
 
@@ -438,17 +458,14 @@ fi
        --%{?with_alsa:en}%{!?with_alsa:dis}able-audio-alsa \
        --%{?with_oss:en}%{!?with_oss:dis}able-audio-oss \
        --%{?with_jack:en}%{!?with_jack:dis}able-audio-jack \
-       --%{?with_opengl:en}%{!?with_opengl:dis}able-opengl-vsync \
        --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
        --%{?with_firewire:en}%{!?with_firewire:dis}able-firewire \
        --%{?with_xrandr:en}%{!?with_xrandr:dis}able-xrandr \
-       --%{?with_xvmc:en}%{!?with_xvmc:dis}able-xvmc \
        --%{?with_ivtv:en}%{!?with_ivtv:dis}able-ivtv \
        --%{?with_iptv:en}%{!?with_iptv:dis}able-iptv \
        --%{?with_nellymoserdec:en}%{!?with_nellymoserdec:dis}able-decoder=nellymoser \
        --%{?with_vaapi:en}%{!?with_vaapi:dis}able-vaapi \
        --%{?with_vdpau:en}%{!?with_vdpau:dis}able-vdpau \
-       --%{?with_directfb:en}%{!?with_directfb:dis}able-directfb \
        --%{?with_fftw3:en}%{!?with_fftw3:dis}able-libfftw3 \
        --enable-xv \
        --enable-x11 \
@@ -464,7 +481,8 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,sysconfig} \
                $RPM_BUILD_ROOT/var/lib/mythtv/tmp \
                $RPM_BUILD_ROOT%{_libdir}/mythtv \
                $RPM_BUILD_ROOT%{_libdir}/mythtv/plugins \
-               $RPM_BUILD_ROOT%{_pixmapsdir}
+               $RPM_BUILD_ROOT%{_pixmapsdir} \
+               $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
 
 %{__make} install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
@@ -475,6 +493,8 @@ cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mythbackend
 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/mythbackend
 %{?with_dshowserver:cp -p %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/mythtv}
 
+install %{SOURCE4} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
+
 # desktop entries
 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
 install %{SOURCE6} $RPM_BUILD_ROOT%{_pixmapsdir}
@@ -489,6 +509,10 @@ for p in mythfrontend; do
        done > $p.lang
 done
 
+for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/locales/*.xml; do
+       echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*/\(.*\).xml\),%%lang(\2) \1,"
+done > mythbackend.lang
+
 # glibc language codes. attempt was made to change it on libmyth side,
 # but that was just asking for trouble due large coverage of
 # language.lower() usage.
@@ -498,9 +522,8 @@ s,%%lang(zh_tw),%%lang(zh_TW),
 s,%%lang(pt_br),%%lang(pt_BR),
 ' *.lang
 
-rm -rf mythtvosd mythwelcome mythlcdserver
-install -d mythtvosd mythwelcome
-cp -a programs/mythtvosd/{README,*.xml} mythtvosd
+rm -rf mythwelcome mythlcdserver
+install -d mythwelcome
 cp -a programs/mythwelcome/README mythwelcome
 cp -a programs/mythlcdserver/README mythlcdserver
 
@@ -542,42 +565,59 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc README* UPGRADING AUTHORS FAQ
-%doc docs contrib config
-%doc keys.txt mythtvosd mythwelcome mythlcdserver
+%doc docs contrib
+%doc keys.txt mythwelcome mythlcdserver
 
-%files backend
+%files backend -f mythbackend.lang
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_sbindir}/mythbackend
-%attr(755,root,root) %{_sbindir}/mythcommflag
+%attr(755,root,root) %{_bindir}/mythbackend
+%attr(755,root,root) %{_bindir}/mythcommflag
 %attr(755,root,root) %{_bindir}/mythfilldatabase
-%attr(755,root,root) %{_sbindir}/mythjobqueue
-%attr(755,root,root) %{_sbindir}/mythlcdserver
+%attr(755,root,root) %{_bindir}/mythjobqueue
+%attr(755,root,root) %{_bindir}/mythlcdserver
+%attr(755,root,root) %{_bindir}/mythlogserver
+%attr(755,root,root) %{_bindir}/mythmediaserver
 %attr(755,root,root) %{_bindir}/mythtranscode
 %attr(755,root,root) %{_bindir}/mythreplex
+%attr(755,root,root) %{_bindir}/mythffmpeg
+%attr(755,root,root) %{_bindir}/mythpreviewgen
+%attr(755,root,root) %{_bindir}/mythccextractor
+%attr(755,root,root) %{_bindir}/mythmetadatalookup
+%attr(755,root,root) %{_bindir}/mythutil
+
 %attr(775,root,mythtv) %dir /var/lib/mythtv
 %attr(700,root,mythtv) %dir /var/lib/mythtv/tmp
 %attr(775,root,mythtv) %dir /var/cache/mythtv
 %attr(775,root,mythtv) %dir /var/run/mythtv
+/usr/lib/tmpfiles.d/%{name}.conf
 %attr(754,root,root) /etc/rc.d/init.d/mythbackend
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mythbackend
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mythbackend
 %attr(775,root,mythtv) %dir %{_localstatedir}/log/mythtv
+%{_datadir}/mythtv/backend-config
+%{_datadir}/mythtv/html
 
 %files frontend -f mythfrontend.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/mythfrontend
 %attr(755,root,root) %{_bindir}/mythshutdown
 %attr(755,root,root) %{_bindir}/mythavtest
-%attr(755,root,root) %{_bindir}/mythtvosd
 %attr(755,root,root) %{_bindir}/mythwelcome
 %dir %{_datadir}/mythtv
 %dir %{_datadir}/mythtv/themes
+%{_datadir}/mythtv/internetcontent
+%if %{without perl}
+%exclude %{_datadir}/mythtv/internetcontent/nv_perl_libs
+%endif
+%{_datadir}/mythtv/metadata
 %dir %{_libdir}/mythtv
 %{_datadir}/mythtv/*.xml
 %dir %{_libdir}/mythtv/filters
 %dir %{_libdir}/mythtv/plugins
 %attr(755,root,root) %{_libdir}/mythtv/filters/*.so
+%dir %{_datadir}/mythtv/fonts
 %{_datadir}/mythtv/fonts/*.ttf
+%{_datadir}/mythtv/fonts/*.otf
 %dir %{_datadir}/mythtv/i18n
 %if %{with dshowserver}
 %{_datadir}/mythtv/dshowcodecs
@@ -596,9 +636,11 @@ fi
 
 %files -n libmyth
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so*
+%attr(755,root,root) %{_libdir}/lib*.so.*
 %attr(755,root,root) %{_libdir}/lib*.a
+%dir %{_datadir}/mythtv
 %{_datadir}/mythtv/*.pl
+%{_datadir}/mythtv/hardwareprofile
 
 %files -n libmyth-devel
 %defattr(644,root,root,755)
@@ -628,3 +670,8 @@ fi
 %{py_sitescriptdir}/MythTV/*
 %{py_sitescriptdir}/*.egg-info
 %endif
+
+%if %{with php}
+%files -n php-MythTV
+%defattr(644,root,root,755)
+%endif
This page took 0.048151 seconds and 4 git commands to generate.