]> git.pld-linux.org Git - packages/mplayer.git/blobdiff - mplayer.spec
- added giflib patch (fixes build with giflib 5.1+)
[packages/mplayer.git] / mplayer.spec
index 8f54c7a2b3aa5c44689caf75e96bd5300d591305..b5bc399c76b6e5819bf29305c9532ac65b758da7 100644 (file)
@@ -1,9 +1,3 @@
-# TODO:
-# - libnemesi >= 0.6.3
-# - vstream-client (http://code.google.com/p/vstream-client/)
-# - libbs2b >= 3.0.0
-# - dxr2 (http://sourceforge.net/projects/dxr2/)
-# - s3fb, tdfxvid, wii?
 #
 # Conditional build:
 # - CPU optimization:
@@ -12,11 +6,8 @@
 %bcond_without runtime         # disable runtime cpu detection, just detect CPU
                                #  in compile time (advertised by mplayer authors as working faster); in this case
                                #  mplayer may not work on machine other then where it was compiled
-%if "%{pld_release}" == "ac"
-%bcond_with    hidden_visibility       # gcc hidden visibility
-%else
 %bcond_without hidden_visibility       # no gcc hidden visibility
-%endif
+%bcond_without verbose         # disable verbose build
 # - general features:
 %bcond_without bluray          # Blu-ray support
 %bcond_without cdio            # libcdio support
 %bcond_without lirc            # lirc support
 %bcond_without live            # LIVE555 Streaming Media support
 %bcond_without mencoder        # mencoder (a/v encoder) compilation
+%bcond_without nemesi          # NeMeSi Streaming Media support
 %bcond_with    on2             # patches from On2 Flix Engine for Linux
 %bcond_without osd             # osd menu support
 %bcond_without rtmp            # RTMPDump Streaming Media support
 %bcond_with    shared          # experimental libmplayer.so support
 %bcond_without smb             # Samba (SMB) input support
+%bcond_without vstream         # TiVo vstream client support
 # - codecs:
 %bcond_without amr             # Adaptive Multi Rate (AMR) speech codec support
+%bcond_without bs2b            # BS2B audio filter support
 %bcond_without crystalhd       # CrystalHD support
 %bcond_without faad            # FAAD2 (AAC) support
 %bcond_without gif             # GIF support
@@ -64,7 +58,8 @@
 %bcond_without aalib           # aalib video output
 %bcond_without caca            # libcaca video output
 %bcond_with    directfb        # DirectFB video output
-%bcond_with    dxr3            # enable use of DXR3/H+ hardware MPEG decoder
+%bcond_with    dxr2            # DXR2 (hardware MPEG decoder) video output
+%bcond_with    dxr3            # DXR3/H+ (hardware MPEG decoder) video output
 %bcond_with    ggi             # GGI video output
 %bcond_without sdl             # SDL video output
 %bcond_with    svga            # svgalib video output
 %ifnarch ppc
 %undefine      with_altivec
 %endif
+%ifnarch i686 pentium4 athlon %{x8664}
+%undefine      with_crystalhd
+%endif
 
 %if %{_lib} == "lib64"
 %define                binsuf  64
 %define                binsuf  32
 %endif
 
+# date from directory inside of tarball (like mplayer-export-2014-04-29)
+%define        snap    2014-09-12
+%define        ssnap   %(echo %{snap} | tr -d -)
 Summary:       MPlayer - THE Movie Player for UN*X
 Summary(de.UTF-8):     MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
 Summary(es.UTF-8):     Otro reproductor de películas
@@ -116,8 +117,8 @@ Summary(ko.UTF-8):  리눅스용 미디어플레이어
 Summary(pl.UTF-8):     Odtwarzacz filmów dla systemów uniksowych
 Summary(pt_BR.UTF-8):  Reprodutor de filmes
 Name:          mplayer
-Version:       1.1
-Release:       3
+Version:       1.1.1
+Release:       6.%{ssnap}.1
 # DO NOT increase epoch unless it's really neccessary!
 # especially such changes like pre7->pre7try2, increase Release instead!
 # PS: $ rpmvercmp pre7try2 pre7
@@ -125,12 +126,11 @@ Release:  3
 Epoch:         3
 License:       GPL
 Group:         Applications/Multimedia
-# for snapshots:
-#   svn export svn://svn.mplayerhq.hu/mplayer/trunk mplayer-rXXX
-#   cd mplayer-rXXX && git clone git://git.videolan.org/ffmpeg.git
-#   tar -cvJf mplayer-rXXX.tar.xz mplayer-rXXX
-Source0:       http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
-# Source0-md5: ac7bf1cfedc1c5c24bfc83107eefb1d9
+# Source0:        http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
+Source0:       ftp://ftp.mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
+# Source0-md5: 28b3754f5a1f8d783e422e1bff239a92
+Source1:       http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
+# Source1-md5: 05728909d83ea25c77e2d7912492ba93
 Source3:       ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
 # Source3-md5: 7b47904a925cf58ea546ca15f3df160c
 Source5:       g%{name}.desktop
@@ -141,22 +141,25 @@ Source8:  %{name}.desktop
 # http://www.on2.com/gpl/mplayer/
 Source9:       http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
 # Source9-md5: 07774a2663a8fda07c308df0c6569b56
+Patch0:                %{name}-giflib.patch
 
 # build (configure / Makefile) related:
 Patch10:       %{name}-ldflags.patch
 Patch11:       %{name}-altivec.patch
 Patch12:       %{name}-check-byteswap.patch
 Patch13:       %{name}-visibility-hidden-fix.patch
-Patch14:       %{name}-ffmpeg.patch
-Patch15:       %{name}-live.patch
+
+Patch15:       %{name}-live555-async.patch
 Patch16:       %{name}-libcdio.patch
 Patch17:       %{name}-gsm.patch
 Patch18:       %{name}-openjpeg.patch
 Patch19:       %{name}-shared.patch
+Patch20:       %{name}-vstream.patch
+Patch23:       vstream-format-security.patch
 
 # codecs, outputs, demuxers:
-Patch20:       %{name}-auto-expand.patch
-Patch21:       %{name}-release_directfb.patch
+Patch21:       %{name}-auto-expand.patch
+Patch22:       %{name}-release_directfb.patch
 
 # goodies:
 Patch30:       %{name}-cp1250-fontdesc.patch
@@ -167,7 +170,6 @@ Patch31:    %{name}-350.patch
 
 Patch100:      %{name}-on2flix.patch
 Patch101:      %{name}-link.patch
-Patch102:      %{name}-build.patch
 
 URL:           http://www.mplayerhq.hu/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
@@ -180,11 +182,12 @@ BuildRequires:    a52dec-libs-devel
 %{?with_arts:BuildRequires:    artsc-devel}
 %{?with_ssse3:BuildRequires:   binutils >= 3:2.16.92}
 BuildRequires: bzip2-devel
-%{?with_cdparanoia:BuildRequires:      cdparanoia-III-devel}
+#%{?with_cdparanoia:BuildRequires:     cdparanoia-III-devel}
 %{?with_gnomess:BuildRequires: dbus-glib-devel}
 BuildRequires: dirac-devel
 %{?with_doc:BuildRequires:     docbook-dtd412-xml}
 %{?with_doc:BuildRequires:     docbook-style-xsl}
+%{?with_dxr2:BuildRequires:    dxr2-driver-devel}
 %{?with_dxr3:BuildRequires:    em8300-devel}
 %{?with_enca:BuildRequires:    enca-devel}
 %{?with_esd:BuildRequires:     esound-devel}
@@ -202,12 +205,13 @@ BuildRequires:    fribidi-devel
 BuildRequires: lame-libs-devel
 BuildRequires: libass-devel >= 0.9.10
 %{?with_bluray:BuildRequires:  libbluray-devel}
+%{?with_bs2b:BuildRequires:    libbs2b-devel >= 3.0.0}
 %{?with_caca:BuildRequires:    libcaca-devel}
 %{?with_cdio:BuildRequires:    libcdio-paranoia-devel}
 %{?with_crystalhd:BuildRequires:       libcrystalhd-devel}
 %{?with_libdts:BuildRequires:  libdts-devel}
 %{?with_libdv:BuildRequires:   libdv-devel > 0.9.5}
-%{?with_system_dvdcss:BuildRequires:   libdvdcss-devel}
+#%{?with_system_dvdcss:BuildRequires:  libdvdcss-devel}
 %{?with_dvdnav:BuildRequires:  libdvdnav-devel >= 4.1.3}
 %{?with_system_dvdread:BuildRequires:  libdvdread-devel >= 4.1}
 %{?with_ggi:BuildRequires:     libggi-devel}
@@ -219,6 +223,7 @@ BuildRequires:      libmng-devel
 %{?with_musepack:BuildRequires:        libmpcdec-devel >= 1.2.1}
 %{?with_system_libmpeg2:BuildRequires: libmpeg2-devel}
 %{?with_mpg123:BuildRequires:  libmpg123-devel >= 1.14}
+%{?with_nemesi:BuildRequires:  libnemesi-devel >= 0.6.3}
 BuildRequires: libnut-devel
 BuildRequires: libpng-devel
 %{?with_rtmp:BuildRequires:    librtmp-devel}
@@ -230,7 +235,7 @@ BuildRequires:      libvpx-devel
 %{?with_x264:BuildRequires:    libx264-devel >= 0.1.3}
 BuildRequires: libxslt-progs
 %{?with_lirc:BuildRequires:    lirc-devel}
-%{?with_live:BuildRequires:    live-devel}
+%{?with_live:BuildRequires:    live-devel >= 2:2011.01.10}
 %{?with_lzo:BuildRequires:     lzo-devel >= 2.0}
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
@@ -246,15 +251,8 @@ BuildRequires:     speex-devel >= 1.1
 BuildRequires: tar >= 1:1.22
 BuildRequires: twolame-devel
 %{?with_vidix:BuildRequires:   vidix-devel}
+%{?with_vstream:BuildRequires: vstream-client-devel}
 %{?with_xmms:BuildRequires:    xmms-devel}
-%{?with_xvid:BuildRequires:    xvid-devel >= 1:0.9.0}
-%ifarch %{ix86} %{x8664}
-BuildRequires: yasm
-%endif
-BuildRequires: zlib-devel
-%if "%{pld_release}" == "ac"
-BuildRequires: XFree86-devel >= 4.0.2
-%else
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXScrnSaver-devel
 BuildRequires: xorg-lib-libXext-devel
@@ -263,7 +261,12 @@ BuildRequires:     xorg-lib-libXv-devel
 BuildRequires: xorg-lib-libXvMC-devel
 BuildRequires: xorg-lib-libXxf86dga-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
+%{?with_xvid:BuildRequires:    xvid-devel >= 1:0.9.0}
+BuildRequires: xz
+%ifarch %{ix86} %{x8664}
+BuildRequires: yasm
 %endif
+BuildRequires: zlib-devel
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      OpenGL
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -274,12 +277,6 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                specflags_ppc   -maltivec
 %endif
 
-%if "%{pld_release}" == "ac"
-%ifarch ppc
-%define                __cc    gcc4
-%endif
-%endif
-
 %description
 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
@@ -396,24 +393,27 @@ package.
 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
 
 %prep
-%setup -q -n MPlayer-%{version} -a3 -a6 -a9
+%setup -q -n %{name}-export-%{snap} -a1 -a3 -a6 -a9
 cp -f etc/codecs.conf etc/codecs.win32.conf
+%patch0 -p1
 
 # build (configure / Makefile) related:
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-%{?with_system_ffmpeg:%patch14 -p1}
+
 %patch15 -p1
 %patch16 -p1
 %patch17 -p1
 %patch18 -p1
 %{?with_shared:%patch19 -p1}
+%patch20 -p1
+%patch23 -p0
 
 # codecs, outputs, demuxers:
-%patch20 -p1
 %patch21 -p1
+%patch22 -p1
 
 # goodies:
 %patch30 -p0
@@ -443,7 +443,6 @@ done
 %endif
 
 %patch101 -p1
-%patch102 -p1
 
 cat etc/example.conf > etc/mplayer.conf
 cat <<'CONFIGADD' >> etc/mplayer.conf
@@ -464,16 +463,19 @@ subcp = cp1250
 # Standard location
 unrarexec = "%{_bindir}/unrar"
 
+# Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
+joystick=no
+
 CONFIGADD
 
 %if %{with system_ffmpeg}
 # using external ffmpeg, but mplayer adds these to includepath
-%{__rm} -r libavcodec libavdevice libavformat libavutil libpostproc libswscale
+%{__rm} -rf ffmpeg
 %endif
 
 %build
 CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
-CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
+CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb} -DHAVE_GSM_H=1"
 
 # NOTE:
 # - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
@@ -492,14 +494,7 @@ build() {
        --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
        --language=all \
 %if %{with system_ffmpeg}
-       --disable-libavutil_a \
-       --disable-libavcodec_a \
-       --disable-libavformat_a \
-       --disable-libpostproc_a \
-       --enable-libavutil_so \
-       --enable-libavcodec_so \
-       --enable-libavformat_so \
-       --enable-libpostproc_so \
+       --disable-ffmpeg_a \
 %endif
 %ifnarch %{ix86} %{x8664}
        --disable-3dnow \
@@ -525,6 +520,7 @@ build() {
        %{__enable_disable directfb} \
        %{__enable_disable dvdnav} \
        %{__disable system_dvdread dvdread-internal} \
+       %{__disable dxr2} \
        %{__disable dxr3} \
        --enable-dynamic-plugins \
        %{__disable enca} \
@@ -538,11 +534,13 @@ build() {
        %{__enable joystick} \
        %{__disable cdio libcdio} \
        %{__disable ladspa} \
+       %{__disable bs2b libbs2b} \
        %{__disable libdts libdca} \
        %{__disable libdv} \
        %{__disable system_dvdcss libdvdcss-internal} \
        %{__disable lzo liblzo} \
        %{__disable system_libmpeg2 libmpeg2-internal} \
+       %{__disable nemesi} \
        %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
        %{__disable openjpeg} \
        %{__disable rtmp librtmp} \
@@ -565,9 +563,11 @@ build() {
        %{__enable_disable runtime runtime-cpudetection} \
        %{__enable_disable sdl} \
        %{__disable select} \
+       --enable-s3fb \
        %{__disable smb} \
        %{__disable svga} \
        --enable-tdfxfb \
+       --enable-tdfxvid \
        %{__disable theora} \
        --disable-toolame \
        --disable-tremor \
@@ -576,7 +576,11 @@ build() {
        --enable-unrarexec \
        %{__disable vdpau} \
        %{__disable vidix} \
+       %{__disable vstream} \
        --enable-vm \
+%ifarch ppc
+       --enable-wii \
+%endif
        %{__disable win32 win32dll} \
        --enable-x11 \
        %{__disable x264} \
@@ -588,7 +592,7 @@ build() {
        %{__enable_disable zr} \
        "$@"
 
-       %{__make}
+       %{__make} %{?with_verbose:V=1}
 }
 
 %if %{with gui}
@@ -618,13 +622,13 @@ install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysc
 
 # executables
 %if %{with mencoder}
-install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
+install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{binsuf}
 ln -sf mencoder%{binsuf} $RPM_BUILD_ROOT%{_bindir}/mencoder
 %endif
-install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
+install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{binsuf}
 ln -sf mplayer%{binsuf} $RPM_BUILD_ROOT%{_bindir}/mplayer
 %if %{with gui}
-install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
+install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{binsuf}
 ln -sf gmplayer%{binsuf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
 %endif
 
This page took 0.062867 seconds and 4 git commands to generate.