]> git.pld-linux.org Git - packages/mplayer.git/blobdiff - mplayer.spec
- added giflib patch (fixes build with giflib 5.1+)
[packages/mplayer.git] / mplayer.spec
index 805f145d89131b6087bfa55453c8ce17a8b72218..b5bc399c76b6e5819bf29305c9532ac65b758da7 100644 (file)
@@ -97,6 +97,9 @@
 %ifnarch ppc
 %undefine      with_altivec
 %endif
+%ifnarch i686 pentium4 athlon %{x8664}
+%undefine      with_crystalhd
+%endif
 
 %if %{_lib} == "lib64"
 %define                binsuf  64
 %define                binsuf  32
 %endif
 
+# date from directory inside of tarball (like mplayer-export-2014-04-29)
+%define        snap    2014-09-12
+%define        ssnap   %(echo %{snap} | tr -d -)
 Summary:       MPlayer - THE Movie Player for UN*X
 Summary(de.UTF-8):     MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
 Summary(es.UTF-8):     Otro reproductor de películas
@@ -111,8 +117,8 @@ Summary(ko.UTF-8):  리눅스용 미디어플레이어
 Summary(pl.UTF-8):     Odtwarzacz filmów dla systemów uniksowych
 Summary(pt_BR.UTF-8):  Reprodutor de filmes
 Name:          mplayer
-Version:       1.1
-Release:       3
+Version:       1.1.1
+Release:       6.%{ssnap}.1
 # DO NOT increase epoch unless it's really neccessary!
 # especially such changes like pre7->pre7try2, increase Release instead!
 # PS: $ rpmvercmp pre7try2 pre7
@@ -120,12 +126,11 @@ Release:  3
 Epoch:         3
 License:       GPL
 Group:         Applications/Multimedia
-# for snapshots:
-#   svn export svn://svn.mplayerhq.hu/mplayer/trunk mplayer-rXXX
-#   cd mplayer-rXXX && git clone git://git.videolan.org/ffmpeg.git
-#   tar -cvJf mplayer-rXXX.tar.xz mplayer-rXXX
-Source0:       http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
-# Source0-md5: ac7bf1cfedc1c5c24bfc83107eefb1d9
+# Source0:        http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
+Source0:       ftp://ftp.mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
+# Source0-md5: 28b3754f5a1f8d783e422e1bff239a92
+Source1:       http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
+# Source1-md5: 05728909d83ea25c77e2d7912492ba93
 Source3:       ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
 # Source3-md5: 7b47904a925cf58ea546ca15f3df160c
 Source5:       g%{name}.desktop
@@ -136,14 +141,15 @@ Source8:  %{name}.desktop
 # http://www.on2.com/gpl/mplayer/
 Source9:       http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
 # Source9-md5: 07774a2663a8fda07c308df0c6569b56
+Patch0:                %{name}-giflib.patch
 
 # build (configure / Makefile) related:
 Patch10:       %{name}-ldflags.patch
 Patch11:       %{name}-altivec.patch
 Patch12:       %{name}-check-byteswap.patch
 Patch13:       %{name}-visibility-hidden-fix.patch
-Patch14:       %{name}-ffmpeg.patch
-Patch15:       %{name}-live.patch
+
+Patch15:       %{name}-live555-async.patch
 Patch16:       %{name}-libcdio.patch
 Patch17:       %{name}-gsm.patch
 Patch18:       %{name}-openjpeg.patch
@@ -164,7 +170,6 @@ Patch31:    %{name}-350.patch
 
 Patch100:      %{name}-on2flix.patch
 Patch101:      %{name}-link.patch
-Patch102:      %{name}-build.patch
 
 URL:           http://www.mplayerhq.hu/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
@@ -177,7 +182,7 @@ BuildRequires:      a52dec-libs-devel
 %{?with_arts:BuildRequires:    artsc-devel}
 %{?with_ssse3:BuildRequires:   binutils >= 3:2.16.92}
 BuildRequires: bzip2-devel
-%{?with_cdparanoia:BuildRequires:      cdparanoia-III-devel}
+#%{?with_cdparanoia:BuildRequires:     cdparanoia-III-devel}
 %{?with_gnomess:BuildRequires: dbus-glib-devel}
 BuildRequires: dirac-devel
 %{?with_doc:BuildRequires:     docbook-dtd412-xml}
@@ -206,7 +211,7 @@ BuildRequires:      libass-devel >= 0.9.10
 %{?with_crystalhd:BuildRequires:       libcrystalhd-devel}
 %{?with_libdts:BuildRequires:  libdts-devel}
 %{?with_libdv:BuildRequires:   libdv-devel > 0.9.5}
-%{?with_system_dvdcss:BuildRequires:   libdvdcss-devel}
+#%{?with_system_dvdcss:BuildRequires:  libdvdcss-devel}
 %{?with_dvdnav:BuildRequires:  libdvdnav-devel >= 4.1.3}
 %{?with_system_dvdread:BuildRequires:  libdvdread-devel >= 4.1}
 %{?with_ggi:BuildRequires:     libggi-devel}
@@ -230,7 +235,7 @@ BuildRequires:      libvpx-devel
 %{?with_x264:BuildRequires:    libx264-devel >= 0.1.3}
 BuildRequires: libxslt-progs
 %{?with_lirc:BuildRequires:    lirc-devel}
-%{?with_live:BuildRequires:    live-devel}
+%{?with_live:BuildRequires:    live-devel >= 2:2011.01.10}
 %{?with_lzo:BuildRequires:     lzo-devel >= 2.0}
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
@@ -248,11 +253,6 @@ BuildRequires:     twolame-devel
 %{?with_vidix:BuildRequires:   vidix-devel}
 %{?with_vstream:BuildRequires: vstream-client-devel}
 %{?with_xmms:BuildRequires:    xmms-devel}
-%{?with_xvid:BuildRequires:    xvid-devel >= 1:0.9.0}
-%ifarch %{ix86} %{x8664}
-BuildRequires: yasm
-%endif
-BuildRequires: zlib-devel
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXScrnSaver-devel
 BuildRequires: xorg-lib-libXext-devel
@@ -261,6 +261,12 @@ BuildRequires:     xorg-lib-libXv-devel
 BuildRequires: xorg-lib-libXvMC-devel
 BuildRequires: xorg-lib-libXxf86dga-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
+%{?with_xvid:BuildRequires:    xvid-devel >= 1:0.9.0}
+BuildRequires: xz
+%ifarch %{ix86} %{x8664}
+BuildRequires: yasm
+%endif
+BuildRequires: zlib-devel
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      OpenGL
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -387,15 +393,16 @@ package.
 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
 
 %prep
-%setup -q -n MPlayer-%{version} -a3 -a6 -a9
+%setup -q -n %{name}-export-%{snap} -a1 -a3 -a6 -a9
 cp -f etc/codecs.conf etc/codecs.win32.conf
+%patch0 -p1
 
 # build (configure / Makefile) related:
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-%{?with_system_ffmpeg:%patch14 -p1}
+
 %patch15 -p1
 %patch16 -p1
 %patch17 -p1
@@ -436,7 +443,6 @@ done
 %endif
 
 %patch101 -p1
-%patch102 -p1
 
 cat etc/example.conf > etc/mplayer.conf
 cat <<'CONFIGADD' >> etc/mplayer.conf
@@ -464,12 +470,12 @@ CONFIGADD
 
 %if %{with system_ffmpeg}
 # using external ffmpeg, but mplayer adds these to includepath
-%{__rm} -r libavcodec libavdevice libavformat libavutil libpostproc libswscale
+%{__rm} -rf ffmpeg
 %endif
 
 %build
 CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
-CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
+CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb} -DHAVE_GSM_H=1"
 
 # NOTE:
 # - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
@@ -488,14 +494,7 @@ build() {
        --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
        --language=all \
 %if %{with system_ffmpeg}
-       --disable-libavutil_a \
-       --disable-libavcodec_a \
-       --disable-libavformat_a \
-       --disable-libpostproc_a \
-       --enable-libavutil_so \
-       --enable-libavcodec_so \
-       --enable-libavformat_so \
-       --enable-libpostproc_so \
+       --disable-ffmpeg_a \
 %endif
 %ifnarch %{ix86} %{x8664}
        --disable-3dnow \
This page took 0.050779 seconds and 4 git commands to generate.