]> git.pld-linux.org Git - packages/mplayer.git/blobdiff - mplayer.spec
- added giflib patch (fixes build with giflib 5.1+)
[packages/mplayer.git] / mplayer.spec
index 5fe0beaab01b634cca38d91d5adfe5fe951b17af..b5bc399c76b6e5819bf29305c9532ac65b758da7 100644 (file)
 %define                binsuf  32
 %endif
 
+# date from directory inside of tarball (like mplayer-export-2014-04-29)
+%define        snap    2014-09-12
+%define        ssnap   %(echo %{snap} | tr -d -)
 Summary:       MPlayer - THE Movie Player for UN*X
 Summary(de.UTF-8):     MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
 Summary(es.UTF-8):     Otro reproductor de películas
@@ -115,7 +118,7 @@ Summary(pl.UTF-8):  Odtwarzacz filmów dla systemów uniksowych
 Summary(pt_BR.UTF-8):  Reprodutor de filmes
 Name:          mplayer
 Version:       1.1.1
-Release:       4
+Release:       6.%{ssnap}.1
 # DO NOT increase epoch unless it's really neccessary!
 # especially such changes like pre7->pre7try2, increase Release instead!
 # PS: $ rpmvercmp pre7try2 pre7
@@ -123,12 +126,11 @@ Release:  4
 Epoch:         3
 License:       GPL
 Group:         Applications/Multimedia
-# for snapshots:
-#   svn export svn://svn.mplayerhq.hu/mplayer/trunk mplayer-rXXX
-#   cd mplayer-rXXX && git clone git://git.videolan.org/ffmpeg.git
-#   tar -cvJf mplayer-rXXX.tar.xz mplayer-rXXX
-Source0:       http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
-# Source0-md5: 39dd55f30eb5403f219a606e79a6648a
+# Source0:        http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
+Source0:       ftp://ftp.mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
+# Source0-md5: 28b3754f5a1f8d783e422e1bff239a92
+Source1:       http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
+# Source1-md5: 05728909d83ea25c77e2d7912492ba93
 Source3:       ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
 # Source3-md5: 7b47904a925cf58ea546ca15f3df160c
 Source5:       g%{name}.desktop
@@ -139,13 +141,14 @@ Source8:  %{name}.desktop
 # http://www.on2.com/gpl/mplayer/
 Source9:       http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
 # Source9-md5: 07774a2663a8fda07c308df0c6569b56
+Patch0:                %{name}-giflib.patch
 
 # build (configure / Makefile) related:
 Patch10:       %{name}-ldflags.patch
 Patch11:       %{name}-altivec.patch
 Patch12:       %{name}-check-byteswap.patch
 Patch13:       %{name}-visibility-hidden-fix.patch
-Patch14:       %{name}-ffmpeg.patch
+
 Patch15:       %{name}-live555-async.patch
 Patch16:       %{name}-libcdio.patch
 Patch17:       %{name}-gsm.patch
@@ -164,11 +167,9 @@ Patch31:   %{name}-350.patch
 # update, hard to fix right now because of gnome bug 579430:
 # https://bugzilla.gnome.org/show_bug.cgi?id=579430
 #Patch32:      %{name}-gnome-screensaver.patch
-Patch33:       %{name}-growing-files.patch
 
 Patch100:      %{name}-on2flix.patch
 Patch101:      %{name}-link.patch
-Patch102:      %{name}-build.patch
 
 URL:           http://www.mplayerhq.hu/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
@@ -392,15 +393,16 @@ package.
 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
 
 %prep
-%setup -q -n MPlayer-%{version} -a3 -a6 -a9
+%setup -q -n %{name}-export-%{snap} -a1 -a3 -a6 -a9
 cp -f etc/codecs.conf etc/codecs.win32.conf
+%patch0 -p1
 
 # build (configure / Makefile) related:
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
-%{?with_system_ffmpeg:%patch14 -p1}
+
 %patch15 -p1
 %patch16 -p1
 %patch17 -p1
@@ -417,7 +419,6 @@ cp -f etc/codecs.conf etc/codecs.win32.conf
 %patch30 -p0
 %patch31 -p1
 #%{with_gnomess:%patch32 -p1}
-%patch33 -p1
 
 # on2flix
 mv mencoder-on2flixenglinux{-*-*-*,}
@@ -442,7 +443,6 @@ done
 %endif
 
 %patch101 -p1
-%patch102 -p1
 
 cat etc/example.conf > etc/mplayer.conf
 cat <<'CONFIGADD' >> etc/mplayer.conf
@@ -470,12 +470,12 @@ CONFIGADD
 
 %if %{with system_ffmpeg}
 # using external ffmpeg, but mplayer adds these to includepath
-%{__rm} -r ffmpeg
+%{__rm} -rf ffmpeg
 %endif
 
 %build
 CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
-CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
+CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb} -DHAVE_GSM_H=1"
 
 # NOTE:
 # - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
@@ -494,14 +494,7 @@ build() {
        --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
        --language=all \
 %if %{with system_ffmpeg}
-       --disable-libavutil_a \
-       --disable-libavcodec_a \
-       --disable-libavformat_a \
-       --disable-libpostproc_a \
-       --enable-libavutil_so \
-       --enable-libavcodec_so \
-       --enable-libavformat_so \
-       --enable-libpostproc_so \
+       --disable-ffmpeg_a \
 %endif
 %ifnarch %{ix86} %{x8664}
        --disable-3dnow \
This page took 0.058374 seconds and 4 git commands to generate.