]> git.pld-linux.org Git - packages/mpfr.git/blobdiff - mpfr.spec
- updated to 3.1.6
[packages/mpfr.git] / mpfr.spec
index fc3e0a0e252d3da4a7e426353cd627f45ae1e9fa..471df85fb56a067b8ed136208f5822f9223b29fb 100644 (file)
--- a/mpfr.spec
+++ b/mpfr.spec
@@ -1,16 +1,26 @@
+#
+# Conditional build:
+%bcond_without tests   # don't perform make check
+#
 Summary:       Multiple-precision floating-point computations library
-Summary(pl):   Biblioteka obliczeñ zmiennoprzecinkowych wielokrotnej precyzji
+Summary(pl.UTF-8):     Biblioteka obliczeń zmiennoprzecinkowych wielokrotnej precyzji
 Name:          mpfr
-Version:       2.2.1
+Version:       3.1.6
 Release:       1
-License:       LGPL
+License:       LGPL v3+
 Group:         Libraries
-Source0:       http://www.mpfr.org/mpfr-current/%{name}-%{version}.tar.bz2
-# Source0-md5: 40bf06f8081461d8db7d6f4ad5b9f6bd
+Source0:       http://www.mpfr.org/mpfr-current/%{name}-%{version}.tar.xz
+# Source0-md5: 51bfdbf81553966c8d43808122cc81b3
 Patch0:                %{name}-info.patch
 URL:           http://www.mpfr.org/
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake >= 1:1.13
 BuildRequires: gmp-devel >= 4.1.0
+BuildRequires: libtool
+BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo
+BuildRequires: xz
+Requires:      gmp >= 4.1.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -22,19 +32,19 @@ which is both efficient and has a well-defined semantics. It copies
 the good ideas from the ANSI/IEEE-754 standard for double-precision
 floating-point arithmetic (53-bit mantissa).
 
-%description -l pl
-Biblioteka MPFR to biblioteka C do obliczeñ zmiennoprzecinkowych z
-wielokrotn± precyzj± i dok³adnym zaokr±glaniem (zwanym tak¿e poprawnym
-zaokr±glaniem). Jest oparta na bibliotece GMP wielokrotnej precyzji.
-G³ównym celem MPFR jest dostarczenie biblioteki do obliczeñ
-zmiennoprzecinkowych wielokrotnej precyzji, która jest wydajna i ma
-dobrze zdefiniowan± semantykê. Powiela dobre idee ze standardu
-ANSI/IEEE-754 dla arytmetyki zmiennoprzecinkowej podwójnej precyzji (z
-53-bitow± mantys±).
+%description -l pl.UTF-8
+Biblioteka MPFR to biblioteka C do obliczeń zmiennoprzecinkowych z
+wielokrotną precyzją i dokładnym zaokrąglaniem (zwanym także poprawnym
+zaokrąglaniem). Jest oparta na bibliotece GMP wielokrotnej precyzji.
+Głównym celem MPFR jest dostarczenie biblioteki do obliczeń
+zmiennoprzecinkowych wielokrotnej precyzji, która jest wydajna i ma
+dobrze zdefiniowaną semantykę. Powiela dobre idee ze standardu
+ANSI/IEEE-754 dla arytmetyki zmiennoprzecinkowej podwójnej precyzji (z
+53-bitową mantysą).
 
 %package devel
 Summary:       Header files for MPFR library
-Summary(pl):   Pliki nag³ówkowe biblioteki MPFR
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki MPFR
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      gmp-devel >= 4.1.0
@@ -43,30 +53,46 @@ Obsoletes:  libmpfr-devel
 %description devel
 Header files for MPFR library.
 
-%description devel -l pl
-Pliki nag³ówkowe biblioteki MPFR.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki MPFR.
 
 %package static
 Summary:       Static MPFR library
-Summary(pl):   Statyczna biblioteka MPFR
+Summary(pl.UTF-8):     Statyczna biblioteka MPFR
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static MPFR library.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Statyczna biblioteka MPFR.
 
 %prep
 %setup -q
 %patch0 -p1
 
+# triggers bug in gold (as of binutils-2.21.53.0.2-1.i686)
+mkdir my-ld
+if [ -x /usr/bin/ld.bfd ]; then
+       ln -s /usr/bin/ld.bfd my-ld/ld
+fi
+
 %build
+export PATH=$PWD/my-ld:$PATH
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__automake}
 %configure \
        --enable-shared
 
-%{__make} all check
+# make -j4 creates truncated .lo files
+%{__make} -j1 all
+
+%if %{with tests}
+%{__make} check
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -74,22 +100,25 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+rm -f $RPM_BUILD_ROOT%{_infodir}/dir
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%post devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%post  devel -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%postun        devel -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS BUGS ChangeLog FAQ.html NEWS README TODO
+%doc AUTHORS BUGS ChangeLog NEWS README TODO doc/FAQ.html
 %attr(755,root,root) %{_libdir}/libmpfr.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libmpfr.so.4
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.036712 seconds and 4 git commands to generate.