]> git.pld-linux.org Git - packages/mlt.git/blobdiff - mlt.spec
- x32 rebuild
[packages/mlt.git] / mlt.spec
index f6d419653f266522c1e9ca6a6cb646e46158325f..d6d7ab1f3cf0d626e4f6933c64256b90a74a8766 100644 (file)
--- a/mlt.spec
+++ b/mlt.spec
@@ -1,36 +1,43 @@
 #
 # TODO:
-# - bconds
-# - currently avformat support is broken, the hell knows why
-# - seems to link/auto-require installed older version of lib instead of own new
-# - still fails to work with kdenlive:
-#     Failed to load plugin: /usr/share/mlt/modules/libmltavformat.so: undefined symbol: img_convert
+#      - bconds
+#      - more bindings
+#      - movit library - http://libregraphicsworld.org/blog/entry/introducing-movit-free-library-for-gpu-side-video-processing
+#
 Summary:       MLT - open source multimedia framework
 Summary(pl.UTF-8):     MLT - szkielet multimedialny o otwartych źródłach
 Name:          mlt
-Version:       0.2.4
-Release:       1.1
+Version:       0.9.2
+Release:       3
 License:       GPL
 Group:         X11/Applications/Multimedia
-Source0:       http://dl.sourceforge.net/mlt/%{name}-%{version}.tar.gz
-# Source0-md5: 6606d8be848a10efef929e2b6de3cf61
-URL:           http://www.dennedy.org/mlt/twiki/bin/view/MLT/WebHome
-Patch1:                mlt-linuxppc.patch
+Source0:       http://downloads.sourceforge.net/mlt/%{name}-%{version}.tar.gz
+# Source0-md5: f88ead8fcea628a65ebf329cc4470b6d
+URL:           http://www.mltframework.org/
+BuildRequires: QtGui-devel
+BuildRequires: QtSvg-devel
+BuildRequires: QtXml-devel
 BuildRequires: SDL-devel
-#BuildRequires:        ffmpeg-devel
+BuildRequires: SDL_image-devel
+BuildRequires: exiv2-devel
+BuildRequires: ffmpeg-devel
 BuildRequires: gtk+2-devel
-BuildRequires: ladspa-devel
-BuildRequires: lame-libs-devel
+#BuildRequires:        ladspa-devel
+#BuildRequires:        lame-libs-devel
 BuildRequires: libdv-devel >= 0.102
-BuildRequires: libmad-devel
+#BuildRequires:        libmad-devel
 BuildRequires: libquicktime-devel
 BuildRequires: libsamplerate-devel
 BuildRequires: libvorbis-devel >= 1:1.0.1
 BuildRequires: libxml2-devel >= 2.5
 BuildRequires: pkgconfig
-BuildRequires: qt-devel
+BuildRequires: python-devel
+BuildRequires: rpm-pythonprov
 BuildRequires: sox-devel
+BuildRequires: swfdec-devel
+BuildRequires: swig-python
 BuildRequires: which
+Obsoletes:     mlt++ < %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -50,11 +57,21 @@ aplikacji. Funkcjonalność systemu jest zapewniona poprzez asortyment
 gotowych do użycia narzędzi, komponentów do tworzenia XML-a i
 rozszerzalne API oparte na wtyczkach.
 
+%package -n python-mlt
+Summary:       MLT Python bindings
+Summary(pl.UTF-8):     Wiązania MLT dla Pythona
+Group:         Development/Languages/Python
+Requires:      %{name} = %{version}-%{release}
+
+%description -n python-mlt
+Python bindings for MLT - open source multimedia framework.
+
 %package devel
 Summary:       Header files for MLT
 Summary(pl.UTF-8):     Pliki nagłówkowe dla MLT
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Obsoletes:     mlt++-devel < %{version}
 
 %description devel
 This package contains header files for MLT.
@@ -65,13 +82,15 @@ Ten pakiet zawiera pliki nagłówkowe dla MLT.
 %prep
 %setup -q
 
-%ifarch ppc ppc64
-%patch1 -p1
-%endif
+# current
+sed -i -e 's#/usr/lib/libvdpau.so#%{_libdir}/libvdpau.so.1#g' ./src/modules/avformat/vdpau.c
+# in case of future changes
+sed -i -e 's#/usr/local/lib/libvdpau.so#%{_libdir}/libvdpau.so.2#g' ./src/modules/avformat/vdpau.c
 
 %build
 %configure \
        --enable-gpl \
+       --enable-gpl3 \
 %ifarch %{x8664}
        --disable-motion-est \
 %else
@@ -79,22 +98,39 @@ Ten pakiet zawiera pliki nagłówkowe dla MLT.
 %endif
        --disable-debug \
 %ifarch i586 i686 %{x8664}
+       --enable-mmx \
+%else
        --disable-mmx \
+%endif
+%ifarch %{x8664}
+       --enable-sse \
+       --enable-sse2 \
 %else
-       --enable-mmx \
+       --disable-sse \
+       --disable-sse2 \
 %endif
-       --qimage-includedir=%{_includedir}/qt \
-       --qimage-libdir=%{_libdir}
-       
+       --avformat-swscale \
+       --avformat-vdpau \
+       --qimage-includedir=%{_includedir}/qt4 \
+       --qimage-libdir=%{_libdir} \
+       --swig-languages=python
+
 %{__make} \
        CC="%{__cc}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{py_sitedir}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+cp -p src/swig/python/{*.py,*.so} $RPM_BUILD_ROOT%{py_sitedir}
+
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%py_postclean
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -105,10 +141,19 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc ChangeLog README
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/*.so*
+%attr(755,root,root) %ghost %{_libdir}/*.so.?
+%attr(755,root,root) %{_libdir}/*.so.*.*
+%dir %{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}/*
 %{_datadir}/mlt*
 
+%files -n python-mlt
+%defattr(644,root,root,755)
+%{py_sitedir}/*.py[co]
+%attr(755,root,root) %{py_sitedir}/*.so
+
 %files devel
 %defattr(644,root,root,755)
 %{_pkgconfigdir}/*.pc
 %{_includedir}/mlt*
+%{_libdir}/*.so
This page took 0.069627 seconds and 4 git commands to generate.