]> git.pld-linux.org Git - packages/mapnik.git/blobdiff - mapnik.spec
- boost 1.61, icu 57.1 rebuild
[packages/mapnik.git] / mapnik.spec
index 948c33f2b0aee2c2d0bb56d897a70cf50e7e58c8..24d84f29fe93b3045798078c76a7567ebb356d79 100644 (file)
@@ -1,15 +1,17 @@
-#
+# it's not possible to build this with debuginfo on 32bit archs due to
+# memory constraints
+%ifarch %{ix86} x32
+%define                _enable_debug_packages          0
+%endif
 Summary:       Toolkit for developing GIS (Geographic Information Systems) applications
 Name:          mapnik
-Version:       2.2.0
+Version:       3.0.9
 Release:       4
 License:       LGPL v2.1
 Group:         Applications
-Source0:       https://github.com/mapnik/mapnik/archive/v%{version}.tar.gz
-# Source0-md5: b837931c7f1a4dc630d8550d3e635036
-Patch0:                %{name}-boost_lib_names.patch
-Patch1:                mapnik-boost-megadiff.diff
-Patch2:                %{name}-build.patch
+Source0:       https://github.com/mapnik/mapnik/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 89907d70b84e45680ee31b27d464fa56
+Patch0:                mapnik-boost_lib_names.patch
 URL:           http://mapnik.org/
 BuildRequires: boost-devel
 BuildRequires: boost-python-devel
@@ -33,6 +35,7 @@ BuildRequires:        rpm-pythonprov
 BuildRequires: scons
 BuildRequires: sqlite3-devel
 BuildRequires: zlib-devel
+Obsoletes:     python-mapnik < 3.0.9-1
 Suggests:      fonts-TTF-DejaVu
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -47,15 +50,6 @@ offers world class anti-aliasing rendering with subpixel accuracy for
 geographic data. It is written from scratch in modern C++ and doesn't
 suffer from design decisions made a decade ago.
 
-%package -n python-%{name}
-Summary:       Python bindings for Mapnik
-Group:         Libraries/Python
-Requires:      %{name} = %{version}-%{release}
-
-%description -n python-%{name}
-Python binding for Mapnik, the toolkit for developing GIS (Geographic
-Information Systems) applications.
-
 %package devel
 Summary:       Header files for Mapnik
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki Mapnik
@@ -83,29 +77,26 @@ Statyczna biblioteka Mapnik.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
 
 %build
-%scons \
+%scons configure \
+       CUSTOM_CXXFLAGS="%{rpmcxxflags}" \
+       CUSTOM_CFLAGS="%{rpmcflags}" \
+       CUSTOM_LDFLAGS="%{rpmldflags}" \
+       DESTDIR=$RPM_BUILD_ROOT \
        PREFIX=%{_prefix} \
        BOOST_TOOLKIT=gcc43 \
-       INPUT_PLUGINS='raster,rasterlite,sqlite,osm,gdal,shape,postgis,ogr,occi,csv,geojson' \
+       INPUT_PLUGINS='csv,gdal,geojson,ogr,pgraster,postgis,raster,shape,sqlite,topojson' \
        SYSTEM_FONTS=%{_datadir}/fonts/TTF \
        LIBDIR_SCHEMA=%{_lib} \
        SVG2PNG=True
 
+%{__make} -j1
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%scons install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       PREFIX=%{_prefix} \
-       BOOST_TOOLKIT=gcc43 \
-       INPUT_PLUGINS='raster,rasterlite,sqlite,osm,gdal,shape,postgis,ogr,occi,csv,geojson' \
-       SYSTEM_FONTS=%{_datadir}/fonts/TTF \
-       LIBDIR_SCHEMA=%{_lib} \
-       SVG2PNG=True
+%{__make} install
 
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
@@ -121,33 +112,27 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS.md CHANGELOG.md INSTALL.md README.md
 %attr(755,root,root) %{_bindir}/mapnik-config
-%attr(755,root,root) %{_bindir}/mapnik-speed-check
+%attr(755,root,root) %{_bindir}/mapnik-index
+%attr(755,root,root) %{_bindir}/mapnik-render
 %attr(755,root,root) %{_bindir}/shapeindex
-%attr(755,root,root) %{_bindir}/upgrade_map_xml.py
 %attr(755,root,root) %{_libdir}/libmapnik.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libmapnik.so.2.2
+%attr(755,root,root) %ghost %{_libdir}/libmapnik.so.3.0
 %dir %{_libdir}/mapnik
 %dir %{_libdir}/mapnik/input
 %attr(755,root,root) %{_libdir}/mapnik/input/csv.input
 %attr(755,root,root) %{_libdir}/mapnik/input/gdal.input
 %attr(755,root,root) %{_libdir}/mapnik/input/geojson.input
 %attr(755,root,root) %{_libdir}/mapnik/input/ogr.input
-%attr(755,root,root) %{_libdir}/mapnik/input/osm.input
+%attr(755,root,root) %{_libdir}/mapnik/input/pgraster.input
 %attr(755,root,root) %{_libdir}/mapnik/input/postgis.input
 %attr(755,root,root) %{_libdir}/mapnik/input/raster.input
-%attr(755,root,root) %{_libdir}/mapnik/input/rasterlite.input
 %attr(755,root,root) %{_libdir}/mapnik/input/shape.input
 %attr(755,root,root) %{_libdir}/mapnik/input/sqlite.input
+%attr(755,root,root) %{_libdir}/mapnik/input/topojson.input
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libmapnik.so
 %{_includedir}/mapnik
-
-%files -n python-%{name}
-%defattr(644,root,root,755)
-%dir %{py_sitedir}/mapnik
-%{py_sitedir}/mapnik/*.py[co]
-%attr(755,root,root) %{py_sitedir}/mapnik/_mapnik.so
-%dir %{py_sitedir}/mapnik2
-%{py_sitedir}/mapnik2/*.py[co]
+%{_libdir}/libmapnik-json.a
+%{_libdir}/libmapnik-wkt.a
This page took 0.052371 seconds and 4 git commands to generate.