]> git.pld-linux.org Git - packages/mapnik.git/blobdiff - mapnik.spec
- boost 1.61, icu 57.1 rebuild
[packages/mapnik.git] / mapnik.spec
index 113f2ce26d6b3e055e143b767accfaee34702923..24d84f29fe93b3045798078c76a7567ebb356d79 100644 (file)
@@ -1,26 +1,31 @@
-#
-Summary:       Toolkit for developing GIS (Geographic Information Systems) applications.
+# it's not possible to build this with debuginfo on 32bit archs due to
+# memory constraints
+%ifarch %{ix86} x32
+%define                _enable_debug_packages          0
+%endif
+Summary:       Toolkit for developing GIS (Geographic Information Systems) applications
 Name:          mapnik
-Version:       0.6.0
-Release:       1
+Version:       3.0.9
+Release:       4
 License:       LGPL v2.1
 Group:         Applications
-Source0:       http://download.berlios.de/mapnik/%{name}-%{version}.tar.bz2
-# Source0-md5: 981271ac1cd1432314a963809c245fe1
-Patch0:                %{name}-boost_lib_names.patch
-URL:           http://prdownload.berlios.de/
+Source0:       https://github.com/mapnik/mapnik/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 89907d70b84e45680ee31b27d464fa56
+Patch0:                mapnik-boost_lib_names.patch
+URL:           http://mapnik.org/
 BuildRequires: boost-devel
 BuildRequires: boost-python-devel
 BuildRequires: cairomm-devel
 BuildRequires: curl-devel
 BuildRequires: freetype-devel
+BuildRequires: gdal-devel
 BuildRequires: libicu-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libltdl-devel
 BuildRequires: libpng-devel
+BuildRequires: librasterlite-devel
 BuildRequires: libtiff-devel
 BuildRequires: libxml2-devel
-BuildRequires: ogdi-devel
 BuildRequires: pkgconfig
 BuildRequires: postgresql-devel
 BuildRequires: proj-devel
@@ -30,28 +35,20 @@ BuildRequires:      rpm-pythonprov
 BuildRequires: scons
 BuildRequires: sqlite3-devel
 BuildRequires: zlib-devel
+Obsoletes:     python-mapnik < 3.0.9-1
 Suggests:      fonts-TTF-DejaVu
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Mapnik is a Free Toolkit for developing mapping applications. It's written in
-C++ and there are Python bindings to facilitate fast-paced agile development.
-It can comfortably be used for both desktop and web development, which was
-something I wanted from the beginning.
-
-Mapnik is about making beautiful maps. It uses the AGG library and offers world
-class anti-aliasing rendering with subpixel accuracy for geographic data. It is
-written from scratch in modern C++ and doesn't suffer from design decisions
-made a decade ago.
-
-%package -n python-%{name}
-Summary:       Python bindings for Mapnik
-Group:         Libraries/Python
-Requires:      %{name} = %{version}-%{release}
+Mapnik is a Free Toolkit for developing mapping applications. It's
+written in C++ and there are Python bindings to facilitate fast-paced
+agile development. It can comfortably be used for both desktop and web
+development, which was something I wanted from the beginning.
 
-%description -n python-%{name}
-Python binding for Mapnik, the toolkit for developing GIS (Geographic
-Information Systems) applications.
+Mapnik is about making beautiful maps. It uses the AGG library and
+offers world class anti-aliasing rendering with subpixel accuracy for
+geographic data. It is written from scratch in modern C++ and doesn't
+suffer from design decisions made a decade ago.
 
 %package devel
 Summary:       Header files for Mapnik
@@ -82,26 +79,29 @@ Statyczna biblioteka Mapnik.
 %patch0 -p1
 
 %build
-%scons \
+%scons configure \
+       CUSTOM_CXXFLAGS="%{rpmcxxflags}" \
+       CUSTOM_CFLAGS="%{rpmcflags}" \
+       CUSTOM_LDFLAGS="%{rpmldflags}" \
+       DESTDIR=$RPM_BUILD_ROOT \
        PREFIX=%{_prefix} \
        BOOST_TOOLKIT=gcc43 \
-       SYSTEM_FONTS=/usr/share/fonts/TTF
+       INPUT_PLUGINS='csv,gdal,geojson,ogr,pgraster,postgis,raster,shape,sqlite,topojson' \
+       SYSTEM_FONTS=%{_datadir}/fonts/TTF \
+       LIBDIR_SCHEMA=%{_lib} \
+       SVG2PNG=True
+
+%{__make} -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%scons install \
-       PREFIX=%{_prefix} \
-       DESTDIR=$RPM_BUILD_ROOT \
-       SYSTEM_FONTS=/usr/share/fonts/TTF
+%{__make} install
 
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
 %py_postclean
 
-## DejaVu fonts are available in a separate package
-#rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/fonts
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -110,22 +110,29 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS CHANGELOG INSTALL README
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
-%dir %{_libdir}/%{name}
-%dir %{_libdir}/%{name}/input
-%attr(755,root,root) %{_libdir}/%{name}/input/*.input
+%doc AUTHORS.md CHANGELOG.md INSTALL.md README.md
+%attr(755,root,root) %{_bindir}/mapnik-config
+%attr(755,root,root) %{_bindir}/mapnik-index
+%attr(755,root,root) %{_bindir}/mapnik-render
+%attr(755,root,root) %{_bindir}/shapeindex
+%attr(755,root,root) %{_libdir}/libmapnik.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libmapnik.so.3.0
+%dir %{_libdir}/mapnik
+%dir %{_libdir}/mapnik/input
+%attr(755,root,root) %{_libdir}/mapnik/input/csv.input
+%attr(755,root,root) %{_libdir}/mapnik/input/gdal.input
+%attr(755,root,root) %{_libdir}/mapnik/input/geojson.input
+%attr(755,root,root) %{_libdir}/mapnik/input/ogr.input
+%attr(755,root,root) %{_libdir}/mapnik/input/pgraster.input
+%attr(755,root,root) %{_libdir}/mapnik/input/postgis.input
+%attr(755,root,root) %{_libdir}/mapnik/input/raster.input
+%attr(755,root,root) %{_libdir}/mapnik/input/shape.input
+%attr(755,root,root) %{_libdir}/mapnik/input/sqlite.input
+%attr(755,root,root) %{_libdir}/mapnik/input/topojson.input
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_includedir}/*
-
-%files -n python-%{name}
-%defattr(644,root,root,755)
-%dir %{py_sitedir}/%{name}
-%{py_sitedir}/%{name}/*.py[co]
-%attr(755,root,root) %{py_sitedir}/%{name}/*.so
-%dir %{py_sitedir}/%{name}/ogcserver
-%{py_sitedir}/%{name}/ogcserver/*.py[co]
+%attr(755,root,root) %{_libdir}/libmapnik.so
+%{_includedir}/mapnik
+%{_libdir}/libmapnik-json.a
+%{_libdir}/libmapnik-wkt.a
This page took 0.07054 seconds and 4 git commands to generate.