]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - lighttpd.spec
up to 1.4.45
[packages/lighttpd.git] / lighttpd.spec
index b587eb4d11ff3d72cc50377941aad14cee7c9b49..d00f5fe686aaf3ab6363fbfcba2c31c7f80d8d33 100644 (file)
@@ -20,6 +20,7 @@
 %bcond_with    gamin           # gamin for reducing number of stat() calls.
                                # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
 %bcond_with    gdbm            # gdbm in mod_trigger_b4_dl
+%bcond_without mod_trigger_b4_dl               # mod_trigger_b4_dl
 %bcond_with    webdav_props    # properties in mod_webdav (includes extra sqlite3/libxml deps)
 %bcond_with    webdav_locks    # webdav locks with extra efsprogs deps
 %bcond_with    valgrind        # compile code with valgrind support.
 %define                webdav_progs    1
 %endif
 
+# if(WITH_PCRE AND (WITH_MEMCACHED OR WITH_GDBM))
+%if %{without memcached} && %{without gdbm}
+%undefine      with_mod_trigger_b4_dl
+%endif
+
 Summary:       Fast and light HTTP server
 Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
-Version:       1.4.43
-Release:       0.4
+Version:       1.4.45
+Release:       1
 License:       BSD
 Group:         Networking/Daemons/HTTP
 Source0:       http://download.lighttpd.net/lighttpd/releases-1.4.x/%{name}-%{version}.tar.xz
-# Source0-md5: 95eda531c27b161ef8fa2b9bf4948caf
+# Source0-md5: a128e1eda76899ce3fd115efae5fe631
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.user
@@ -57,7 +63,6 @@ Source12:     %{name}.monitrc
 Source13:      branch.sh
 Source14:      TODO
 Source16:      %{name}.tmpfiles
-Source17:      %{name}.service
 Source100:     %{name}-mod_access.conf
 Source101:     %{name}-mod_accesslog.conf
 Source102:     %{name}-mod_alias.conf
@@ -106,6 +111,7 @@ Patch0:             %{name}-use_bin_sh.patch
 Patch1:                %{name}-mod_evasive-status_code.patch
 Patch2:                %{name}-mod_h264_streaming.patch
 Patch3:                %{name}-branding.patch
+Patch4:                systemd.patch
 Patch6:                test-port-setup.patch
 Patch7:                env-documentroot.patch
 URL:           http://www.lighttpd.net/
@@ -246,7 +252,9 @@ Requires:   %{name}-mod_authn_file = %{version}-%{release}
 # TODO: ldap and mysql should be optional
 # https://github.com/lighttpd/lighttpd1.4/blob/lighttpd-1.4.42/src/configfile.c#L426-L428
 Requires:      %{name}-mod_authn_ldap = %{version}-%{release}
+%if %{with mysql}
 Requires:      %{name}-mod_authn_mysql = %{version}-%{release}
+%endif
 Provides:      webserver(auth)
 
 %description mod_auth
@@ -904,6 +912,7 @@ Plik monitrc do monitorowania serwera www lighttpd.
 #%patch1 -p1 UPDATE (and submit upstream!) if you need this
 %{?with_h264_streaming:%patch2 -p1}
 %patch3 -p1
+%patch4 -p1
 %patch6 -p1
 #%patch7 -p1 probably fixed upstream
 
@@ -925,9 +934,9 @@ if [ "$ver" != "%{version}" ]; then
        exit 1
 fi
 
+%{__aclocal} -I scripts/m4
 %{__libtoolize}
 %{__autoheader}
-%{__aclocal}
 %{__autoconf}
 %{__automake}
 
@@ -976,7 +985,7 @@ cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
 cp -p %{SOURCE12} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
 cp -p %{SOURCE16} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
-cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
+cp -p doc/systemd/lighttpd.service $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
 
 rm -f $RPM_BUILD_ROOT%{pkglibdir}/*.la
 
@@ -1007,7 +1016,9 @@ cp -p %{SOURCE109} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evasive.conf
 cp -p %{SOURCE110} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_evhost.conf
 cp -p %{SOURCE112} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_fastcgi.conf
 cp -p %{SOURCE113} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_flv_streaming.conf
+%if %{with geoip}
 cp -p %{SOURCE140} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_geoip.conf
+%endif
 %if %{with h264_streaming}
 cp -p %{SOURCE136} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_h264_streaming.conf
 %endif
@@ -1021,12 +1032,16 @@ cp -p %{SOURCE122} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_simple_vhost.conf
 cp -p %{SOURCE123} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_ssi.conf
 cp -p %{SOURCE124} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_staticfile.conf
 cp -p %{SOURCE125} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_status.conf
+%if %{with mod_trigger_b4_dl}
 cp -p %{SOURCE126} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_trigger_b4_dl.conf
+%endif
 cp -p %{SOURCE139} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_uploadprogress.conf
 cp -p %{SOURCE127} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_userdir.conf
 cp -p %{SOURCE128} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_usertrack.conf
 cp -p %{SOURCE129} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_webdav.conf
+%if %{with mysql}
 cp -p %{SOURCE133} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/50_mod_mysql_vhost.conf
+%endif
 
 cp -p %{SOURCE134} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/55_mod_magnet.conf
 cp -p %{SOURCE111} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/55_mod_expire.conf
@@ -1045,19 +1060,6 @@ touch $RPM_BUILD_ROOT/var/lib/lighttpd/lighttpd.rrd
 install -d $RPM_BUILD_ROOT/etc/tmpwatch
 cp -p %{SOURCE138} $RPM_BUILD_ROOT/etc/tmpwatch/lighttpd-mod_compress.conf
 
-# avoid packaging dummy modules
-%if %{without mysql}
-%{__rm} $RPM_BUILD_ROOT%{pkglibdir}/mod_mysql_vhost.so
-%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/*_mod_mysql_vhost.conf
-%endif
-%if %{without geoip}
-%{__rm} $RPM_BUILD_ROOT%{pkglibdir}/mod_geoip.so
-%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/*_mod_geoip.conf
-%endif
-%if %{without krb5}
-%{__rm} $RPM_BUILD_ROOT%{pkglibdir}/mod_authn_gssapi.so
-%endif
-
 touch $RPM_BUILD_ROOT/var/log/%{name}/{access,error,breakage}.log
 
 %clean
@@ -1214,6 +1216,7 @@ fi
 %attr(755,root,root) %{_sbindir}/lighttpd-angel
 %dir %{pkglibdir}
 %{_mandir}/man8/lighttpd.8*
+%{_mandir}/man8/lighttpd-angel.8*
 %dir %{_lighttpddir}
 %dir %{_lighttpddir}/cgi-bin
 %dir %{_lighttpddir}/html
@@ -1264,9 +1267,11 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{pkglibdir}/mod_authn_ldap.so
 
+%if %{with mysql}
 %files mod_authn_mysql
 %defattr(644,root,root,755)
 %attr(755,root,root) %{pkglibdir}/mod_authn_mysql.so
+%endif
 
 %files mod_cgi
 %defattr(644,root,root,755)
@@ -1416,10 +1421,12 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_status.conf
 %attr(755,root,root) %{pkglibdir}/mod_status.so
 
+%if %{with mod_trigger_b4_dl}
 %files mod_trigger_b4_dl
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_trigger_b4_dl.conf
 %attr(755,root,root) %{pkglibdir}/mod_trigger_b4_dl.so
+%endif
 
 %files mod_uploadprogress
 %defattr(644,root,root,755)
This page took 0.0442900000000001 seconds and 4 git commands to generate.