]> git.pld-linux.org Git - packages/kp5-powerdevil.git/blobdiff - kp5-powerdevil.spec
- updated to 5.24.5
[packages/kp5-powerdevil.git] / kp5-powerdevil.spec
index 894fa94e664d49501601c145d4d34c5d0037dfef..a7f24c5d981e54fd3bd8db87ba9d87dc863d8c23 100644 (file)
@@ -1,16 +1,19 @@
-%define                kdeplasmaver    5.22.2.1
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeplasmaver    5.24.5
 %define                qtver           5.9.0
 %define                kpname          powerdevil
 
 Summary:       Manages the power consumption settings of a Plasma Shell
 Name:          kp5-%{kpname}
-Version:       5.22.2.1
+Version:       5.24.5
 Release:       1
 License:       LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
-# Source0-md5: b810ce3999aaeb9a1501ed86bdb0c318
-URL:           http://www.kde.org/
+Source0:       https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
+# Source0-md5: ac1e83397316954fb587c86d00f04591
+URL:           https://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: cmake >= 2.8.12
 BuildRequires: kf5-bluez-qt-devel
@@ -47,11 +50,16 @@ Manages the power consumption settings of a Plasma Shell.
 install -d build
 cd build
 %cmake -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        -DHTML_INSTALL_DIR=%{_kdedocdir} \
        ../
 %ninja_build
 
+%if %{with tests}
+ctest
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 %ninja_install -C build
@@ -107,3 +115,4 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/dbus-1/system.d/org.kde.powerdevil.chargethresholdhelper.conf
 %{_datadir}/polkit-1/actions/org.kde.powerdevil.chargethresholdhelper.policy
 %{_datadir}/qlogging-categories5/powerdevil.categories
+%{_libdir}/qt5/plugins/powerdevilpowerprofileaction_config.so
This page took 0.03591 seconds and 4 git commands to generate.