]> git.pld-linux.org Git - packages/kp5-kde-gtk-config.git/blobdiff - kp5-kde-gtk-config.spec
- updated to 5.27.7; cmake -B build
[packages/kp5-kde-gtk-config.git] / kp5-kde-gtk-config.spec
index 7eccd546e680d5164ebe3b9c3faa644db5dfeb68..470841bc3df65c69c29414aa7bf39e02e086ac48 100644 (file)
@@ -1,19 +1,24 @@
-%define                kdeplasmaver    5.23.0
-%define                qtver           5.9.0
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeplasmaver    5.27.7
+%define                qtver           5.15.2
 %define                kpname          kde-gtk-config
 Summary:       GTK2 and GTK3 Configurator for KDE
 Name:          kp5-%{kpname}
-Version:       5.23.0
+Version:       5.27.7
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
-# Source0-md5: 13de87a62abae8ab09988bd126cc035e
+Source0:       https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
+# Source0-md5: 77731f7530552c096785e938554c5c0e
 Patch0:                x32.patch
 %define                specflags       -I/usr/include/harfbuzz
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
-BuildRequires: cmake >= 2.8.12
+BuildRequires: cmake >= 3.16.0
+BuildRequires: gsettings-desktop-schemas
+BuildRequires: gsettings-desktop-schemas-devel
 BuildRequires: gtk+2-devel
 BuildRequires: gtk+3-devel
 BuildRequires: kf5-extra-cmake-modules >= 1.4.0
@@ -47,13 +52,16 @@ GTK2 and GTK3 Configurator for KDE.
 #%%patch0 -p1
 
 %build
-install -d build
-cd build
-%cmake -G Ninja \
+%cmake -B build \
+       -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-       -DHTML_INSTALL_DIR=%{_kdedocdir} \
-       ..
-%ninja_build
+       -DHTML_INSTALL_DIR=%{_kdedocdir}
+%ninja_build -C build
+
+%if %{with tests}
+ctest
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -79,3 +87,4 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/themes/Breeze/window_decorations.css
 %dir %{_datadir}/kcm-gtk-module
 %{_datadir}/kcm-gtk-module/preview.ui
+%attr(755,root,root) %{_libdir}/kconf_update_bin/remove_deprecated_gtk4_option
This page took 0.0573 seconds and 4 git commands to generate.