]> git.pld-linux.org Git - packages/kp5-kde-cli-tools.git/blobdiff - kp5-kde-cli-tools.spec
- relup
[packages/kp5-kde-cli-tools.git] / kp5-kde-cli-tools.spec
index 64fa3e09740ce901c1b430dc59f73700f9d79a24..5169b3414af78d63b2415eafba96389c29a072a8 100644 (file)
@@ -1,17 +1,20 @@
-%define                kdeplasmaver    5.24.2
-%define                qtver           5.9.0
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeplasmaver    5.27.11
+%define                qtver           5.15.2
 %define                kpname          kde-cli-tools
 Summary:       Tools based on KDE Frameworks 5 to better interact with the system
 Name:          kp5-%{kpname}
-Version:       5.24.2
+Version:       5.27.11
 Release:       2
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
 Source0:       https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
-# Source0-md5: 6d676950e8ac9f4471d172f8b667665e
+# Source0-md5: 1a124a230cb05c9b0ec14252b39729ea
 URL:           https://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
-BuildRequires: cmake >= 2.8.12
+BuildRequires: cmake >= 3.16.0
 BuildRequires: kf5-extra-cmake-modules >= 1.4.0
 BuildRequires: kf5-kcmutils-devel
 BuildRequires: kf5-kconfig-devel
@@ -21,6 +24,7 @@ BuildRequires:        kf5-kemoticons-devel
 BuildRequires: kf5-ki18n-devel
 BuildRequires: kf5-kiconthemes-devel
 BuildRequires: kf5-kitemmodels-devel
+BuildRequires: kf5-kpty-devel
 BuildRequires: kf5-kwindowsystem-devel
 BuildRequires: kp5-plasma-workspace-devel >= %{version}
 BuildRequires: ninja
@@ -37,13 +41,16 @@ Tools based on KDE Frameworks 5 to better interact with the system.
 %setup -q -n %{kpname}-%{version}
 
 %build
-install -d build
-cd build
-%cmake -G Ninja \
+%cmake -B build \
+       -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-       -DHTML_INSTALL_DIR=%{_kdedocdir} \
-       ..
-%ninja_build
+       -DHTML_INSTALL_DIR=%{_kdedocdir}
+%ninja_build -C build
+
+%if %{with tests}
+ctest
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -63,6 +70,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/kdecp5
 %attr(755,root,root) %{_bindir}/kdemv5
 %attr(755,root,root) %{_bindir}/keditfiletype5
+%attr(755,root,root) %{_bindir}/kinfo
 %attr(755,root,root) %{_bindir}/kioclient5
 %attr(755,root,root) %{_bindir}/kmimetypefinder5
 %attr(755,root,root) %{_bindir}/kstart5
@@ -85,6 +93,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(de) %{_mandir}/de/man1/kdesu.1*
 %lang(es) %{_mandir}/es/man1/kdesu.1*
 %lang(et) %{_mandir}/et/man1/kdesu.1*
+%lang(id) %{_mandir}/id/man1/kdesu.1*
 %lang(it) %{_mandir}/it/man1/kdesu.1*
 %lang(nb) %{_mandir}/nb/man1/kdesu.1*
 %lang(nl) %{_mandir}/nl/man1/kdesu.1*
@@ -97,5 +106,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/org.kde.keditfiletype.desktop
 %attr(755,root,root) %{_bindir}/kde-inhibit
 %lang(fr) %{_mandir}/fr/man1/kdesu.1*
+%lang(tr) %{_mandir}/tr/man1/kdesu.1*
 %{_libdir}/qt5/plugins/plasma/kcms/systemsettings_qwidgets/kcm_filetypes.so
 %{_desktopdir}/kcm_filetypes.desktop
This page took 0.043685 seconds and 4 git commands to generate.