]> git.pld-linux.org Git - packages/kodi.git/blobdiff - kodi.spec
convert configure to cmake bconds
[packages/kodi.git] / kodi.spec
index 8c97c032a73a11717f77168f81a84a05c15e984c..925bc3825c45acb78d2ca97fe804a928b3b6d065 100644 (file)
--- a/kodi.spec
+++ b/kodi.spec
@@ -53,7 +53,7 @@
 %bcond_with    system_dvdread  # build with system dvdread
 
 %define        codename Leia
-%define        subver  a2
+%define        subver  a3
 Summary:       Kodi is a free and open source media-player and entertainment hub
 Name:          kodi
 Version:       18.0
@@ -62,7 +62,7 @@ License:      GPL v2+ and GPL v3+
 Group:         Applications/Multimedia
 #Source0:      http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
 Source0:       https://github.com/xbmc/xbmc/archive/%{version}%{subver}-%{codename}.tar.gz
-# Source0-md5: 6e2262d8b38d4ed28f0b102e51eb9a8e
+# Source0-md5: bc912304c3c0bcfd63f85b5d2642972d
 Patch0:                jpeglib-boolean.patch
 Patch1:                disable-static.patch
 Patch2:                dvdread.patch
@@ -105,11 +105,12 @@ BuildRequires:    libcap-devel
 BuildRequires: libcdio-devel
 %{?with_libcec:BuildRequires:  libcec-devel >= 3.0.0}
 BuildRequires: libdrm-devel
+BuildRequires: libdvdcss-devel >= 1.4.1
 %{?with_system_dvdread:BuildRequires:  libdvdread-devel}
 BuildRequires: libgcrypt-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libltdl-devel
-BuildRequires: libmicrohttpd-devel
+BuildRequires: libmicrohttpd-devel >= 0.9.40
 BuildRequires: libogg-devel
 BuildRequires: libplist-devel
 BuildRequires: libpng-devel
@@ -130,6 +131,7 @@ BuildRequires:      mysql-devel
 %ifarch %{ix86}
 BuildRequires: nasm
 %endif
+BuildRequires: fstrcmp-devel >= 0.7
 BuildRequires: openssl-devel
 BuildRequires: pcre-cxx-devel
 BuildRequires: pkgconfig
@@ -195,7 +197,7 @@ all common digital media files from local and network storage media.
 %{?with_system_dvdread:%patch2 -p1}
 #%patch3 -p1
 #%patch4 -p1
-#%{!?with_system_dvdread:%patch5 -p1}
+%patch5 -p1
 
 #%{__rm} -r lib/cximage-6.0/zlib
 #%{__rm} -r lib/libhdhomerun
@@ -217,7 +219,13 @@ cd build
 # https://trac.kodi.tv/ticket/16861
 %define        specflags -I/usr/include/freetype2
 %cmake \
+       -DENABLE_INTERNAL_LIBDVD=OFF \
        -DENABLE_INTERNAL_CROSSGUID=OFF \
+       -DENABLE_DVDCSS=%{__true_false dvdcss} \
+       -DENABLE_UPNP=%{__true_false upnp} \
+       -DENABLE_AIRTUNES=%{__true_false airtunes} \
+       -DENABLE_OPTICAL=%{__true_false optical_drive} \
+       -DENABLE_INTERNAL_FFMPEG=%{!?with_system_ffmpeg:ON}%{?with_system_ffmpeg:OFF} \
        ..
 %if 0
 %configure \
@@ -228,12 +236,10 @@ cd build
        --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
        %{__enable_disable afpclient} \
        %{__enable_disable airplay} \
-       %{__enable_disable airtunes} \
        %{__enable_disable alsa} \
        %{__enable_disable asap_codec asap-codec} \
        %{__enable_disable avahi} \
        %{__enable_disable dbus} \
-       %{__enable_disable dvdcss} \
        %{__enable_disable gles} \
        %{__enable_disable gl} \
        %{__enable_disable gtest} \
@@ -249,7 +255,6 @@ cd build
        %{__enable_disable nfs} \
        %{__enable_disable non_free non-free} \
        %{__enable_disable openmax} \
-       %{__enable_disable optical_drive optical-drive} \
        %{__enable_disable profiling} \
        %{__enable_disable pulse} \
        %{__enable_disable rtmp} \
@@ -277,7 +282,7 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__rm} $RPM_BUILD_ROOT%{_docdir}/{version.txt,copying.txt,README.linux,LICENSE.GPL}
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/{version.txt,README.Linux.md,LICENSE.md}
 
 # not packaged
 %{__rm} $RPM_BUILD_ROOT%{_prefix}/lib/firewalld/services/kodi-*.xml
@@ -290,7 +295,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.md docs/README.linux
+%doc README.md docs/README.Linux.md
 %attr(755,root,root) %{_bindir}/TexturePacker
 %attr(755,root,root) %{_bindir}/kodi
 %attr(755,root,root) %{_bindir}/kodi-standalone
This page took 0.106015 seconds and 4 git commands to generate.