]> git.pld-linux.org Git - packages/kodi.git/blobdiff - kodi.spec
convert configure to cmake bconds
[packages/kodi.git] / kodi.spec
index 2e41897ee9a9cbaf3a2ab1c201b43209740008a2..925bc3825c45acb78d2ca97fe804a928b3b6d065 100644 (file)
--- a/kodi.spec
+++ b/kodi.spec
 %bcond_without system_ffmpeg   # build with system ffmpeg
 %bcond_with    system_dvdread  # build with system dvdread
 
-%define        codename Krypton
+%define        codename Leia
+%define        subver  a3
 Summary:       Kodi is a free and open source media-player and entertainment hub
 Name:          kodi
-Version:       17.6
-Release:       1
+Version:       18.0
+Release:       0.1
 License:       GPL v2+ and GPL v3+
 Group:         Applications/Multimedia
 #Source0:      http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
-Source0:       https://github.com/xbmc/xbmc/archive/%{version}-%{codename}.tar.gz
-# Source0-md5: a64c2fc56ddc41b9b0dded55eaabf170
+Source0:       https://github.com/xbmc/xbmc/archive/%{version}%{subver}-%{codename}.tar.gz
+# Source0-md5: bc912304c3c0bcfd63f85b5d2642972d
 Patch0:                jpeglib-boolean.patch
 Patch1:                disable-static.patch
 Patch2:                dvdread.patch
@@ -74,15 +75,15 @@ BuildRequires:      OpenGL-GLU-devel
 BuildRequires: OpenGL-devel
 BuildRequires: SDL2-devel
 BuildRequires: alsa-lib-devel
-BuildRequires: autoconf >= 2.59
-BuildRequires: automake
 BuildRequires: avahi-devel
 BuildRequires: bluez-libs-devel >= 4.99
 BuildRequires: bzip2-devel
-BuildRequires: cmake
+BuildRequires: cmake >= 3.4
 BuildRequires: crossguid-devel
 BuildRequires: curl-devel
 BuildRequires: dbus-devel
+BuildRequires: libfmt-devel >= 3.0.1
+BuildRequires: rapidjson-devel >= 1.1.0
 # libavcodec >= 56.26.100 libavfilter >= 5.11.102 libavformat >= 56.25.101 libavutil >= 54.20.100 libpostproc >= 53.3.100 libswscale >= 3.1.101 libswresample >= 1.1.100
 %{?with_system_ffmpeg:BuildRequires:   ffmpeg-devel >= 2.4.4}
 BuildRequires: flac-devel
@@ -104,11 +105,12 @@ BuildRequires:    libcap-devel
 BuildRequires: libcdio-devel
 %{?with_libcec:BuildRequires:  libcec-devel >= 3.0.0}
 BuildRequires: libdrm-devel
+BuildRequires: libdvdcss-devel >= 1.4.1
 %{?with_system_dvdread:BuildRequires:  libdvdread-devel}
 BuildRequires: libgcrypt-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libltdl-devel
-BuildRequires: libmicrohttpd-devel
+BuildRequires: libmicrohttpd-devel >= 0.9.40
 BuildRequires: libogg-devel
 BuildRequires: libplist-devel
 BuildRequires: libpng-devel
@@ -129,6 +131,7 @@ BuildRequires:      mysql-devel
 %ifarch %{ix86}
 BuildRequires: nasm
 %endif
+BuildRequires: fstrcmp-devel >= 0.7
 BuildRequires: openssl-devel
 BuildRequires: pcre-cxx-devel
 BuildRequires: pkgconfig
@@ -173,6 +176,11 @@ Requires:  libvorbis
 Obsoletes:     xbmc < 14.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# extracting debug info from /home/users/glen/tmp/kodi-18.0-root-glen/usr/lib64/kodi/kodi-x11
+# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
+%define                _noautostrip    kodi-x11
+%define                _enable_debug_packages  0
+
 %description
 Kodi Entertainment Center (formerly XBMC) is a free and open-source
 media player software developed by the XBMC Foundation, a non-profit
@@ -183,13 +191,13 @@ and view most videos, music, such as podcasts from the internet, and
 all common digital media files from local and network storage media.
 
 %prep
-%setup -q -n xbmc-%{version}-%{codename}
+%setup -q -n xbmc-%{version}%{?subver}-%{codename}
 #%patch0 -p1
 %patch1 -p1
 %{?with_system_dvdread:%patch2 -p1}
 #%patch3 -p1
 #%patch4 -p1
-%{!?with_system_dvdread:%patch5 -p1}
+%patch5 -p1
 
 #%{__rm} -r lib/cximage-6.0/zlib
 #%{__rm} -r lib/libhdhomerun
@@ -205,10 +213,21 @@ all common digital media files from local and network storage media.
 %endif
 
 %build
-#%{__make} -C tools/depends/native/libsquish-native \
-#      CXX="%{__cxx}"
-
-./bootstrap
+install -d build
+cd build
+# cmake not picking up include path from pkgconfig
+# https://trac.kodi.tv/ticket/16861
+%define        specflags -I/usr/include/freetype2
+%cmake \
+       -DENABLE_INTERNAL_LIBDVD=OFF \
+       -DENABLE_INTERNAL_CROSSGUID=OFF \
+       -DENABLE_DVDCSS=%{__true_false dvdcss} \
+       -DENABLE_UPNP=%{__true_false upnp} \
+       -DENABLE_AIRTUNES=%{__true_false airtunes} \
+       -DENABLE_OPTICAL=%{__true_false optical_drive} \
+       -DENABLE_INTERNAL_FFMPEG=%{!?with_system_ffmpeg:ON}%{?with_system_ffmpeg:OFF} \
+       ..
+%if 0
 %configure \
        ac_cv_type__Bool=yes \
        --disable-silent-rules \
@@ -217,12 +236,10 @@ all common digital media files from local and network storage media.
        --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
        %{__enable_disable afpclient} \
        %{__enable_disable airplay} \
-       %{__enable_disable airtunes} \
        %{__enable_disable alsa} \
        %{__enable_disable asap_codec asap-codec} \
        %{__enable_disable avahi} \
        %{__enable_disable dbus} \
-       %{__enable_disable dvdcss} \
        %{__enable_disable gles} \
        %{__enable_disable gl} \
        %{__enable_disable gtest} \
@@ -238,7 +255,6 @@ all common digital media files from local and network storage media.
        %{__enable_disable nfs} \
        %{__enable_disable non_free non-free} \
        %{__enable_disable openmax} \
-       %{__enable_disable optical_drive optical-drive} \
        %{__enable_disable profiling} \
        %{__enable_disable pulse} \
        %{__enable_disable rtmp} \
@@ -257,30 +273,30 @@ all common digital media files from local and network storage media.
        %{__enable_disable x11} \
        %{__enable_disable xrandr} \
        %{nil}
+%endif
 
-%{__make} V=1
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/{version.txt,README.Linux.md,LICENSE.md}
+
+# not packaged
+%{__rm} $RPM_BUILD_ROOT%{_prefix}/lib/firewalld/services/kodi-*.xml
 
 # no -devel package yet
 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
-%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
-
-# no real use for symlinks to datadir, and make rpm packaging more difficult (symlink vs dir issues)
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/xbmc
-%{__rm} $RPM_BUILD_ROOT%{_datadir}/xbmc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.md docs/README.linux
+%doc README.md docs/README.Linux.md
+%attr(755,root,root) %{_bindir}/TexturePacker
 %attr(755,root,root) %{_bindir}/kodi
 %attr(755,root,root) %{_bindir}/kodi-standalone
 %{_datadir}/%{name}
@@ -288,8 +304,3 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/kodi.desktop
 %{_iconsdir}/hicolor/*/apps/%{name}.png
 %{_datadir}/xsessions/kodi.desktop
-
-# legacy xbmc compatibility links
-%attr(755,root,root) %{_bindir}/xbmc
-%attr(755,root,root) %{_bindir}/xbmc-standalone
-%{_datadir}/xsessions/xbmc.desktop
This page took 0.057791 seconds and 4 git commands to generate.