]> git.pld-linux.org Git - packages/kf5-kpackage.git/blobdiff - kf5-kpackage.spec
- updated to 5.249.0; rel 0.1
[packages/kf5-kpackage.git] / kf5-kpackage.spec
index b2efae63b00a2790c07e0340a195930ae2a5caad..f977e020a38eb17aa59aef420ca5839a61047317 100644 (file)
@@ -1,22 +1,22 @@
 #
 # Conditional build:
 %bcond_with    tests           # build with tests
-%define                kdeframever     5.101
+%define                kdeframever     5.249.0
 %define                qtver           5.15.2
 %define                kfname          kpackage
 
 Summary:       Library to load and install packages as plugins
 Name:          kf5-%{kfname}
-Version:       5.101.0
-Release:       2
+Version:       5.249.0
+Release:       0.1
 License:       LGPL v2.1+
 Group:         X11/Libraries
-Source0:       https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
-# Source0-md5: 67891a31b5642865b90f39eeff0c7d67
+Source0:       https://download.kde.org/unstable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
+# Source0-md5: f7fca0ac09678a1d3c0f221ab368c815
 URL:           http://www.kde.org/
-BuildRequires: Qt5Core-devel >= %{qtver}
-BuildRequires: Qt5DBus-devel >= %{qtver}
-BuildRequires: Qt5Test-devel >= %{qtver}
+BuildRequires: Qt6Core-devel >= %{qtver}
+BuildRequires: Qt6DBus-devel >= %{qtver}
+BuildRequires: Qt6Test-devel >= %{qtver}
 BuildRequires: cmake >= 3.16
 BuildRequires: gettext-devel
 BuildRequires: kf5-extra-cmake-modules >= %{version}
@@ -28,15 +28,15 @@ BuildRequires:      ninja
 BuildRequires: rpmbuild(macros) >= 1.736
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
-Requires:      Qt5Core >= %{qtver}
-Requires:      Qt5DBus >= %{qtver}
+Requires:      Qt6Core >= %{qtver}
+Requires:      Qt6DBus >= %{qtver}
 Requires:      kf5-dirs
 Requires:      kf5-karchive >= %{version}
 Requires:      kf5-kcoreaddons >= %{version}
 Requires:      kf5-ki18n >= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                qt5dir          %{_libdir}/qt5
+%define                qt6dir          %{_libdir}/qt6
 
 %description
 Library to load and install packages as plugins.
@@ -58,26 +58,25 @@ Pliki nagłówkowe dla programistów używających %{kfname}.
 %setup -q -n %{kfname}-%{version}
 
 %build
-install -d build
-cd build
-%cmake -G Ninja \
+%cmake -B build \
+       -G Ninja \
        %{!?with_tests:-DBUILD_TESTING=OFF} \
-       -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-       ../
-%ninja_build
+       -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+
+%ninja_build -C build
 
 %if %{with tests}
-ctest
+%ninja_build -C build test
 %endif
 
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT%{_libdir}/qt5/plugins/kpackage/packagestructure
+install -d $RPM_BUILD_ROOT%{_libdir}/qt6/plugins/kpackage/packagestructure
 %ninja_install -C build
 
-%find_lang lib%{kfname}5
+%find_lang lib%{kfname}6
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -85,33 +84,28 @@ rm -rf $RPM_BUILD_ROOT
 %post -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
-%files -f lib%{kfname}5.lang
+%files -f lib%{kfname}6.lang
 %defattr(644,root,root,755)
 %doc README.md
-%{_datadir}/qlogging-categories5/kpackage.categories
-%attr(755,root,root) %{_bindir}/kpackagetool5
-%ghost %{_libdir}/libKF5Package.so.5
-%attr(755,root,root) %{_libdir}/libKF5Package.so.*.*
-%dir %{_libdir}/qt5/plugins/kpackage
-%dir %{_libdir}/qt5/plugins/kpackage/packagestructure
-%{_mandir}/man1/kpackagetool5.1*
-%lang(ca) %{_mandir}/ca/man1/kpackagetool5.1*
-%lang(de) %{_mandir}/de/man1/kpackagetool5.1*
-%lang(es) %{_mandir}/es/man1/kpackagetool5.1*
-%lang(it) %{_mandir}/it/man1/kpackagetool5.1*
-%lang(nl) %{_mandir}/nl/man1/kpackagetool5.1*
-%lang(pt) %{_mandir}/pt/man1/kpackagetool5.1*
-%lang(pt_BR) %{_mandir}/pt_BR/man1/kpackagetool5.1*
-%lang(sv) %{_mandir}/sv/man1/kpackagetool5.1*
-%lang(uk) %{_mandir}/uk/man1/kpackagetool5.1*
-%{_datadir}/kservicetypes5/kpackage-generic.desktop
-%{_datadir}/kservicetypes5/kpackage-genericqml.desktop
-%{_datadir}/kservicetypes5/kpackage-packagestructure.desktop
-%lang(fr) %{_mandir}/fr/man1/kpackagetool5.1*
-%{_datadir}/qlogging-categories5/kpackage.renamecategories
+%{_datadir}/qlogging-categories6/kpackage.categories
+%attr(755,root,root) %{_bindir}/kpackagetool6
+%ghost %{_libdir}/libKF6Package.so.6
+%attr(755,root,root) %{_libdir}/libKF6Package.so.*.*
+%dir %{_libdir}/qt6/plugins/kpackage
+%dir %{_libdir}/qt6/plugins/kpackage/packagestructure
+%{_mandir}/man1/kpackagetool6.1*
+%lang(ca) %{_mandir}/ca/man1/kpackagetool6.1*
+%lang(es) %{_mandir}/es/man1/kpackagetool6.1*
+%lang(it) %{_mandir}/it/man1/kpackagetool6.1*
+%lang(nl) %{_mandir}/nl/man1/kpackagetool6.1*
+%lang(pt_BR) %{_mandir}/pt_BR/man1/kpackagetool6.1*
+%lang(uk) %{_mandir}/uk/man1/kpackagetool6.1*
+%lang(fr) %{_mandir}/fr/man1/kpackagetool6.1*
+%{_datadir}/qlogging-categories6/kpackage.renamecategories
+%lang(tr) %{_mandir}/tr/man1/kpackagetool6.1*
 
 %files devel
 %defattr(644,root,root,755)
-%{_includedir}/KF5/KPackage
-%{_libdir}/cmake/KF5Package
-%{_libdir}/libKF5Package.so
+%{_includedir}/KF6/KPackage
+%{_libdir}/cmake/KF6Package
+%{_libdir}/libKF6Package.so
This page took 0.068216 seconds and 4 git commands to generate.