]> git.pld-linux.org Git - packages/kf5-extra-cmake-modules.git/blobdiff - kf5-extra-cmake-modules.spec
- Up to 5.67.0.
[packages/kf5-extra-cmake-modules.git] / kf5-extra-cmake-modules.spec
index 34695a02d18390d4f835f26aff5909cfe19c9a33..92743db80e18cdd5346cebc3765119659ef5fa40 100644 (file)
@@ -1,30 +1,45 @@
-# TODO where to put files and docs of KF5
-%define         _state          stable
-%define                orgname         extra-cmake-modules
+#
+# Conditional build:
+%bcond_without tests           # build without tests
 
+%define                orgname         extra-cmake-modules
+%define                kdeframever     5.67
 Summary:       Extra Cmake Modules for KF5
-Name:          kf5-extra-cmake-modules
-Version:       1.0.0
-Release:       0.2
-License:       See COPYING-CMAKE-SCRIPTS
-Group:         X11/Libraries
-Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/5.0.0/%{orgname}-%{version}.tar.xz
-# Source0-md5: a7b9e8756fdc2b3a8518ad9f9d21dfd5
+Summary(pl.UTF-8):     Dodatkowe moduły Cmake'a dla KF5
+Name:          kf5-%{orgname}
+Version:       5.67.0
+Release:       1
+License:       BSD
+Group:         Development/Building
+Source0:       http://download.kde.org/stable/frameworks/%{kdeframever}/%{orgname}-%{version}.tar.xz
+# Source0-md5: f59f70433adc17145b6ce2e8ab0c416d
+Patch0:                %{orgname}-tests.patch
 URL:           http://www.kde.org/
 BuildRequires: cmake >= 2.8.12
-BuildRequires: rpmbuild(macros) >= 1.164
-BuildRequires: sphinx-pdg
+BuildRequires: qt5-assistant >= 5.9.0
+BuildRequires: qt5-linguist
+BuildRequires: rpmbuild(macros) >= 1.698
+BuildRequires: sed >= 4.0
+BuildRequires: sphinx-pdg >= 1.2
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
+%if %{with tests}
+BuildRequires: Qt5Core-devel >= 5.9.0
+BuildRequires: Qt5Gui-devel >= 5.9.0
+BuildRequires: Qt5Network-devel >= 5.9.0
+BuildRequires: Qt5Qml-devel >= 5.9.0
+BuildRequires: Qt5Quick-devel >= 5.9.0
+BuildRequires: libstdc++-devel >= 6:4.9
+BuildRequires: qt5-build >= 5.9.0
+%endif
+Obsoletes:     kf5-extra-cmake-modules-doc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                qt5dir          %{_libdir}/qt5
-
 %description
 The Extra CMake Modules package, or ECM, adds to the modules provided
-by CMake, including both ones used by ``find_package()`` to find
-common software and ones that can be used directly in
-``CMakeLists.txt`` files to perform common tasks.
+by CMake, including both ones used by find_package() to find common
+software and ones that can be used directly in CMakeLists.txt files to
+perform common tasks.
 
 In addition, it provides common build settings used in software
 produced by the KDE community.
@@ -33,53 +48,56 @@ While the driving force of this module is to reduce duplication in
 CMake scripts across KDE software, it is intended to be useful for any
 software that uses the CMake build system.
 
-%package doc
-Summary:       Documentation for ECM
-Group:         Documentation
-%if "%{_rpmversion}" >= "5"
-BuildArch:     noarch
-%endif
+%description -l pl.UTF-8
+Pakiet Extra CMake Modules (ECM) dostarcza dodatkowe moduły do tych
+dostarczanych przez CMake'a, zawierające te używane przez
+find_package() do szukania popularnego oprogramowania, a także takie,
+których można używać bezpośrednio w CMakeLists.txt do wykonywania
+wspólnych zadań.
+
+Ponadto pakiet dostarcza wspólne ustawienia budowana używane w
+oprogramowaniu tworzonym przez społeczność KDE.
 
-%description doc
-Documentation for ECM.
+O ile główną motywacją tego modułu jest zmniejszenie duplikacji w
+skryptach CMake'a w oprogramowaniu KDE, ma także być przydatny dla
+dowolnych programów wykorzystujących system budowania CMake.
 
 %prep
 %setup -q -n %{orgname}-%{version}
+%patch0 -p1
+
+# causes make install failure after running tests
+%{__sed} -i -e '/ECMToolchainAndroidTest/d' tests/CMakeLists.txt
 
 %build
 install -d build
 cd build
-%cmake \
-       -DBIN_INSTALL_DIR=%{_bindir} \
-       -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
-       -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
-       -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
-       -DQML_INSTALL_DIR=%{qt5dir}/qml \
-       -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
-       -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
-       -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
-       -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
-       -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
-       -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
-       -D_IMPORT_PREFIX=%{_prefix} \
-       ../
+%cmake .. \
+       %{!?with_tests:-DBUILD_TESTING=OFF}
+
 %{__make}
 
+%if %{with tests}
+# GenerateSipBindings wants clang and has libclang checks incompatible with libclang >= 4
+# ECMPoQmToolsTest fails to build it's own moc file
+ctest -E '(GenerateSipBindings|ECMPoQmToolsTest)'
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} -C build/ install \
+%{__make} -C build -j1 install \
         DESTDIR=$RPM_BUILD_ROOT
 
+%{__mv} $RPM_BUILD_ROOT%{_docdir}/ECM ECM-doc
+install -d $RPM_BUILD_ROOT%{_datadir}/qlogging-categories5
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYING-CMAKE-SCRIPTS README.rst
+%doc COPYING-CMAKE-SCRIPTS README.rst ECM-doc/*
 %{_datadir}/ECM
-%{_mandir}/man7/ecm*
-
-%files doc
-%defattr(644,root,root,755)
-%{_docdir}/ECM
+%{_datadir}/qlogging-categories5
+%{_mandir}/man7/ecm*.7*
This page took 0.034334 seconds and 4 git commands to generate.