]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- up to 4.9.59
[packages/kernel.git] / kernel.spec
index 487b1ac3a6a9a66c6cb1b4d3a786af4a2567b9f1..c66df98330a66457f17b41de9d8c01b677a35826 100644 (file)
@@ -29,6 +29,8 @@
 %bcond_without imq             # imq support
 %bcond_without ipv6            # ipv6 support
 
+%bcond_without aufs            # aufs4 support
+
 %bcond_with    vserver         # support for VServer
 
 %bcond_with    rt              # real-time kernel (CONFIG_PREEMPT_RT) for low latencies
 %endif
 
 %define                rel             1
-%define                basever         4.8
-%define                postver         .10
+%define                basever         4.9
+%define                postver         .59
 
 # define this to '-%{basever}' for longterm branch
-%define                versuffix       %{nil}
+%define                versuffix       -%{basever}
 
 # __alt_kernel is list of features, empty string if none set
 # _alt kernel is defined as: %{nil}%{?alt_kernel:-%{?alt_kernel}} (defined in rpm.macros)
@@ -120,10 +122,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
-# Source0-md5: c1af0afbd3df35c1ccdc7a5118cd2d07
+# Source0-md5: 0a68ef3615c64bd5ee54a3320e46667d
 %if "%{postver}" != ".0"
 Patch0:                https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  37eadcdaefae51ced736747cb817aa58
+# Patch0-md5:  c1bc6405ad9a51a2b86a6031f2fcddfd
 %endif
 Source1:       kernel.sysconfig
 
@@ -197,12 +199,11 @@ Patch101: kernel-vserver-fixes.patch
 # Patch creation:
 # git clone git://github.com/sfjro/aufs4-standalone.git
 # cd aufs4-standalone
-# git checkout -b aufs4.8 origin/aufs4.8
+# git checkout -b aufs4.9 origin/aufs4.9
 # cat aufs4-kbuild.patch aufs4-base.patch aufs4-mmap.patch aufs4-standalone.patch > ~/rpm/packages/kernel/kernel-aufs4.patch
 # rm -rf linux && mkdir linux
 # cp -a Documentation fs include linux
-# diff -urN /usr/share/empty linux >> ~/rpm/packages/kernel/kernel-aufs4.patch
-# drop hunk at the end of patch (hunk is patching include/linux/Kbuild with single line change)
+# diff -urN /usr/share/empty linux | filterdiff -x linux/include/uapi/linux/Kbuild >> ~/rpm/packages/kernel/kernel-aufs4.patch
 # cat aufs4-loopback.patch >> ~/rpm/packages/kernel/kernel-aufs4.patch
 #
 Patch145:      kernel-aufs4.patch
@@ -212,7 +213,7 @@ Patch146:   kernel-aufs4+vserver.patch
 Patch250:      kernel-fix_256colors_menuconfig.patch
 
 # https://rt.wiki.kernel.org/
-# https://www.kernel.org/pub/linux/kernel/projects/rt/4.8/patch-4.8.6-rt5.patch.xz
+# https://www.kernel.org/pub/linux/kernel/projects/rt/4.9/patch-4.9.27-rt18.patch.xz
 Patch500:      kernel-rt.patch
 
 Patch2000:     kernel-small_fixes.patch
@@ -692,11 +693,13 @@ cd linux-%{basever}
 %patch101 -p1
 %endif
 
-# aufs3
+%if %{with aufs}
+# aufs4
 %patch145 -p1
 %if %{with vserver}
 %patch146 -p1
 %endif
+%endif
 
 %if %{with rescuecd}
 %patch7000 -p1
This page took 0.032568 seconds and 4 git commands to generate.