]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- up to 4.3.0; builds on x86_64; untested, so rel 0.1
[packages/kernel.git] / kernel.spec
index d118708b0327c00ab88b16961e89b2ae4fa3df77..a09995fa94a02dae751cbfe58fe84fe13d9e92a2 100644 (file)
 %bcond_without source          # don't build kernel-source package
 %bcond_without doc                     # don't build kernel-doc package
 %bcond_without pcmcia          # don't build pcmcia
+%bcond_without firmware        # don't build firmware into main package
 
 %bcond_with    verbose         # verbose build (V=1)
 
 %bcond_with    fbcondecor      # build fbcondecor (disable FB_TILEBLITTING and affected fb modules)
 %bcond_without pae             # build PAE (HIGHMEM64G) support on 32bit i686 athlon pentium3 pentium4
 %bcond_with    nfsroot         # build with root on NFS support
+%bcond_with    uksm            # build with UKSM patch, http://kerneldedup.org/projects/uksm/
 
 %bcond_without imq             # imq support
 %bcond_without esfq            # esfq support
 %bcond_without ipv6            # ipv6 support
-%bcond_with    padmcrypt       # parallel dm-crypt
 
 %bcond_with    vserver         # support for VServer
 
@@ -68,9 +69,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
-%define                basever         3.18
-%define                postver         .6
+%define                rel             0.1
+%define                basever         4.3
+%define                postver         .0
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -115,11 +116,11 @@ Release:  %{rel}
 Epoch:         3
 License:       GPL v2
 Group:         Base/Kernel
-Source0:       http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
-# Source0-md5: 9e854df51ca3fef8bfe566dbd7b89241
+Source0:       http://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
+# Source0-md5: 58b35794eee3b6d52ce7be39357801e7
 %if "%{postver}" != ".0"
-Patch0:                http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
-# Patch0-md5:  30aa769974e64fd17a01724d1577a913
+Patch0:                http://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
+# Patch0-md5:  408f9975969da326b5804a04dbf0d4de
 %endif
 Source1:       kernel.sysconfig
 
@@ -143,6 +144,7 @@ Source41:   kernel-patches.config
 Source43:      kernel-vserver.config
 
 Source55:      kernel-imq.config
+Source56:      kernel-uksm.config
 
 Source58:      kernel-inittmpfs.config
 
@@ -186,28 +188,33 @@ Patch59:  kernel-rndis_host-wm5.patch
 # http://patches.aircrack-ng.org/hostap-kernel-2.6.18.patch
 Patch85:       kernel-hostap.patch
 
-%define        vserver_patch 3.10.9-vs2.3.6.6
-# http://vserver.13thfloor.at/Experimental/patch-3.13.6-vs2.3.6.11.diff
+%define        vserver_patch 3.18.5-vs2.3.7.3
+# http://vserver.13thfloor.at/Experimental/patch-3.18.5-vs2.3.7.3.diff
 # note there are additional patches from above url:
 # - *fix* are real fixes (we want these)
 # - *feat* are new features/tests (we don't want these)
 Patch100:      kernel-vserver-2.3.patch
 Patch101:      kernel-vserver-fixes.patch
 
-# git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git, read README
+# git://github.com/sfjro/aufs4-standalone.git, read README
 # Patch creation:
-# git clone git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git
-# cd aufs3-standalone
-# git checkout -b aufs3.15 origin/aufs3.15
-# cat aufs3-kbuild.patch aufs3-base.patch aufs3-mmap.patch aufs3-standalone.patch > ~/rpm/packages/kernel/kernel-aufs3.patch
+# git clone git://github.com/sfjro/aufs4-standalone.git
+# cd aufs4-standalone
+# git checkout -b aufs4.3 origin/aufs4.3
+# cat aufs4-kbuild.patch aufs4-base.patch aufs4-mmap.patch aufs4-standalone.patch > ~/rpm/packages/kernel/kernel-aufs4.patch
 # mkdir linux
 # cp -a Documentation fs include linux
-# diff -urN /usr/share/empty linux >> ~/rpm/packages/kernel/kernel-aufs3.patch
+# diff -urN /usr/share/empty linux >> ~/rpm/packages/kernel/kernel-aufs4.patch
 # drop hunk at the end of patch (hunk is patching include/linux/Kbuild with single line change)
-# cat aufs3-loopback.patch >> ~/rpm/packages/kernel/kernel-aufs3.patch
+# cat aufs4-loopback.patch >> ~/rpm/packages/kernel/kernel-aufs4.patch
 #
-Patch145:      kernel-aufs3.patch
-Patch146:      kernel-aufs3+vserver.patch
+Patch145:      kernel-aufs4.patch
+Patch146:      kernel-aufs4+vserver.patch
+
+%define uksm_major_version 0.1.2.3
+%define uksm_version %{uksm_major_version}-for-v3.18
+Patch150:      http://kerneldedup.org/download/uksm/%{uksm_major_version}/uksm-%{uksm_version}.patch
+# Patch150-md5:        b6a2b2aae9c2844d0c74690632d7019e
 
 # Show normal colors in menuconfig with ncurses ABI 6
 Patch250:      kernel-fix_256colors_menuconfig.patch
@@ -215,20 +222,13 @@ Patch250: kernel-fix_256colors_menuconfig.patch
 # https://patchwork.kernel.org/patch/236261/
 Patch400:      kernel-virtio-gl-accel.patch
 
-# http://people.redhat.com/mpatocka/patches/kernel/dm-crypt-paralelizace/current/series.html
-Patch500:      dm-crypt-unbound-workqueue.patch
-Patch501:      dm-crypt-dont-allocate-partial-pages.patch
-Patch502:      dm-crypt-fix-allocation-deadlock.patch
-Patch503:      dm-crypt-remove-io-pool.patch
-Patch504:      dm-crypt-offload-writes-to-thread.patch
-Patch505:      dm-crypt-sort-requests.patch
-
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
+Patch2004:     kernel-libata-ahci-pm.patch
 
-# bzr co lp:apparmor
-# ls apparmor/kernel-patches/3.12
+# git://git.kernel.org/pub/scm/linux/kernel/git/jj/linux-apparmor
+# branch v4.2-aa2.8-out-of-tree
 Patch5000:     kernel-apparmor.patch
 
 # for rescuecd
@@ -258,11 +258,11 @@ BuildRequires:    perl-base
 BuildRequires: rpm-build >= 4.5-24
 BuildRequires: rpmbuild(macros) >= 1.707
 Requires(post):        coreutils
-Requires(post):        geninitrd >= 10000.32
+Requires(post):        geninitrd >= 12749
 Requires(post):        kmod >= 12-2
 Requires:      /sbin/depmod
 Requires:      coreutils
-Requires:      geninitrd >= 10000.32
+Requires:      geninitrd >= 12749
 Requires:      kmod >= 12-2
 %if %{with pae}
 %ifarch i686 athlon pentium3 pentium4
@@ -273,7 +273,11 @@ Suggests:  crda
 Suggests:      dracut
 Suggests:      keyutils
 Suggests:      kernel%{versuffix}-ide = %{epoch}:%{version}-%{release}
+%if %{with firmware}
 Suggests:      linux-firmware
+%else
+Requires:      linux-firmware
+%endif
 Provides:      %{name}(netfilter) = 20070806
 Provides:      %{name}(vermagic) = %{kernel_release}
 Obsoletes:     kernel%{_alt_kernel}-char-lirc-ene0100
@@ -705,6 +709,11 @@ cd linux-%{basever}
 %patch146 -p1
 %endif
 
+# UKSM
+%if %{with uksm}
+%patch150 -p1
+%endif
+
 %if %{with rescuecd}
 %patch7000 -p1
 %endif
@@ -717,22 +726,13 @@ cd linux-%{basever}
 # virtio-gl
 %patch400 -p1
 
-# parallel dm-crypt
-%if %{with padmcrypt}
-%patch500 -p1
-%patch501 -p1
-%patch502 -p1
-%patch503 -p1
-%patch504 -p1
-%patch505 -p1
-%endif
-
 %endif # vanilla
 
 # Small fixes:
 %patch2000 -p1
 %patch2001 -p1
 #%patch2003 -p1
+%patch2004 -p1
 
 # Do not remove this, please!
 #%%patch50000 -p1
@@ -922,6 +922,9 @@ EOCONFIG
 %if %{with imq}
                %{SOURCE55} \
 %endif
+%if %{with uksm}
+               %{SOURCE56} \
+%endif
 %if %{with vserver}
                %{SOURCE43} \
 %endif
@@ -952,7 +955,7 @@ cd -
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} %{MakeOpts} -j1 %{!?with_verbose:-s} modules_install firmware_install \
+%{__make} %{MakeOpts} -j1 %{!?with_verbose:-s} modules_install %{?with_firmware:firmware_install} \
        -C %{objdir} \
        %{?with_verbose:V=1} \
        DEPMOD=%{DepMod} \
@@ -1248,7 +1251,9 @@ fi
 /boot/config-%{kernel_release}
 %ghost %{initrd_dir}/initrd-%{kernel_release}.gz
 %ghost %{initrd_dir}/initramfs-%{kernel_release}.img
+%if %{with firmware}
 /lib/firmware/%{kernel_release}
+%endif
 
 %dir /lib/modules/%{kernel_release}
 %dir /lib/modules/%{kernel_release}/kernel
@@ -1468,7 +1473,6 @@ fi
 %{_kernelsrcdir}/arch/m68k/install.sh
 %{_kernelsrcdir}/arch/parisc/install.sh
 %{_kernelsrcdir}/arch/x86/ia32/[!M]*
-%{_kernelsrcdir}/arch/ia64/kvm
 %{_kernelsrcdir}/arch/powerpc/kvm
 %ifarch ppc ppc64
 %exclude %{_kernelsrcdir}/arch/powerpc/lib/crtsavres.*
@@ -1483,6 +1487,7 @@ fi
 %exclude %{_kernelsrcdir}/drivers/lguest/lg.h
 %exclude %{_kernelsrcdir}/drivers/media/pci/bt8xx/bttv.h
 %{_kernelsrcdir}/block
+%{_kernelsrcdir}/certs
 %{_kernelsrcdir}/crypto
 %{_kernelsrcdir}/drivers
 %{_kernelsrcdir}/firmware
This page took 0.046704 seconds and 4 git commands to generate.