]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- up to 4.3.0; builds on x86_64; untested, so rel 0.1
[packages/kernel.git] / kernel.spec
index a548204746bece425285936d7cfa7b5c65ec1de7..a09995fa94a02dae751cbfe58fe84fe13d9e92a2 100644 (file)
@@ -30,7 +30,6 @@
 %bcond_without imq             # imq support
 %bcond_without esfq            # esfq support
 %bcond_without ipv6            # ipv6 support
-%bcond_with    padmcrypt       # parallel dm-crypt
 
 %bcond_with    vserver         # support for VServer
 
@@ -70,9 +69,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
-%define                basever         4.0
-%define                postver         .2
+%define                rel             0.1
+%define                basever         4.3
+%define                postver         .0
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -118,10 +117,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
-# Source0-md5: a86916bd12798220da9eb4a1eec3616d
+# Source0-md5: 58b35794eee3b6d52ce7be39357801e7
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
-# Patch0-md5:  a5a2d31a62688759482968b9c1dc135c
+# Patch0-md5:  408f9975969da326b5804a04dbf0d4de
 %endif
 Source1:       kernel.sysconfig
 
@@ -197,20 +196,20 @@ Patch85:  kernel-hostap.patch
 Patch100:      kernel-vserver-2.3.patch
 Patch101:      kernel-vserver-fixes.patch
 
-# git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git, read README
+# git://github.com/sfjro/aufs4-standalone.git, read README
 # Patch creation:
-# git clone git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git
-# cd aufs3-standalone
-# git checkout -b aufs4.0 origin/aufs4.0
-# cat aufs3-kbuild.patch aufs3-base.patch aufs3-mmap.patch aufs3-standalone.patch > ~/rpm/packages/kernel/kernel-aufs3.patch
+# git clone git://github.com/sfjro/aufs4-standalone.git
+# cd aufs4-standalone
+# git checkout -b aufs4.3 origin/aufs4.3
+# cat aufs4-kbuild.patch aufs4-base.patch aufs4-mmap.patch aufs4-standalone.patch > ~/rpm/packages/kernel/kernel-aufs4.patch
 # mkdir linux
 # cp -a Documentation fs include linux
-# diff -urN /usr/share/empty linux >> ~/rpm/packages/kernel/kernel-aufs3.patch
+# diff -urN /usr/share/empty linux >> ~/rpm/packages/kernel/kernel-aufs4.patch
 # drop hunk at the end of patch (hunk is patching include/linux/Kbuild with single line change)
-# cat aufs3-loopback.patch >> ~/rpm/packages/kernel/kernel-aufs3.patch
+# cat aufs4-loopback.patch >> ~/rpm/packages/kernel/kernel-aufs4.patch
 #
-Patch145:      kernel-aufs3.patch
-Patch146:      kernel-aufs3+vserver.patch
+Patch145:      kernel-aufs4.patch
+Patch146:      kernel-aufs4+vserver.patch
 
 %define uksm_major_version 0.1.2.3
 %define uksm_version %{uksm_major_version}-for-v3.18
@@ -223,21 +222,13 @@ Patch250: kernel-fix_256colors_menuconfig.patch
 # https://patchwork.kernel.org/patch/236261/
 Patch400:      kernel-virtio-gl-accel.patch
 
-# http://people.redhat.com/mpatocka/patches/kernel/dm-crypt-paralelizace/current/series.html
-Patch500:      dm-crypt-unbound-workqueue.patch
-Patch501:      dm-crypt-dont-allocate-partial-pages.patch
-Patch502:      dm-crypt-fix-allocation-deadlock.patch
-Patch503:      dm-crypt-remove-io-pool.patch
-Patch504:      dm-crypt-offload-writes-to-thread.patch
-Patch505:      dm-crypt-sort-requests.patch
-
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
 Patch2004:     kernel-libata-ahci-pm.patch
 
-# bzr co lp:apparmor
-# ls apparmor/kernel-patches/3.12
+# git://git.kernel.org/pub/scm/linux/kernel/git/jj/linux-apparmor
+# branch v4.2-aa2.8-out-of-tree
 Patch5000:     kernel-apparmor.patch
 
 # for rescuecd
@@ -267,11 +258,11 @@ BuildRequires:    perl-base
 BuildRequires: rpm-build >= 4.5-24
 BuildRequires: rpmbuild(macros) >= 1.707
 Requires(post):        coreutils
-Requires(post):        geninitrd >= 10000.32
+Requires(post):        geninitrd >= 12749
 Requires(post):        kmod >= 12-2
 Requires:      /sbin/depmod
 Requires:      coreutils
-Requires:      geninitrd >= 10000.32
+Requires:      geninitrd >= 12749
 Requires:      kmod >= 12-2
 %if %{with pae}
 %ifarch i686 athlon pentium3 pentium4
@@ -735,16 +726,6 @@ cd linux-%{basever}
 # virtio-gl
 %patch400 -p1
 
-# parallel dm-crypt
-%if %{with padmcrypt}
-%patch500 -p1
-%patch501 -p1
-%patch502 -p1
-%patch503 -p1
-%patch504 -p1
-%patch505 -p1
-%endif
-
 %endif # vanilla
 
 # Small fixes:
@@ -1506,6 +1487,7 @@ fi
 %exclude %{_kernelsrcdir}/drivers/lguest/lg.h
 %exclude %{_kernelsrcdir}/drivers/media/pci/bt8xx/bttv.h
 %{_kernelsrcdir}/block
+%{_kernelsrcdir}/certs
 %{_kernelsrcdir}/crypto
 %{_kernelsrcdir}/drivers
 %{_kernelsrcdir}/firmware
This page took 0.130989 seconds and 4 git commands to generate.