]> git.pld-linux.org Git - packages/iptables.git/blobdiff - iptables.spec
- release 5 (rebuild with libnftnl 1.0.8)
[packages/iptables.git] / iptables.spec
index d43f212039467ded230e4f53b52189180e241685..610f10590e77cf7f58ef47c988df329b5cbf6414 100644 (file)
@@ -3,6 +3,8 @@
 # - update BR to real required llh version
 # - check if kernel-headers are still required to properly build iptabels for dist kernel
 # - fix makefile (-D_UNKNOWN_KERNEL_POINTER_SIZE issue)
+# - think what to do with the useless 'ebtables' wrapper. The original old
+#   ebtables is still needed e.g. for libvirt's nwfilter
 #
 # Conditional build:
 %bcond_without doc             # without documentation (HOWTOS) which needed TeX
@@ -34,7 +36,7 @@ Summary(uk.UTF-8):    Утиліти для керування пакетними 
 Summary(zh_CN.UTF-8):  Linux内核包过滤管理工具
 Name:          iptables%{?with_vserver:-vserver}
 Version:       1.6.1
-Release:       1
+Release:       5
 License:       GPL v2
 Group:         Networking/Admin
 Source0:       ftp://ftp.netfilter.org/pub/iptables/%{orgname}-%{version}.tar.bz2
@@ -47,6 +49,7 @@ Source6:      %{orgname}-config
 Source7:       %{name6}-config
 Source8:       %{orgname}.service
 Source9:       %{name6}.service
+# these are not compatible with this package! there are no ebtables-save and ebtables-restore here
 Source10:      ebtables.init
 Source11:      ebtables-config
 Source12:      ebtables.service
@@ -57,6 +60,7 @@ Patch1:               %{orgname}-batch.patch
 Patch2:                no-libiptc.patch
 Patch3:                %{orgname}-aligned_u64.patch
 Patch4:                %{orgname}-ebtables.patch
+Patch5:                ebtables-X.patch
 # --- ADDITIONAL/CHANGED EXTENSIONS:
 # just ipt_IPV4OPTSSTRIP now
 Patch10:       %{orgname}-20070806.patch
@@ -106,10 +110,9 @@ Requires:  libnetfilter_conntrack >= 1.0.6
 Requires:      libnfnetlink >= 1.0
 %{?with_nftables:Requires:     libnftnl >= 1.0.5}
 Provides:      arptables
-Provides:      ebtables
 Provides:      firewall-userspace-tool
+%{?with_vserver:Provides:      iptables = %{version}-%{release}}
 Obsoletes:     arptables
-Obsoletes:     ebtables
 Obsoletes:     ipchains
 Obsoletes:     iptables24-compat
 Obsoletes:     netfilter
@@ -184,12 +187,13 @@ Summary(pl.UTF-8):        Iptables init (w stylu RedHata)
 Group:         Networking/Admin
 Requires(post,preun):  /sbin/chkconfig
 Requires(post,preun,postun):   systemd-units >= 38
-Requires:      %{name}
+Requires:      %{name} = %{version}-%{release}
 Requires:      rc-scripts >= 0.4.3.0
 Requires:      systemd-units >= 38
 Obsoletes:     firewall-init
 Obsoletes:     firewall-init-ipchains
 Obsoletes:     iptables24-init
+%{?with_vserver:Provides:      iptables-init = %{version}-%{release}}
 
 %description init
 Iptables-init is meant to provide an alternate way than firewall-init
@@ -200,6 +204,29 @@ Iptables-init ma na celu udostępnienie alternatywnego w stosunku do
 firewall-init sposobu włączania i wyłączania filtrów IP jądra poprzez
 iptables(8).
 
+%package ebtables
+Summary:       Ethernet Bridge Tables - xtables compatibility wrapper
+Summary(pl.UTF-8):     Ethernet Bridge Tables – nakładka kompatybilności na xtables
+Group:         Networking/Admin
+Requires(post,preun):  /sbin/chkconfig
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      %{name}
+Requires:      rc-scripts >= 0.4.3.0
+Requires:      systemd-units >= 38
+# do not 'provide' something this is not really compatible with
+#Provides:     ebtables
+Obsoletes:     ebtables
+%{?with_vserver:Provides:      ebtables = %{version}-%{release}}
+
+%description ebtables
+ebtables is a tool for managing Linux 2.5.x (and above) Link Layer firewalling
+subsystem.
+
+This package contains a compatibility wrapper over xtables providing some
+functionality of the original ebtables tool.
+
+Note: this is not really a fully-compatible drop-in replacement!
+
 %prep
 %setup -q -n iptables-%{version} -a1
 %patch0 -p1
@@ -209,6 +236,7 @@ iptables(8).
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %{?with_ipt_IPV4OPTSSTRIP:%patch10 -p1}
 %{?with_xt_layer7:%patch11 -p1}
@@ -272,9 +300,10 @@ install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/sysconfig/%{name6}-config
 install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/%{orgname}.service
 install -p %{SOURCE9} $RPM_BUILD_ROOT%{systemdunitdir}/%{name6}.service
 
-install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/ebtables
-install -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/ebtables-config
-install -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/ebtables.service
+# these won't work as they are now
+#install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/ebtables
+#install -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/ebtables-config
+#install -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/ebtables.service
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -283,18 +312,16 @@ rm -rf $RPM_BUILD_ROOT
 %postun        libs -p /sbin/ldconfig
 
 %post init
-/sbin/chkconfig --add ebtables
 /sbin/chkconfig --add %{orgname}
 /sbin/chkconfig --add %{name6}
-%systemd_post %{orgname}.service %{name6}.service ebtables.service
+%systemd_post %{orgname}.service %{name6}.service
 
 %preun init
 if [ "$1" = "0" ]; then
-       /sbin/chkconfig --del ebtables
        /sbin/chkconfig --del %{orgname}
        /sbin/chkconfig --del %{name6}
 fi
-%systemd_preun %{orgname}.service %{name6}.service ebtables.service
+%systemd_preun %{orgname}.service %{name6}.service
 
 %postun init
 %systemd_reload
@@ -302,15 +329,11 @@ fi
 %triggerpostun init -- %{orgname}-init < 1.4.13-2
 %systemd_trigger %{orgname}.service %{name6}.service
 
-%triggerpostun init -- %{orgname}-init < 1.6.0-1
-%systemd_trigger ebtables.service
-
 %files
 %defattr(644,root,root,755)
 %{?with_doc:%doc iptables-howtos/{NAT,networking-concepts,packet-filtering}-HOWTO*}
 %attr(755,root,root) %{_bindir}/iptables-xml
 %attr(755,root,root) %{_sbindir}/arptables
-%attr(755,root,root) %{_sbindir}/ebtables
 %attr(755,root,root) %{_sbindir}/iptables
 %attr(755,root,root) %{_sbindir}/iptables-restore
 %attr(755,root,root) %{_sbindir}/iptables-save
@@ -521,12 +544,13 @@ fi
 
 %files init
 %defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ebtables-config
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{orgname}-config
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name6}-config
-%attr(754,root,root) /etc/rc.d/init.d/ebtables
 %attr(754,root,root) /etc/rc.d/init.d/iptables
 %attr(754,root,root) /etc/rc.d/init.d/ip6tables
-%{systemdunitdir}/ebtables.service
 %{systemdunitdir}/%{orgname}.service
 %{systemdunitdir}/%{name6}.service
+
+%files ebtables
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_sbindir}/ebtables
This page took 0.073148 seconds and 4 git commands to generate.